[Stable Update] 2019-12-29 - Kernels, KDE Apps 19.12, Xorg-Stack, Mesa, Qt5

A little late to the party but the update went fine. Suffering from the Latte bug some others mentioned, but it seems like it was fixed upstream a few days ago so no worries there.

I had to install the 8168 driver to get my Realtek wifi card working with kernel 5.4 as the baked in 8169 driver doesn't appear to be working anymore (no issues on 4.19 or 5.3). Other than that, nothing to report, many thanks to the team for another smooth update.

Just noticed
when i open a session on vitualbox i'm getting an error message

Failed to open a session for the virtual machine Windows Xp.

VT-x is not available (VERR_VMX_NO_VMX).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

i think last update was break something. but update went smooth without any errors
what to do now ?
p.s i'm new to manjaro

Have you recently updated your bios or reset it / made changes? That error message is typically when the VT-x has been disabled in your computers bios. Take a look at your bios and make sure that VT-X is enabled.

1 Like

Hi! I have an issue with wps-presentation. I'm not sure is it wps issue or dependency package issue.
--Open wps- office presentation (or command line with wpp)
--Press new document button
--wps freeze and cpu usage peak suddenly (note: other wps-office products works fine) There is no problem with open pptx file in file manager already made. I have latest wps-office release. This issue appeared after last update.
My system is: 4.19.91-1-MANJARO #x86_64 GNU/Linux Xfce Desktop. Is there anyone can confirm my issue and then I can sure this issue related my system or related with wps itself. Thanks!

After this update Calibre is experiencing problems when I try to use Metadata Editor. I get this error:

calibre 4.6  embedded-python: False is64bit: True
Linux-5.4.6-2-MANJARO-x86_64-with-glibc2.2.5 Linux ('64bit', 'ELF')
('Linux', '5.4.6-2-MANJARO', '#1 SMP PREEMPT Tue Dec 24 15:55:20 UTC 2019')
Python 2.7.17
Linux: ('', '', '')
Interface language: None
Successfully initialized third party plugins: DeDRM (6, 6, 3) && Inept Epub DeDRM (0, 1, 7) && djvumaker (1, 0, 2) && Annotations (1, 11, 0) && Modify ePub (1, 4, 0)
Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/gui2/widgets.py", line 522, in event
    ev.key() in (Qt.Key_Left, Qt.Key_Right) and (ev.modifiers() & ~Qt.KeypadModifier) == Qt.ControlModifier):
AttributeError: 'QResizeEvent' object has no attribute 'key'

I suspect it's related to the recent changes in python-pyqt5 and pyqt5-common that Calibre was built against.
Fix: I downloaded and installed the official Calibre package from their website and it works normally:

sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin
1 Like

A post was split to a new topic: System errors during update in TTY

@Isaacson thank you for this!
I think I updated QGIS to 3.10... not point-one. So, I don't know if this will impact me, but I will watch for things.
I did the last update and did do the recommended removal of the conflicting stuff. So far, I have seen no indication of a problem. Did it fail completely?
Please PM me, as I cannot figure out how to send you a PM only. Thanx!

The problem is (possibly) to do with the Qt update and you can't avoid that on its own because so many other things rely on it. I tried and couldn't even get beyond loading SDDM. I'll PM you the details, but if you've not yet done the update which has Qt 5.14 (the OP update), I wouldn't update anything yet, it might make Qgis non-functional for you. I should stress that the link between Qt 5.14 and Qgis problems is only theoretical, I haven't been able to test it or find anyone who can.

I have updated (before seeing your post) and have not come upon any issue with expressions (except with a specific plugin that was already failing before the update).
I have not tried sql one, just qgis ones so far.
Cheers,

I'd appreciate if you would take the time to see if you can replicate.

  1. Just to check - Qgis 3.10.1-1 and Qt all at 5.14.0-1
  2. Open Qgis. On any layer open 'Properties', 'Field Manager', then 'Field Calculator'.
  3. In the 'Expression' box, type a very long string like "jdhfhdkjahfjkhkjgfhjhgfahgf"

I get the image below. There are no spaces after the text string, that's just where the cursor ends up, miles away from the actual typing. If I place the cursor somewhere in the text string and hit backspace, it deletes some characters from five or six spaces back.

image

So the application kinda works but not as expected in functionality of usage.

I had a problem like that in konsole some time ago. Changing fonts solved it.

As I already reported, I didn't encountered any issue when I applied this update: everything goes OK.
After some days, while checking the leftovers (pacman -Qdtq) , xorgproto-transfer (a meta-package) was reported as leftover and I remove it.
I guess that was necessary just for properly do this update (as alternative to the Arch suggestion), am I right? I didn't noticed any issue on the system, or maybe xorgproto-transfer will be necessary again in the future and I need to reinstall it?

No problems (KDE in terminal).

Yeah, that's right. The idea that it might be Qt related was suggested to me by one of the Qgis team, only because the text boxes affected are all Qt objects and Qgis 3.10 is built against Qt 5.13, not 5.14 as in the latest update.

It's still possible that it's totally unrelated, I haven't been able to test it (can't downgrade Qt now - too complicated)

Thanks for the suggestion, not sure how to change fonts within the Qt boxes, but I'll look into it.

Reproducible in KDE. In XFCE it looks ok though.

https://manjaro.moson.eu/custom/qgis_kde.mp4

https://manjaro.moson.eu/custom/qgis_xfce.mp4

So it is related to KDE rather than qt5 i guess :man_shrugging:
Probably some font thing as @mparillo said.

New patch released for breakages on Intel e1000e based Ethernet adapters.

https://bugs.archlinux.org/task/64018

Should be fixed by this patch released Jan. 5, 2020:

https://patchwork.ozlabs.org/patch/1217709/

1 Like

That's interesting. I've only found it on Qgis, and only on Qt boxes, so something between Qgis and the way KDE handles Qt??

I've tried every font group available as Qgis system font as @mparillo suggested, but the problem persists despite font changes. I've also tried changing the default font in system settings to no effect.

If there's a default font for Qt, that might do something, but I can't find any such setting.

Duplicated here too.
Couldn't capture cursor but it appeared about where yours is in last line.
I faked the position...
image

Forum kindly sponsored by