[Stable Update] 2019-12-29 - Kernels, KDE Apps 19.12, Xorg-Stack, Mesa, Qt5

Everything good here on Openbox, Thank You! :heart:

1 Like

QT update broke my system settings. Screenshot_20191229_093936

It's a lie. We stayed on NetworkManager 1.20.X for now. :slight_smile:

nm120x

(Unless it has suddenly changed? :thinking: )

1 Like

Same issue here too. Need some advice on how to proceed.

Alex

I had to update via Pamac because on the terminal it said it cannot resolve conflicts but then everything went fine, at least seems for now. I'll report if something is not ok after some day of normal use.

I also had the pyqt5 conflict. Quick search on the forum => no problem actually. I verified that no other package depends on python-pyqt5 (only some optional dependencies), then removed it and then the whole update went good. Info: I do updates on the tty only; kernel 419, XFCFE.

1 Like

Excellent. Thank you for your quick response.

Alex

I had conflict with pyqt5-common and one more python package, I just clicked remove y/N yes on both and upgrade went ok. No issue found, yet.
I do upgrade from TTY, always.

1 Like

Latte Dock and Event Calendar having issues, Latte is not responding after widget customization and event calendar is giving error. ( Error loading QML file ) Other than that no problem so far

1 Like

Updated through TTY. Apart from the pyqt5-common conflict no further issues.

Alex

Looks like a copypaste from Testing thread :slight_smile:
That version works for me, however.

warning: libnm: local (1.22.2-1) is newer than extra (1.20.9dev+19+gcbb1ad1ba-1)
...
warning: networkmanager: local (1.22.2-1) is newer than extra (1.20.9dev+19+gcbb1ad1ba-1)

Please see this thread:

1 Like

This is what I've got:

error: failed to commit transaction (conflicting files)
kdeconnect: /usr/share/contractor/kdeconnect.contract exists in filesystem (owned by indicator-kdeconnect)
Errors occurred, no packages were upgraded.

Because of that error I can't update anything. What can I do?

Absolute legend buddy, was running out of time until I needed to reboot but this helped massively! Cleanly updated now after removing a *.part file :smiley:

1 Like

There is still problem also with copy paste in spreadsheets apps like libre office/ms office 2010 in Gnome. Sometimes selected cells are copying sometimes not, even other times it copy bmp image of cell instead oof numbers/formulas.

1 Like

Transaction done successfully with no hiccups on Pamac GTK 9.2.0. Around 940 MB of packages got downloaded.

Thanks for this upgrade and happy 2020 in advance.

@Eleuth

Because of that error I can't update anything. What can I do?

uninstall "contractor" first.
Reboot and try update again.
second: if fail:
uninstall indicator-kdeconnect.
Try update again (sudo pacman -Syyu)

1 Like

Updated fine for Cinnamon/kernel 5.4/Intel video modesetting

I had to remove one barely used package I installed from AUR because it depended on the old Python packages that are being replaced.

Same error at dkms for xpadneo. Uninstalled this because I don’t use it anymore

Looked smooth (pacman in a konsole).

:: Replace libdmx with extra/xorgproto-transfer? [Y/n] 
resolving dependencies...
looking for conflicting packages...
:: python-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] y

After a re-boot, cleaned up some orphans and demotions

$ pacman -Qm
python-sip-pyqt5 4.19.19-3
xf86-input-keyboard 1.9.0-3
xf86-input-mouse 1.9.3-1


$ sudo pacman -Rsn $(pacman -Qqdt)
Packages (3) libxxf86dga-1.1.5-1.1  python-sip-pyqt5-4.19.19-3  xorgproto-transfer-2019.12-1

After a second re-boot, everything seems OK.

1 Like

Forum kindly sponsored by