[Stable Update] 2020-01-16 - Kernels, KDE, Xorg-Stack, Mesa, Qt5, Firefox, Mhwd

Hello community,

here is our first Stable Update for 2020! Tell us how 2019 was for you!

Manjaro ARM Team will be at #FOSDEM2020

Some feature-updates:

  • Most Kernel updates added fixes for some issues: Intel Graphics Driver issue, Marvell WiFi chip driver issue
  • Etcher got updated to 1.5.71
  • Latest Timeshift snapshot
  • KDE-Git packages got renewed
  • Xorg-Server got updated to 1.20.7
  • Plasma5 we updated to 5.17.5
  • KDE Frameworks are now at 5.66.0
  • KDE Apps are now at 19.12.1
  • Palemoon got updated to 28.8.1
  • Some packages got rebuild against poppler 0.84.0-1. Tell us if we missed some.
  • Mesa is now at 19.3.2
  • Updated some snap related packages
  • Pushed out some Packagekit, Cinnamon and Gnome related packages
  • Firefox is now at v72.0
  • Added the latest Firefox developer edition
  • Added some more Haskell updates/rebuilds
  • mhwd got initial Nvidia-Prime support for 440 and 435 driver series
  • The usual upstream fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 18.1.5 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels:

  • linux316 3.16.81
  • linux44 4.4.210
  • linux49 4.9.210
  • linux414 4.14.165
  • linux419 4.19.96
  • linux53 5.3.18 [EOL]
  • linux54 5.4.12
  • linux55 5.5-rc6
  • linux419-rt 4.19.94_rt38
  • linux54-rt 5.4.10_rt5

Package Changes (Tue Jan 14 14:25:43 CET 2020)

  • stable community x86_64: 1714 new and 1688 removed package(s)
  • stable core x86_64: 43 new and 42 removed package(s)
  • stable extra x86_64: 872 new and 959 removed package(s)
  • stable multilib x86_64: 29 new and 29 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

If the Floppy Driver returns errors on update-grub

Blacklist the Floppy Driver fd0 (if don't needed):

sudo rmmod floppy
echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf

Older issues

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

2 * Manjaro KDE: update went well.
1 * Manjaro XFCE: update went well.


Some of the archlinux keys are not valid: is this a problem?

Another smooth update on Gnome/ Nvidia 4.40.

Had a small issue with KDE right after upgrade - couldn't browse any files because of some kde5.io" or similar error (which was displayed in file manager), but restart solved it.


Small OT: would you consider including -DHAVE_DDCUTIL=On for KDE's powerdevil in next builds?
I explained here why, but i don't think it was the right sub where to post :confused:
It allows us KDE users to adjust external monitors' brightness


Point us to those keys. 20200108-1 is currently the latest version of archlinux-keyring.

Always reboot after updating kernel and/or core components before checking/searching for and reporting "issues".


please install kernel-alive to avoid those issues.


Intel cannot catch a break... https://www.phoronix.com/scan.php?page=article&item=intel-gen7-hit&num=1

1 Like

i am curently experiencing an issue when i wanna update. it says

could not satisfy dependencies:
installing x264 (3:0.159.r2991.1771b55-1) breaks dependency 'libx264.so=157-64' required by libquicktime

is there any solutions?

KDE update went well, thanks for the updates!
I still have linux54-rt installed but the error when using virtualbox in combination with nvidia is still present (does not boot) ...
so currently I can live with the standard kernel :wink:

update went well,thanks manjaro. but as others here in the forum i'm struggeling with problems with the realtek r8169 driver and the network. there were several threads because low speed connections and i'm struggeling with that too. i have no glue how and where to start searching for a solution.

1 Like

That is an AUR package. You should remove it if nothing depends on it

I'm using an up-to-date mirror: https://repo.ialab.dsu.edu/manjaro/

error: failed retrieving file 'linux54-5.4.12-1-x86_64.pkg.tar.zst' from repo.ialab.dsu.edu : 
warning: failed to retrieve some files
error: failed retrieving file 'linux54-headers-5.4.12-1-x86_64.pkg.tar.zst' from repo.ialab.dsu.edu : 
warning: failed to retrieve some files
error: failed retrieving file 'openvpn-2.4.8-4-x86_64.pkg.tar.zst' from repo.ialab.dsu.edu : 
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.


■■■■■■■ intel... I'm guessing 5.4 LTS got updated with that Intel HD graphic "fix" as well? I'm currently using HD 4000 on 3570K and according to Phoronix after update gpu is basically useless.
Should I just add kernel to ignore list? I'm so pissed right now -.-

smooth as silk on

BTW how DEEPin is your heart? I know this isn't the right thread but.....will we get updates from deepin v20 in the next months?

anyways ... again...probably not the best thread to ask this but is there a way to preserve custom systemd-boot boot entry .conf with custom kernel parameters from updating?

so new iso should release tonight?

I think the Deepin release was put on hiatus for an indeterminate time due to issues with it.

1 Like

Forum kindly sponsored by