[Stable Update] 2020-02-06 - Kernels, Calamares, LibreOffice, Nvidia, KDE-Git, Qt

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Older issues

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Hopefully not overpriced like their other offerings... besides that, amazing job Manjaro!

5 Likes

Not working here:

"error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-440xx-utils (440.59-1) breaks dependency 'nvidia-440xx-utils=440.44' required by linux53-nvidia-440xx"

It doesn't install anything.

Thx for reporting. Should be available shortly also for linux53 kernel. However, you might want to switch to another kernel series as we will drop that series with one of the next updates.

Please add a note that this is yet another bri.ck from the dead CPU vendor.

3 Likes

I had the same thing happening to me about the time you posted that.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-440xx-utils (440.59-1) breaks dependency 'nvidia-440xx-utils=440.44' required by linux53-nvidia-440xx"

This is now solved.
Look in the edit history if it ever crops up again

1 Like

Hello, I'm having issues since several previous updates. Detailed description here: Some recent update broke VLC open files from Samba share

In short again: after some update, I cannot open media files located on samba share (on my NAS) directly with VLC. Instead it shows me a notification from "kioexec" and tries to copy file locally before launch. I tried installing kio-fuse package, but it didn't help, only made worse: now no notification is shown by VLC is stuck until media file is silently (!) copied on local machine.

Some people on Reddit told me that it's a bug (?) and it has been fixed recently so it needs to be merged into Manjaro.

yolo!

Update went well, but after it I cannot run my poker game, OMG:

$ pokerth 
pokerth: error while loading shared libraries: libboost_thread.so.1.71.0: cannot open shared object file: No such file or directory

Any ideas?

it's an AUR package not compiled again since 2019. Contact the maintainer... Or if you did not get it from the AUR, remove the package you have and get it from there as the last comment was:

blacktav commented on 2019-10-29 17:52
Thanks to xx55tt we are back on the road
Release 11 requires latest boost

We had an update of boost. Seems you have to rebuild your application when you had installed it from the AUR.

Thanks that resolved the problem! :slight_smile:

I got a downgrade warning

$ pacman -Syyuuw  --noconfirm
...
...
:: Starting full system upgrade...
warning: ruby-domain_name: downgrading from version 1:0.5.20180417-1 to version 0.5.20190701-2
resolving dependencies...

Is it ok to go on?

EDIT
I suppose it is...
Seems version numbering has changed there?

Everything installed fine but wifi is still broken on 5.5 with 3168NGW wireless card.

1 Like

I've had that once too: just go ahead or it'll keep nagging you about it...

:wink:

Updated via terminal
Could not reboot through KDE
rebooted with $ sudo reboot
Back on track.

Any explanation for this (just for the sake of knowledge)?

1 Like

Using nvidia? fyi this also happens on winten.

Yep.

Could be that.

Cheers.

Hi all,
The package file-5.38-3 looks corrupted.
No way to upgrade it.

Hi,
Sorry. I had an issue with the pamac cache.
Regards,

I don't know why my LibreOffice still 6.3.4.2.0+, not the LO 6.4 version after update.

Forum kindly sponsored by