[Stable Update] 2020-02-10 - Kernels, KDE Apps, Gnome Settings

My steam games crashed after the latest mesa updates. Thanks for reverting them back!

Just a FYI for all i915 intel graphics users:

https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.5-Intel-Missed-Graphics

solved , my bad.

What do you mean by corrected?

So after 10 Minutes trying, either Lightdm stopped hanging up, or i was quick enough to log in via 3 seconds...
sudo pacman -Syyuu

solved this.

i got 33 kybte logfile of these

Feb 14 15:22:31  systemd-coredump[516]: Process 476 (Xorg) of user 0 dumped core.
                                          
                                          Stack trace of thread 476:
                                          #0  0x00007f536d105f25 raise (libc.so.6)
                                          #1  0x00007f536d0ef897 abort (libc.so.6)
                                          #2  0x000055c9167a5c5a OsAbort (Xorg)
                                          #3  0x000055c9167a94a1 FatalError (Xorg)
                                          #4  0x000055c9167accd2 n/a (Xorg)
                                          #5  0x00007f536d105fb0 __restore_rt (libc.so.6)
                                          #6  0x00007f536ad0b404 n/a (r600_dri.so)
                                          #7  0x00007f536ad1df16 n/a (r600_dri.so)
                                          #8  0x00007f536ad08e04 n/a (r600_dri.so)
                                          #9  0x00007f536ad09fa3 n/a (r600_dri.so)
                                          #10 0x00007f536a8ce4cd n/a (r600_dri.so)
                                          #11 0x00007f536d2ec72a call_init.part.0 (ld-linux-x86-64.so.2)
                                          #12 0x00007f536d2ec831 _dl_init (ld-linux-x86-64.so.2)
                                          #13 0x00007f536d2f0603 dl_open_worker (ld-linux-x86-64.so.2)
                                          #14 0x00007f536d203d79 _dl_catch_exception (libc.so.6)
                                          #15 0x00007f536d2efeee _dl_open (ld-linux-x86-64.so.2)
                                          #16 0x00007f536ced634c n/a (libdl.so.2)
                                          #17 0x00007f536d203d79 _dl_catch_exception (libc.so.6)
                                          #18 0x00007f536d203e13 _dl_catch_error (libc.so.6)
                                          #19 0x00007f536ced6ab9 n/a (libdl.so.2)
                                          #20 0x00007f536ced63da dlopen (libdl.so.2)
                                          #21 0x00007f536bf572d0 n/a (libgbm.so.1)
                                          #22 0x00007f536bf560a7 n/a (libgbm.so.1)
                                          #23 0x00007f536bf5653c n/a (libgbm.so.1)
                                          #24 0x00007f536bf541d9 gbm_create_device (libgbm.so.1)
                                          #25 0x00007f536bfccf86 n/a (radeon_drv.so)
                                          #26 0x00007f536bfbd2a4 n/a (radeon_drv.so)
                                          #27 0x000055c916799412 InitOutput (Xorg)
                                          #28 0x000055c91673b503 n/a (Xorg)
                                          #29 0x00007f536d0f1153 __libc_start_main (libc.so.6)
                                          #30 0x000055c91673c3be _start (Xorg)
-- Subject: Speicherabbild für Prozess 476 (@COREDUMP_COMM) generiert
-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- Documentation: man:core(5)
-- 
-- Prozess 476 (Xorg) ist abgebrochen worden und
-- ein Speicherabbild wurde generiert.
-- 
-- Üblicherweise ist dies ein Hinweis auf einen Programmfehler und sollte
-- als Fehler dem jeweiligen Hersteller gemeldet werden.
Feb 14 15:22:33  systemd-coredump[630]: Process 628 (Xorg) of user 0 dumped core.
                                          
                                          Stack trace of thread 628:
                                          #0  0x00007f812d6aef25 raise (libc.so.6)
                                          #1  0x00007f812d698897 abort (libc.so.6)
                                          #2  0x000055b65c2aec5a OsAbort (Xorg)
                                          #3  0x000055b65c2b24a1 FatalError (Xorg)
                                          #4  0x000055b65c2b5cd2 n/a (Xorg)
                                          #5  0x00007f812d6aefb0 __restore_rt (libc.so.6)
                                          #6  0x00007f812b2b4404 n/a (r600_dri.so)
                                          #7  0x00007f812b2c6f16 n/a (r600_dri.so)
                                          #8  0x00007f812b2b1e04 n/a (r600_dri.so)
                                          #9  0x00007f812b2b2fa3 n/a (r600_dri.so)
                                          #10 0x00007f812ae774cd n/a (r600_dri.so)
                                          #11 0x00007f812d89572a call_init.part.0 (ld-linux-x86-64.so.2)
                                          #12 0x00007f812d895831 _dl_init (ld-linux-x86-64.so.2)
                                          #13 0x00007f812d899603 dl_open_worker (ld-linux-x86-64.so.2)
                                          #14 0x00007f812d7acd79 _dl_catch_exception (libc.so.6)
                                          #15 0x00007f812d898eee _dl_open (ld-linux-x86-64.so.2)
                                          #16 0x00007f812d47f34c n/a (libdl.so.2)
                                          #17 0x00007f812d7acd79 _dl_catch_exception (libc.so.6)
                                          #18 0x00007f812d7ace13 _dl_catch_error (libc.so.6)
                                          #19 0x00007f812d47fab9 n/a (libdl.so.2)
                                          #20 0x00007f812d47f3da dlopen (libdl.so.2)
                                          #21 0x00007f812c5002d0 n/a (libgbm.so.1)
                                          #22 0x00007f812c4ff0a7 n/a (libgbm.so.1)
                                          #23 0x00007f812c4ff53c n/a (libgbm.so.1)
                                          #24 0x00007f812c4fd1d9 gbm_create_device (libgbm.so.1)
                                          #25 0x00007f812c575f86 n/a (radeon_drv.so)
                                          #26 0x00007f812c5662a4 n/a (radeon_drv.so)
                                          #27 0x000055b65c2a2412 InitOutput (Xorg)
                                          #28 0x000055b65c244503 n/a (Xorg)
                                          #29 0x00007f812d69a153 __libc_start_main (libc.so.6)
                                          #30 0x000055b65c2453be _start (Xorg)
-- Subject: Speicherabbild für Prozess 628 (@COREDUMP_COMM) generiert
-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- Documentation: man:core(5)
-- 
-- Prozess 628 (Xorg) ist abgebrochen worden und
-- ein Speicherabbild wurde generiert.
-- 
-- Üblicherweise ist dies ein Hinweis auf einen Programmfehler und sollte
-- als Fehler dem jeweiligen Hersteller gemeldet werden.


Sadly Mesa 19.3.4 had a regression in SWR, which is now fixed. Corrected packages got uploaded now.

4 Likes

Hi everyone, seem to have graphical session boot problem. I keep trying philms fix " sudo pacman -Syyuu"
But I keep getting " error invalid option ' -s' " in the TTY session interface repeatedly on every try.
I really do not know what to do. Any help would be appricated.

Thank you

My Manjaro system was broken yesterday 02-14-2020, very likely caused by this update.
The system booted not completely and the screen remaind black.
The only way to get a command prompt was adding a 3 at the end of the linux line after pressing e at the boot menu. Note that i was using the 4.4 Linux kernel. I use an AMD graphics adapter.
The command sudo pacman -Syyu did not help.
I have formatted only the / partition. Luckily i have a separate /home partition.
After re-installation and updating of Manjaro, i only needed to re-install a number of applications and some printer drivers. For my HP P1102W printer i needed to edit and patch hplip again.
Today (02-15-2020) the 19.3.4-0.2 stuff was offered again same as yesterday.
The updates contained at first only 5 packages, same as yesterday. About one hour later there were also lib32- packages added.
I use now kernel 5.4.18 LTS and applied the updates again holding my fingers crossed.
This time all went fine and the system rebooted.
I only wonder: What could have happened if i had applied only the first 5 updates (like i did yesterday), so without the lib32-mesa and lib 32-vulkan and lib32- libva updates?

Regards, gsm

mesa 19.3.4-0.1 broke systems, 19.3.4-0.2 fixes it ...

1 Like

Thanks for the explanation!
So yesterday it must have been 19.3.4-0.1 that broke my system.

XFCE, 5.4.18-1

Everything went smoothly! Thanks for all the hard work.

Thanks for the explanation, mesa 19.3.4-0.2 fixed my black screen
Keep up the good work.

I'm confused. I saw the news of the 2020-20-10 update right before I went away for a few days, and before I had a chance to apply it. I returned yesterday and checked this announcement for updates before proceeding. I saw this news about mesa 19.3.4, I ran pacman -Syu | grep 19.3.4 and no results. I applied the update with pacman -Syu and all went well. This morning pamac gui tells me that 19.3.4 is available, confirmed with pacman -Syu. Should I take this update or nor? I assumed it would have been puled since it was a mistake.
Thanks!

NM, I now see the other posts explaining about 19.3.4.1 vs 3.2.

I just pressed strg+alt+F3 as long as i could log in finally. Took me ~10 minutes..

What i do not understand, this should have broken the testing-branch before stable?

Hi there. Do you got some ideas on how can I get the fixed version quicker? It seems to me that servers close to me need to refresh.
Mesa broke 30m ago. So I don't expect it to be updated soon

Hi, I don't know, maybe update mirrors and pacman -Syyu that did the trick for me
mirrors I pick them by hand, I never refresh with command and always the closest ones to me.So I have the same mirrors always and as soon as stable update comes I am informed.Even if its one package.You can see the sync times of the mirrors on the page.

Edit -> when you visit the page go to all states section and click and choose up to date and you will see last sync, there you will see the times, the best are with the minimal hh:mm, then simply put the ones you like in pacman mirrors /etc/pacman.d/mirrorlist.

Edit 2 -> Example mirror: Server = https://manjaro.moson.eu/stable/$repo/$arch that's how I have it in may mirrorlist.This one is German and is alaways up to date.

Welcome to Manjaro. You can downgrade all mesa-packages manually to previous version if the mirror of your choice doesn't yet serve the fixed versions.

Are you still having this issue?
Make sure you're typing -S (capital), and not -s (lowercase) for the start of -Syyuu

Hello. This morning (February 18th) there was an update and now my usb-dac does not work. I have to power it off and on again, then it starts working for a couple of seconds and then it stops again. If there is some sound playing, for instance a video, then I can power off and on and I will have sound until the video ends, where my usb dac stops again. I tried plugging in a usb drive and it seems to work fine. Any ideas?

The packages that got updated where the following,

[2020-02-18T09:32:02+0200] [ALPM] upgraded linux-latest (5.4-1 -> 5.5-1)
[2020-02-18T09:32:02+0200] [ALPM] upgraded linux-latest-nvidia-430xx (5.4-1 -> 5.5-1)
[2020-02-18T09:32:02+0200] [ALPM] upgraded linux-latest-virtualbox-host-modules (5.4-1 -> 5.5-1)
[2020-02-18T09:32:02+0200] [ALPM] upgraded tlp (1.2.2-1.1 -> 1.3.1-2)

I suspect tlp because it puts the card to suspend if there is no audio. I have an opened vlc window that plays a file, although I have the volume on 0% and that keeps my card working for now. In /var/cache/pacman/pkg/ I cannot find the previous version.

Forum kindly sponsored by