[Stable Update] 2020-02-15 - Firefox 73.0

I'm still experiencing an issue with virt-manager not connecting to remote hosts via ssh:

everything works, cinnamon stable. thanks

The update of Firefox went fine without problems.

Doing fine on Cinnamon minimal as well, thanks!

ManjaroLinux 19.0.0
Firefox 73
All's well ... Thanks!

Audio problem.

After the previous update - and now after this is am experiencing audio as if has been recorded with a hydrophone with the source several fathoms below.

On the previous occasion I thought I'd solved the problem with

systemctl --user restart pulseaudio

On this occasion this is not working.

Reboot also take a the full stop job allocation

stop job is running for Session 1 of user ... 1min 30

I suspect they are connected - is there some process running that isn't stopping?

Thanks
(edit) - within the system settings when I test audio (click front left/front right) there is no audio distortion.
(edit) - thought it might be browser problem. Downloaded audio file played through VLC with same distortion.
(edit) -

Solved audio problem
Still have stop job issue

Gaston LaGaffe, I presume?

M'enfin

Absolutely, Gaston LaGaffe (Guust Flater), epic! Nou moe?! :grinning:

This upset my Firefox: most pages look ugly. I believe it's not showing any background images anymore. Screenshot below. (And the same when in "Safe Mode" = menu Help > Restart with Add-Ons disabled). All my other Manjaro applications are OK. But for example, even "Reply" button on this Manjaro forum page doesn't show up in Firefox - I'm writing this in Chrome.

GNOME
5.4.18-1-MANJARO #1 SMP PREEMPT Thu Feb 6 11:41:30 UTC 2020 x86_64 GNU/Linux

image

Second: Is this some kind of non-standard version? Why am I asking? In the messed-up version of Firefox, I got the name of my profile (as I have several) from about:support. Then I've downloaded a Firefox binary from https://ftp.mozilla.org/pub/firefox/releases/73.0/linux-x86_64/en-US/ > https://ftp.mozilla.org/pub/firefox/releases/73.0/linux-x86_64/en-US/firefox-73.0.tar.bz2. But, when I start that downloaded FF binary (with the same profile), it says that it can't use that profile because it was used with a newer version of Firefox!

So I believe this Manjaro's "73.0" is not the same as 73.0 at FF download page above:
image

Manjaro's FF "73.0" Build ID is 20200215171151:
image

However, Build ID of Firefox "73.0" from the official Firefox website above is older: 20200207195153:
(Side note: Since I couldn't open my profile in the official Firefox, as described above, I opened a different profile to get the following screenshot):
image

Please, could you revisit your process, so the build always matches the one on Mozilla download page. Otherwise it's not replicable and inconsistent.

1 Like

The problem is not with the specific Manjaro's 73.0 version of Firefox. I've downloaded 73.0.1 from https://ftp.mozilla.org/pub/firefox/releases/73.0.1/linux-x86_64/en-US, and it has the same problem.

When I updated my Firefox less than 2 hours ago, there were also some library updates (but I don't remember which ones). Then I rebooted.

I didn't use Pacman, but I used "Software Update" (same as "Add/Remove Software"). How do I get the list of what it updated the last time, so I can report it here?

Also, how do I get the numbers of previous versions of those libraries affected by my last "Software Update", and how do I roll them back (with Pacman), please?

Inspect var/log/pacman.log to see which libraries were updated when and their previous version.

2 Likes

Off topic

A well meaning accident to happen :laughing: - known in Denmark as Vakse Viggo with Kvik as his perplectic collegue.

1 Like

That is a common issue with the build-id. As soon as we have a newer build than Arch or Upstream those issues may occur. Currently starting to build 70.0.1:

I've already passed a solution upstream to Arch. They have thus far ignored it.

The solution was previously implemented in the Manjaro overlay packaging files but has since been force-pushed over the top of and deleted.

6 Likes

OMZ. Who was that masked man? All he left was a silver... 32-bit compiler. :wink:

5 Likes

Thank you @jonathon and @Freggel.doe.

I've rolled back (upgraded to the previous versions) all the libraries involved in my last update (the log and my rollback commands are below; "Software Update" shows them now as being at the older versions that I downgraded them to). However, that didn't help - still having the same problem: no pages are showing background images. I've created a new Firefox profile (firefox -P), but it has the same problem.

However, I didn't undo any pre-upgrade and post-upgrade hooks (at least not manually) - would they be undone automatically by Pacman when I upgraded the libraries to the previous versions? How can I see what was done by the following, and is there any way to undo them (other than manually)?
firefox-pre.hook
30-systemd-update.hook
firefox-post.hook
glib-compile-schemas.hook
gtk-update-icon-cache.hook
update-desktop-database.hook

Pacman log of the troublesome upgrade, and my actions so far:
[2020-02-17 14:22] [PAMAC] synchronizing package lists
[2020-02-17T14:23:35-0800] [ALPM] running 'firefox-pre.hook'...
[2020-02-17T14:23:35-0800] [ALPM] transaction started
[2020-02-17T14:23:35-0800] [ALPM] upgraded mesa (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:35-0800] [ALPM] upgraded firefox (72.0.2-1 -> 73.0-0.1)
[2020-02-17T14:23:36-0800] [ALPM] upgraded gnome-control-center (3.34.4-0.1 -> 3.34.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded lib32-mesa (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded lib32-mesa-vdpau (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded lib32-vulkan-intel (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded lib32-vulkan-radeon (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded libva-mesa-driver (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded manjaro-hello (0.6.4-2 -> 0.6.5-2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded manjaro-printer (20200126-1 -> 20200215-2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded mesa-vdpau (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded vulkan-intel (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] upgraded vulkan-radeon (19.3.4-0.1 -> 19.3.4-0.2)
[2020-02-17T14:23:36-0800] [ALPM] transaction completed
[2020-02-17T14:23:36-0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-17T14:23:36-0800] [ALPM] running 'firefox-post.hook'...
[2020-02-17T14:23:36-0800] [ALPM] running 'glib-compile-schemas.hook'...
[2020-02-17T14:23:37-0800] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-02-17T14:23:37-0800] [ALPM] running 'update-desktop-database.hook'..

Then I've downgraded all the above libraries:

pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/libva-mesa-driver-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/mesa-vdpau-19.3.4-0.2-x86_64.pkg.tar.zst
pacman -U /var/cache/pacman/pkg/vulkan-intel-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/vulkan-radeon-19.3.4-0.1-x86_64.pkg.tar.zst
pacman -U /var/cache/pacman/pkg/lib32-mesa-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/lib32-mesa-vdpau-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/lib32-vulkan-intel-19.3.4-0.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/lib32-vulkan-radeon-19.3.4-0.1-x86_64.pkg.tar.zst
pacman -U /var/cache/pacman/pkg/manjaro-hello-0.6.4-2-any.pkg.tar.zst /var/cache/pacman/pkg/manjaro-printer-20200126-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/gnome-control-center-3.34.4-0.1-x86_64.pkg.tar.zst

Please advise (without my need for a mini-PhD in Pacman or Linux libraries).

2 Likes

@Jonathon Negative: the issue is not with my extensions/config. As I wrote above, I've created a brand new Firefox profile (with no extensions, no "Firefox Sync" etc.), but it has the same problem.

1 Like

Again: How do I see actions taken by update pre-transaction and post-transaction hooks as reported in Pacman log? And is there any (semi-)automated way to undo effect of those hooks, please?

For my Pacman log and my undo actions see [Stable Update] 2020-02-15 - Firefox 73.0 (post # 20).

Forum kindly sponsored by