[Stable Update] 2020-02-18 - Firefox 73.0.1

Hello community,

here is another Stable Update.

firefox-header

Mozilla Firefox 73 itself is a modest bug-fix update that continues to pump the vein of change Firefox 72 laid out, i.e. iterative improvements rather than headline features. For this release Mozilla has delivered two substantial improvements to accessibility, the features designed to help make navigating the web easier for people who need it:

  • Fixed crashes on Windows systems running third-party security software such as 0patch or G DATA (bug 1610790)
  • Fixed loss of browser functionality in certain circumstances such as running in Windows compatibility mode or having custom anti-exploit settings (bug 1614885)
  • Resolved problems connecting to the RBC Royal Bank website (bug 1613943)
  • Fixed Firefox unexpectedly exiting when leaving Print Preview mode (bug 1611133)
  • Fixed crashes when playing encrypted content on some Linux systems (bug 1614535)

More information in the release notes.

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.81
  • linux44 4.4.213
  • linux49 4.9.213
  • linux414 4.14.170
  • linux419 4.19.102
  • linux53 5.3.18 [EOL]
  • linux54 5.4.18
  • linux55 5.5.2
  • linux419-rt 4.19.94_rt39
  • linux54-rt 5.4.10_rt5

Package Changes (Sat Feb 15 20:19:45 CET 2020)

  • stable extra x86_64: 97 new and 0 removed package(s)

A detailed list of all packages changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

(2020-02-14) Can't boot into a graphical session anymore

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.


Older issues

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Testing still seems to have Firefox 73.0.

1 Like

XFCE, 5.5.2-1

Everything went smoothly! Thanks for all the hard work.

Smooth update without any issues on Gnome, 5.4 kernel, nvidia 440 series drivers. Thanks to the team for a smooth update as usual.

1 Like

Okay, not to nitpick here but I wouldn't say this is a very relevant note for us...

Otherwise no problems with any of the upgrades recently, good work!

1 Like

The new version of Firefox works without issues.

Thanks!

1 Like

Screenshot_20200219_093240
Hi,
I also got nvidia drivers update alongside firefox, which installed kernel 5.5 and somehow broken booting with kernel 5.4. System booted fine with kernel 5.5, but vmware workstation doesn't work with that one so I have to stick with 5.4 for now. Trying to boot with kernel 5.4 resulted in a halt during boot which prompted for root password or press ctrl+d. I couldn't do either because keyboard wasn't responding. So I had to do a timeshift restore, which fortunately worked just fine.
I'm sorry, but I don't have time to investigate this issue further.

1 Like

Welcome to Manjaro.

Check if linux-latest package is installed. If it is: this would have triggered the installation/usage of linux55 kernel.
If you do want to stay on linux54: install linux-latest-lts and remove linux-latest.

Firefox constantly crashes on tabs. Crash report below.

https://crash-stats.mozilla.org/report/index/bp-c4e8f03f-dd82-4d37-8fd1-d63080200219

Reinstalling the Firefox worked actually. While reinstalling, it complained about Firefox 73 package was broken. That was from my side.

Oh, that seems to be it. I didn't have linux-latest installed, but I had linux-latest-nvidia-440xx. I removed it, just in case. Thanks.

I'm still experiencing an issue with virt-manager not connecting to remote hosts via ssh:

After installing the last 3 stable updates (I was away in vacation for like a week) plasma has been broken on my system. The window titlebar and controls are missing window switching doesn't work composting is broken widgets are broken. Reverting to a backup before the update works perfectly but once I update everything is broken.

Please try kde 19.0-rc2 ISO, which includes this update. See if a fresh ISO might boot on your system. Also open a new thread and list which packages might get installed on your system including your system details to narrow down your problem. Great to hear that you have a working backup system established at your end.

Pamac was unable to update google-chrome

This happened on my Xfce Laptop which I had not updated for about 2 weeks (last was the 2020-02-10 manjaro update)

I just ran the latest Manjaro Stable 2020-02-20 update (non-aur) via terminal (via -Syyu) and rebooted and then got a pamac notification to update my aur stuff, which I tried to do, but Pamac threw the following error:

Building google-chrome...
==> ERROR: install file (google-chrome.install) does not exist or is not a regular file.

Oddly, I was able to update using via the terminal
$ yay -Syyu

:: 1 Packages to upgrade.
[...]
1 aur/google-chrome 80.0.3987.87-1 -> 80.0.3987.116-1

Not a big problem, but just curious if anyone knows why?

thanks philm, yeah I figured out the problem I was updating kwin-low latency to 5.18 while the rest of kde was at 5.17. after going back to my backup and ignoring the kwin update and updateing the rest of the system everything worked :sweat_smile: guees I will leave kwin ignored until manjaro stable get 5.18 which would probaly be when 19.0 releases right?

So 73 brought global zoom which would be pretty nice on my 14" screen. I set 120% in the settings but it doesn't apply the default zoom on any site. Does anyone know what the problem might be?
I have to click on the '100%' text in the url bar for the zoom to actually apply.. Is this to be expected?

Not sure either of these issues is going to be fixed by an update to Firefox?

Also, google-chrome is an AUR package.

I use a system theme called Adapta-Nokto-Eta-Maia then use Adapta-Eta-Maia in widget.content.gtk-theme-override. The theme used in gtk-theme-override is a light theme so the textboxes must be white but they're not, it is still dark.

Forum kindly sponsored by