[Stable Update] 2020-02-28 - Kernels, Mesa, LibreOffice, Pamac 9.4-rc, Blender 2.82, NetworkManager

Hello community,

we are happy that our Manjaro Kyria release was such a success so far. Our team worked hard to achieve this. Now we are proud to present our first update for Kyria, with lots of goodies for you.

Get a sneak-peak on our KDE-Dev ISO on how Manjaro 20.0 might look like ...

Some feature-updates:

  • Most of our Kernels got updated
  • We updated our RT-Kernel to 5.4.17_rt9 and added linux56 series
  • linux53 is now deprecated. Users will automatically update to linux54
  • More Updates to KDE-Git packages
  • Firefox-Dev is on its sixth beta of 74 series
  • We updated to Mesa 19.3.4
  • Pamac 9.4 has its first release candidate. We still need translation updates!
  • Blender is now at 2.82
  • Gnome got some more updates
  • Additional packages for Cinnamon
  • Updates to our Calamares installer
  • Fixes to binutils to support linux316 and linux44
  • Wine got updated to 5.2
  • LibreOffice got updated to 6.3.5
  • VirtualBox 6.1.4 added some needed fixes
  • PHP is now at 7.4.3
  • Palemoon got renewed to 28.8.3
  • NetworkManager is now at 1.22.8
  • A lot of python and haskell updates
  • Flatpak got updated to 1.6.2
  • polkit and other small updates
  • Haskell and Python updates with regular upstream package changes got added

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.214
  • linux49 4.9.214
  • linux414 4.14.171
  • linux419 4.19.106
  • linux54 5.4.22
  • linux55 5.5.6
  • linux56 5.6-rc3
  • linux419-rt 4.19.103_rt42
  • linux54-rt 5.4.19_rt11

Package Changes (Tue Feb 25 08:06:49 CET 2020)

  • stable community x86_64: 1756 new and 1768 removed package(s)
  • stable core x86_64: 57 new and 56 removed package(s)
  • stable extra x86_64: 687 new and 857 removed package(s)
  • stable multilib x86_64: 34 new and 36 removed package(s)

A detailed package change can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

(2020-02-14) Can't boot into a graphical session anymore

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.

Older issues

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here


Shame that no Plasma 5.18 even after its second release, but thank you so much Manjaro for providing such an amazing distro! You are the perfect distro for many people, incredibly stable and also very up to date!


Why was linux53 deprecated?

Because it's EOL (End Of Life). See https://www.kernel.org/category/faq.html

1 Like

Thanks, I couldn't find much on it. Kernel release is going so quickly; I didn't expect something I was using to reach EOL already.

Hey, so strange thing, just did the update and now it seems like my DNS is a bit wonky? I changed my DNS for the connection to instead of, and now it works better but going to any page seems to take forever. Using and also produce similar results. Any help would be appreciated!

inxi -Fxxxza --no-host
System:    Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=2916bb67-a9e8-4d4e-96eb-18dbede3917a rw quiet apparmor=1 
           security=apparmor resume=UUID=91510309-5ad8-4b57-bcce-46c26d171a9d udev.log_priority=3 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G7 7588 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: N/A serial: <filter> UEFI: Dell v: 1.8.0 date: 12/21/2018 
Battery:   ID-1: BAT0 charge: 24.8 Wh condition: 39.5/56.0 Wh (71%) volts: 16.4/15.2 model: Samsung SDI DELL W7NKD8B 
           type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: CA L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 901 2: 900 3: 900 4: 900 5: 901 6: 900 7: 901 8: 900 
           9: 900 10: 900 11: 900 12: 900 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Dell driver: nvidia v: 440.59 bus ID: 01:00.0 
           chip ID: 10de:1c20 
           Display: x11 server: X.Org 1.20.7 driver: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
           Sound Server: ALSA v: k5.4.22-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell driver: alx v: kernel port: 3000 
           bus ID: 3c:00.0 chip ID: 1969:e0a1 
           IF: enp60s0 state: down mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 430.65 GiB (41.0%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC501 NVMe 128GB size: 119.24 GiB block size: physical: 512 B 
           logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 80001C00 scheme: GPT 
           ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: GPT 
Partition: ID-1: / raw size: 95.32 GiB size: 93.32 GiB (97.91%) used: 28.77 GiB (30.8%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: /home raw size: 931.51 GiB size: 915.89 GiB (98.32%) used: 401.88 GiB (43.9%) fs: ext4 dev: /dev/dm-0 
           ID-3: swap-1 size: 9.31 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 313 Uptime: 35m Memory: 15.34 GiB used: 3.97 GiB (25.9%) Init: systemd v: 242 Compilers: gcc: 9.2.1 
           clang: 9.0.1 Shell: bash v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37 

EDIT: It seems to be fixed now? Not exactly sure what was going on but I'll post an update if anything changes.

Updated without problems, thanks manjaro team.

1 Like

I am having trouble with pip after install.

 akya@quady ~ sudo pip list          
Traceback (most recent call last):
  File "/usr/bin/pip", line 11, in <module>
    load_entry_point('pip==19.3.1', 'console_scripts', 'pip')()
  File "/usr/lib/python3.8/site-packages/pip/_internal/main.py", line 45, in main
    command = create_command(cmd_name, isolated=("--isolated" in cmd_args))
  File "/usr/lib/python3.8/site-packages/pip/_internal/commands/__init__.py", line 96, in create_command
    module = importlib.import_module(module_path)
  File "/usr/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/lib/python3.8/site-packages/pip/_internal/commands/list.py", line 13, in <module>
    from pip._internal.cli.req_command import IndexGroupCommand
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/req_command.py", line 17, in <module>
    from pip._internal.index import PackageFinder
ImportError: cannot import name 'PackageFinder' from 'pip._internal.index' (/usr/lib/python3.8/site-packages/pip/_internal/index/__init__.py)

Yes I know I have in past used sudo for pip and I am going to remove the ones installed by pip and install from repos. But cant do anything atm.

Edit: Was solved by this - curl https://bootstrap.pypa.io/get-pip.py | sudo python3

Can someone tell me how to find packages installed by pip and replace them with ones from repo?

Just updated cinnamon stable version, all is good, no problems. nicely done. Thanks again.

I'm still experiencing an issue with virt-manager not connecting to remote hosts via ssh:

Thank you for the update. My usb mouse stopped working after the update. It is a Roccat brand mouse which never created problem before. Unfortunately, I don't have the expertise to be able to post outputs of lsusb or other commands that I would think may be helpful without a functioning mouse. I will try to boot with the previous kernel and see if it would help.

UPDATE: I was able to get the mouse working again after booting into 4.19.106-1, and the lsusb command output is as follows:

Bus 001 Device 005: ID 1e7d:2e22 ROCCAT ROCCAT Kone XTD

This option was not listed in previous boot for sure. I guess the new kernel did not recognize my mouse. However, I confirm that there was no such problem with the prior 5.4 kernel. Any pointers will be greatly appreciated.


A buttery smooth update on manjaro KDE as expected, we're getting spoiled.


No issues to report. Excellent work as always team Manjaro!



I have this error trying to update.

error: failed to commit transaction (conflicting files)
python-setuptools: /usr/lib/python3.8/site-packages/pkg_resources/pycache/py2_warn.cpython-38.pyc exists in filesystem
python-setuptools: /usr/lib/python3.8/site-packages/pkg_resources/py2_warn.py exists in filesystem
Errors occurred, no packages were upgraded.

I try this solution: sudo pacman -R python-pip

And the message that I have after executing it is the following:
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python-pip breaks dependency 'python-pip' required by overgrive
:: removing python-pip breaks dependency 'python-pip' required by python-reportlab

I use the program Overgrive for sync with Google Drive and I do not want to miss Overgrive.
So, is there any solution to upgrade but keeping Overgrive?

SOLUTION: The solution in my case was to execute pacman in this way:

sudo pacman -Syu --overwrite /usr/lib/python3.8/site-packages/pkg_resources/py2_warn.py --overwrite /usr/lib/python3.8/site-packages/pkg_resources/pycache/py2_warn.cpython-38.pyc --overwrite /usr/lib/python3.8/site-packages/pkg_resources/pycache/py2_warn.cpython-38.pyc

Thanks a lot @freggel.doe for your answer!!!

Thanks a lot!

1 Like

Never had any issues. Going on a year and a half, and still rock solid!

Does KDE 5.18 still have issues, or something?


You seem to have used sudo pip ..

You could just overwrite those existing files

$ sudo pacman -Syu --overwrite /usr/lib/python3.8/site-packages/pkg_resources/py2_warn.py --overwrite /usr/lib/python3.8/site-packages/pkg_resources/pycache/py2_warn.cpython-38.pyc
1 Like

I read about the sudo pip. I really do not remember to had done it. Could it be related to the installation of Overgrive?
But, the most important question, doing this won't affect Overgrive, right?
Thanks a lot!

Any Updates for hp Kaby Lake laptop's users no microphone sounds... hope u reply to me iam coming from the grim reaper windows 10 which i hate
.. please help

Was this update pushed faster thanks to stable-staging? And is this update also for manjaro kde stable?

Forum kindly sponsored by