[Stable Update] 2020-03-14 - Kernels, Plasma 5.18.3, KDE Frameworks 5.67, KDE Apps 19.12.3, Firefox, Kodi

I have the same issue with kwallet and password at login.
Specifically the application kde5 requires password after each login.
Unfortunately leaving the field blank does not help me.

So what were the exact steps you were following?
Same password in kde5 dialog and kwalletmanager ?

Otherwise a flawless update.
Thank you manjaro team :+1:

Try to change password in Wallet Manager and also you can check this WikiPage: https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login for additional info about wallet.
Unfortunately, I don't know exactly what solved my problem.
I hope this helps you.

I see... Tried various passwords in wallet manager (Same or different from login password).
Unfortunately none of them worked. There must be something else that solved your problem.

Thank you for your help, anyways :slight_smile:

xps9550, 419,KDE, update OK

All smooth, except for one funny.
I no longer get the SDDM greeter screen. Instead I'm shown a huge on-screen keyboard. The greeter appears fleetingly after I've hit after typing my password.
After a bit of a search I found that the solution is to add a line to /etc/sddm.conf in the [General] section:
InputMethod=

Did someone else encountered issues with an HP printer? I have an HP Deskjet 2540 and I cannot upgrade, for now, if the issue is confirmed.

EDIT:
Yes: someone else found the same issue reported in this discussion:

And @mparillo guess that the issue could be caused by hplip:

If needed, I will continue in such discussion, for avoiding to pollute this one about the stable update.

EDIT 2:

Update mostly works, but I can't install the Macbook Pro touchbar DKMS module. I've uninstalled and reinstalled, both through AUR and git. The module is there, but my touchbar never loads in. I'm on 5.4.24-1, for which a module currently exists near /var/lib/dkms/macbook12-spi-driver/.

I had the same problem, thus I removed all my network connections (I remember few years ago on openSUSE I had the same problem when I forgot to install pam_kwallet and steps were same. If I wouldn't removed them then it would still ask for the password) and removed whole wallet. Then I rebooted and added new wallet with same old password and everything is back to normal.

A little while ago I made a post about being unable to boot into my 5.4 environment, the issue got resolved during an update but the update that I pulled in yesterday (presumably this one) once again made me unable to get into 5.4 (5.4.24-1), I am currently forced to fall back to 4.19.

Specifically I am able to get into the grub, but after selecting 5.4 the screen remains black.

Following your advice, what I did was:

  1. Removed my WiFi connection (this is the source of the problem)
  2. Deleted the respective wallet
  3. Reboot and login
  4. Connected to my WiFi giving my wifi password... again, I re-checked with kwalletmanager and the wallet had being recreated. (smiles)

After this I thought maybe everything would be normal again. But in vain :frowning:
The next time i turned on my computer, it was asking for my wallet password again

PS: I dont know how to create a new wallet with the same parameters and add apps to it. So the next idea I'll try is to export my old wallet and then import it again...

Thank you so much !

Those with Firefox file dialog issue in KDE Plasma, please see this:

And yes, the /etc/profile.d/mozilla-common.sh require this entry
export GTK_USE_PORTAL=1

1 Like

Using KDE: After the upgrade, my Firefox doesn't play any sound. Fist I notice this in youtube, but I can't play any sound in other sites that play audio+video.

I can play video+sound in other browsers: chrome, waterfox and any other application: smplayer, vlc, spotify.

This is the current setting in autoplay, but before was "Allow Audio and Video" to all sites and still the issue occurs:
image

The DRM is checked:
image

In some websites playing videos shows the speaker on but no sound:
image

I wonder if there is a key "shortcut" in the browser that has disabled the sound in the whole browser.
Maybe it's just me because I can't find any report about this issue. Any hint?
Thanks!


I found it!, clicking the icon in the task bar "mute" the whole browser :upside_down_face::
Very useful feature, but make me lost my Sunday seeing videos :woozy_face: at home.
image

You will have to update hplip to make hp printers work again after this stable snap. See my post here:

I hope the new (fixed) hplip version will make it to stable soon!

2 Likes

I use Noto Sans fonts but they are distorted in some places in settings GUI
ksnip_20200316-214647
ksnip_20200316-215546
Also on desktop the kerning is really bad
Screenshot_20200316_215630

I just updated and the font in firefox's titlebar and tabs is fine.

I think libpipewire02 0.2.7-1 and pipewire 0.3.1-1 should be pushed to stable too. Now i see why my previous comment makes no sense and people have issue with the Firefox file dialog.

Oddly enough, the problem seems to have disappeared now.

Unfortunately the "wallet problem" (asking for the kde5: wallet password after login to connect to the wifi) persists.

None of the instructions at the Arhc wiki: https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login seem to help.

If i set the password blank with the help of kwalletmanager5, does the trick. But this is a workaround and not a solution.

Let's hope that the next KDE update will fix this...

There will be updates for KDE Framework eventually. In Testing, we recently got an upgrade for KDE Framework (including Kwallet) from 5.67.0 to 5.68.0. Perhaps it will help?

Forum kindly sponsored by