[Stable Update] 2020-03-14 - Kernels, Plasma 5.18.3, KDE Frameworks 5.67, KDE Apps 19.12.3, Firefox, Kodi

A little while ago I made a post about being unable to boot into my 5.4 environment, the issue got resolved during an update but the update that I pulled in yesterday (presumably this one) once again made me unable to get into 5.4 (5.4.24-1), I am currently forced to fall back to 4.19.

Specifically I am able to get into the grub, but after selecting 5.4 the screen remains black.

Following your advice, what I did was:

  1. Removed my WiFi connection (this is the source of the problem)
  2. Deleted the respective wallet
  3. Reboot and login
  4. Connected to my WiFi giving my wifi password... again, I re-checked with kwalletmanager and the wallet had being recreated. (smiles)

After this I thought maybe everything would be normal again. But in vain :frowning:
The next time i turned on my computer, it was asking for my wallet password again

PS: I dont know how to create a new wallet with the same parameters and add apps to it. So the next idea I'll try is to export my old wallet and then import it again...

Thank you so much !

Those with Firefox file dialog issue in KDE Plasma, please see this:

And yes, the /etc/profile.d/mozilla-common.sh require this entry
export GTK_USE_PORTAL=1

1 Like

Using KDE: After the upgrade, my Firefox doesn't play any sound. Fist I notice this in youtube, but I can't play any sound in other sites that play audio+video.

I can play video+sound in other browsers: chrome, waterfox and any other application: smplayer, vlc, spotify.

This is the current setting in autoplay, but before was "Allow Audio and Video" to all sites and still the issue occurs:
image

The DRM is checked:
image

In some websites playing videos shows the speaker on but no sound:
image

I wonder if there is a key "shortcut" in the browser that has disabled the sound in the whole browser.
Maybe it's just me because I can't find any report about this issue. Any hint?
Thanks!


I found it!, clicking the icon in the task bar "mute" the whole browser :upside_down_face::
Very useful feature, but make me lost my Sunday seeing videos :woozy_face: at home.
image

You will have to update hplip to make hp printers work again after this stable snap. See my post here:

I hope the new (fixed) hplip version will make it to stable soon!

2 Likes

I use Noto Sans fonts but they are distorted in some places in settings GUI
ksnip_20200316-214647
ksnip_20200316-215546
Also on desktop the kerning is really bad
Screenshot_20200316_215630

I just updated and the font in firefox's titlebar and tabs is fine.

I think libpipewire02 0.2.7-1 and pipewire 0.3.1-1 should be pushed to stable too. Now i see why my previous comment makes no sense and people have issue with the Firefox file dialog.

Oddly enough, the problem seems to have disappeared now.

Unfortunately the "wallet problem" (asking for the kde5: wallet password after login to connect to the wifi) persists.

None of the instructions at the Arhc wiki: https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login seem to help.

If i set the password blank with the help of kwalletmanager5, does the trick. But this is a workaround and not a solution.

Let's hope that the next KDE update will fix this...

There will be updates for KDE Framework eventually. In Testing, we recently got an upgrade for KDE Framework (including Kwallet) from 5.67.0 to 5.68.0. Perhaps it will help?

Since the update the KInfocenter reports KDE Framework 5.69 on my side and a on a friend's installation 5.68, though it should be 5.67.

I already reported the issue to the KDE devs, but they sent me to you: https://bugs.kde.org/show_bug.cgi?id=418924

You'll need to talk to the manjaro devs about that. KIC uses the kcoreaddons framework to determine the version. The version, or rather the dialog containing the version, in dolphin is from a different framework. So, what you describe is an inconsistent line up of framework versions. That's not supported and also advised against.

Any idea why we experience an inconsistent line up? Does anyone else experience it too?

Solved.
I added a new panel.

Probably not very fair, but I tried to update a laptop that hadn't been used or updated in a while, so was still running the 5.3 kernel.
The command line update (pacman -Syu) that I always used managed to remove the running kernel without properly installing the new ones. Also I was not able to use mhwd-kernel to install (or reinstall) any of the available kernels -- it complained that no target was specified.
Eventually, after trying to rescue the system by booting from the installation media and chrooting I was not able to make any progress and had to resort to reinstalling.
I guess the big concern is that the package manager was able to kick out the running kernel.
And the question -- how to tell it "No I do not want 'linux-latest', let me manage my kernels manually".

I could not open xls files with the file manager. MSG. File not found, although i've clicked it!?!?
Only at LibreOffice Calc / File Open... here the file was found and could have been loaded...

After reboot this odd behaivor was gone.

All well on xfce with ryzen 5 3600x and rtx 2060 super. ISO booted straight with non-free drivers and installed without a hiccup. Updated without any problems. Beautiful.

Am getting a Kernel Bug that is preventing me from using KVM. Do not update to linux4.19.108-1 if you are using a Ryzen chip and need KVM virtualization for QEMU.

Journalctl is reporting:
kernel BUG at arch/x86/kvm/mmu.c:296!

This issue has been reported here:
https://bugzilla.kernel.org/show_bug.cgi?id=206795

Is it safe for me to downgrade back to linux419 1.19.107 with: 'downgrade linux419'?

maybe upgrade to kernel 5.4 instead? It is the most recent LTS.

1 Like

Forum kindly sponsored by