[Stable Update] 2020-03-24 - Kernels, KDE Frameworks 5.68, Gnome 3.36, LibreOffice 6.4.2

Hello community,

here is another Stable Update for you.

Note for Gnome users

It is critical NOT to use a graphical environment when updating from 3.34 to 3.36 series of Gnome. Therefore switch to a TTY and use our CLI package managers.

  • First switch to a TTY: CTRL+ALT+F3
  • Login with your normal user in that terminal
  • Perform your update: sudo pacman -Syyu or pamac upgrade --force-refresh
  • Reboot your system after the update completed. Don't worry about not supported extensions. Gnome 3.36 will deactivate them for you.

Test our Gnome 19.1 Preview ...

Some feature-updates

  • All Kernels got rebuild against GCC 9.3 toolchain
  • Gnome got updated to 3.36. As usual report your issues!
  • poppler packages got updated
  • gamemode is updated to 1.5.1
  • KDE-Git package updates
  • Matcha theme got more fixes for Gnome 3.36
  • Updated packages for manjaro-asian-input-support
  • LibreOffice got updated to 6.4.2
  • archlinux-appstream-data got stripped of any <em> tags preventing package listing in pamac and gnome-software
  • PHP got updated to 7.4.4 and Firefox-Developer got pushed ot its fifth beta release
  • KDE Framework got updated to 5.68
  • Haskell and Python updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.217
  • linux49 4.9.217
  • linux414 4.14.174
  • linux419 4.19.112
  • linux54 5.4.27
  • linux55 5.5.11
  • linux56 5.6-rc7
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.26_rt17

Package Changes (Tue Mar 24 09:08:47 CET 2020)

  • stable community x86_64: 1765 new and 1708 removed package(s)
  • stable core x86_64: 58 new and 56 removed package(s)
  • stable extra x86_64: 739 new and 928 removed package(s)
  • stable multilib x86_64: 38 new and 39 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Reminder for Gnome users: How to upgrade within TTY?

In order to upgrade from Gnome 3.34 to Gnome 3.36, Manjaro devs strongly recommend to upgrade within TTY and not within a graphical session. Read the announcement above for the instructions on how to do the upgrade as recommended. For a more comprehensive guide on this subject, please read the following article in the FAQ: How do I do a system upgrade "within a tty"?.

error: failed to commit transaction (conflicting files)

If you get

error: failed to commit transaction (conflicting files)
hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc exists in filesystem

Make sure your mirrors are synced and that you have manjaro-system-20200324-4 or newer installed:

$ sudo pacman -S manjaro-system

Sound issues

If you're having sound issues (e.g. on Firefox, hardware keys, panel slider), try disabling User Themes, restarting and then enabling again.

Older issues

firewalld>=0.8.1-2 update requires manual intervention

(From arch linux post)
The firewalld package prior to version 0.8.1-2 was missing the compiled python modules. This has been fixed in 0.8.1-2, so the upgrade will need to overwrite the untracked pyc files created. If you get errors like these

firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/__init__.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/client.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/dbus_utils.cpython-38.pyc exists in filesystem
...many more...

when updating, use

pacman -Syu --overwrite /usr/lib/python3.8/site-packages/firewall/\*

to perform the upgrade.

(2020-02-14) Can't boot into a graphical session anymore

[Stable Update] 2020-02-10 - Kernels, KDE Apps, Gnome Settings

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

Orphaned khotkeys

There is some discussion of whether this is a true orphan, or an upstream packaging error, or merely a difference in philosophy about dependencies:

$ pacman -Qdt
khotkeys 5.18.3-1

Regardless, do not blindly remove this orphan.


Great update. However I wish mesa 20 was here too. Do you think we can get it sooner? :grinning:

1 Like

I have a small problem on two computers:


and so on

already exist in filesystem.

What can I do?

1 Like

Which are the ones? This should have been avoided by adding the workaround to manjaro-system

It went ok on Gnome, new orphans, only some extensions do not work, but not manjaro ones. Gnome-terminal wont start, again Locale not supported by C library
Screenshot from 2020-03-24 09-57-06

1 Like

What is the output of vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 3.20.3-2

Here is the errors of pacman -Syyu:

hplip: /usr/share/hplip/base/pycache/init.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/avahi.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/codes.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/device.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/g.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/logger.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/mdns.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/models.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/os_utils.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/pml.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/services.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/six.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/sixext.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/slp.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/status.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/strings.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/tui.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pycache/utils.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pexpect/pycache/init.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/pycache/init.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/pycache/cups.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/pycache/ldl.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/pycache/pcl.cpython-38.pyc existiert im Dateisystem

1 Like

Again, what is the output of

vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 3.20.3-2

Also check if manjaro-system-20200324-2 fixes the issue.

I had the same pycache errors. For me the result of that command is "1".


$ sudo pacman -S manjaro-system-20200324-2
error: target not found: manjaro-system-20200324-2

I did update the package db's first.

1 Like

Same problem here, vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 3.20.3-2 outputs 1

I don't think any mirrors have manjaro-system-20200324-2 yet, according to https://repo.manjaro.org/ anyways

Hopefully the update to manjaro-system fixes that

For anyone still experiencing hplip __pycache__ issues here is the workaround @fredb74 it's not that manjaro don't care about hp printer owners, the hplip packages are upstream from Arch and not maintained by manjaro developers. As stated by philm, the new manjaro-system (make sure the mirrors you use are synchronised before updating) and hplip build were supposed to negate this issue.


Found the issue. Check vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 1:3.20.3-2

1 Like

I have no HP printer installed. It is one from Kyocera.

Maybe uninstalling HPlib fixes this issue?

Yes, indeed. If you don't own an hp printer do that

hplip is installed on basically every manjaro install however, hopefully the workaround is implemented so not everyone has to deal with it

Most likely manjaro-system-20200324-3 should fix it ...

vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 1:3.20.3-2

Let's see when the updated manjaro-system package is synced and try again :slight_smile:

1 Like

Thanks, worked for me so far (didn't reboot yet)!

Thank you Manjaro team! I love this distro <3

[EDIT] I rebooted and... everything fine, as usual :wink:

1 Like

Forum kindly sponsored by