[Stable-Update] 2020-04-08 - Kernels, Pamac, Plasma, Mesa, Nvidia, Firefox, Haskell, Python

Hello community,

here is another Stable Update for you:


Our evergrowing hardware line will bring new devices to you soon ... #StayHome, #StayHealthy, #StaySafe, #HomeOffice

Some feature-updates:

  • Plasma is now at 5.18.4.1
  • Our breath2 theme got updated
  • Pamac 9.4 got it's first point-release
  • We added Gnome-Integration to Pamac
  • KDE-git packages got updated
  • Nvidia got updated to 440.82
  • Firefox got renewed to 75.0
  • x265 rebuilds of several packages
  • foomatic-db got updated
  • Calamares-git got some updates
  • Mesa got updated to 20.0.4
  • Qt got updated to 5.14.2
  • Rebuilds based on Qt update. Report if we missed some.
  • Updates to UKUI and Pamac got some fixes added
  • The usual upstream updates including Haskell and Python

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our first preview of Manjaro Lysia 20.0! XFCE, KDE and Gnome

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.218
  • linux49 4.9.218
  • linux414 4.14.175
  • linux419 4.19.114
  • linux54 5.4.30
  • linux55 5.5.15
  • linux56 5.6.2
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.28_rt19

Package Changes (Tue Apr 7 18:58:38 CEST 2020)

  • stable community x86_64: 1292 new and 1268 removed package(s)
  • stable core x86_64: 28 new and 28 removed package(s)
  • stable extra x86_64: 471 new and 573 removed package(s)
  • stable multilib x86_64: 20 new and 26 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

18 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Thinkpad T460 (Intel Wireless 8260) bluetooth problems
If you have a Thinkpad T460 with kernel 5.5, Intel Wireless 8260 and experience trouble with bluetooth, just reboot several times.


Older issues

Reminder for Gnome users: How to upgrade within TTY?

In order to upgrade from Gnome 3.34 to Gnome 3.36, Manjaro devs strongly recommend to upgrade within TTY and not within a graphical session. Read the announcement above for the instructions on how to do the upgrade as recommended. For a more comprehensive guide on this subject, please read the following article in the FAQ: How do I do a system upgrade "within a tty"?.

error: failed to commit transaction (conflicting files)

If you get

error: failed to commit transaction (conflicting files)
hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc exists in filesystem

Make sure your mirrors are synced and that you have manjaro-system-20200324-4 or newer installed:

$ sudo pacman -S manjaro-system

Sound issues

If you're having sound issues (e.g. on Firefox, hardware keys, panel slider), try disabling User Themes, restarting and then enabling again.


firewalld>=0.8.1-2 update requires manual intervention

(From arch linux post)
The firewalld package prior to version 0.8.1-2 was missing the compiled python modules. This has been fixed in 0.8.1-2, so the upgrade will need to overwrite the untracked pyc files created. If you get errors like these

firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/__init__.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/client.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/dbus_utils.cpython-38.pyc exists in filesystem
...many more...

when updating, use

pacman -Syu --overwrite /usr/lib/python3.8/site-packages/firewall/\*

to perform the upgrade.

(2020-02-14) Can't boot into a graphical session anymore

[Stable Update] 2020-02-10 - Kernels, KDE Apps, Gnome Settings

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

Orphaned khotkeys

There is some discussion of whether this is a true orphan, or an upstream packaging error, or merely a difference in philosophy about dependencies:

$ pacman -Qdt
khotkeys 5.18.3-1

Regardless, do not blindly remove this orphan.

1 Like

Thank you so much for making an amazing distro Manjaro!

10 Likes

Update went fine from TTY. Cinnamon DE, kernel 5.5, Nvidia 440xx. Updated kernel to 5.6, that went fine too. Thanks!

Update via console went fine on 3 computers:
2 * KDE and 1 * XFCE.

Thanks to the Manjaro Team.

1 Like

Updated from TTY, no issues. XFCE

1 Like

Update went ok on Gnome, does anyone know how to fix gnome-boxes? It is still broken as it was after update to 3.36.

All went smoothly on my pc.

I want to express my appreciation to the Manjaro development team for releasing updates in spite of the current lock-down and social distancing restrictions .

Very well done indeed.

1 Like

Open a new thread for Gnome-Boxes and explain what the issue is.

Went fine as far as I could tell. Thank you!

Terminal upgrade - KDE

Wow, that was quick. Weren't NVidia drivers released just yesterday? I'll have to update as soon as I am finished with work and try if/how Doom runs :smile:. I am a bit afraid of the kernel upgrade, but I hope for the best.

TTY update on the Gnome. Running on: Lenovo ThinkPad T420s.

No issues.

Thanks to all involved in this release.

With mesa 20, finally we have a fix for this bug: https://gitlab.freedesktop.org/drm/amd/issues/842 (graphics glitches to ryzen laptops).

So you no longer need an /etc/profile.d/amd_fix.sh file with export AMD_DEBUG=nodcc.

Happy day!

it has been reported here

Here is a small bug!

Caffeine FirewallD

Icons are missing in these 2. FirewallD Applet and Caffeine Extension.
They work fine. Just the icons are missing

Same here caffeine needs to be updated.

The update went smoothly. There is a small bug though, not necessarily related to this latest update.
When I was under the kernel 5.5, I installed linux55-acpi_call via linux-latest-acpi_call so that I would have the latest compatible acpi when changing the kernel. However, after installing the kernel 5.6, I tried to remove 5.5 via the control panel and it won't let me do it because

removing linux55-acpi_call breaks dependency 'linux55-acpi_call' required by linux-latest-acpi_call
error: failed to prepare transaction (could not satisfy dependencies)

Is there any way to remove kernel 5.5 other than manually remove linux-latest-acpi_call and eventually installing the acpi for kernel 5.6 manually?

EDIT, linux-latest-acpi_call is at the version 5.5.1-1, maybe it needs to be updated to the version 5.6?

KDE Plasma, kernel 5.4.30-1. Big update...!

Smooth re-boot and everything fine.

Thanks for the hard work, and keep safe :v:

Update in TTY on KDE - all went smooth, thx for the great Distro! The Audacious v.4 with qt-Interface is awesome ...

Got an issue on kde. pamac-gtk crashed while updating. trying to update through tty via pacman was not possible as it couldn't connect to network. Tried to chroot through another manjaro installation with working internet connection and pacman can still not connect to network

1 Like

Forum kindly sponsored by