[Stable Update] 2020-04-18 - Kernels, Browsers, VirtualBox, LibreOffice. KDE-Frameworks

Hello community,

After a long week of development we fast-tracked all packages to stable branch. With this, we have some interesting updates for you!


Get out and test our latest Gnome!

  • Most of our kernels got updated. Realtime-Kernel 4.19 got removed. You get upgraded to 5.4 series automatically
  • KDE-git packages got partly renewed
  • The universal package manager bauh got updated to 0.9.0
  • Some Webbrowsers got renewed
  • VirtualBox is now at 6.1.6
  • KDE Frameworks got updated to 5.69.0
  • LibreOffice is now at 6.4.3
  • Some fixes for php got added with 7.4.5

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our second release-candidate of Manjaro Lysia 20.0! XFCE, KDE and Gnome

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.218
  • linux49 4.9.218
  • linux414 4.14.175
  • linux419 4.19.114
  • linux54 5.4.31
  • linux55 5.5.16
  • linux56 5.6.3
  • linux57 5.7-rc0
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.28_rt19

Package Changes (Sat Apr 18 14:18:39 CEST 2020)

  • stable community x86_64: 960 new and 957 removed package(s)
  • stable core x86_64: 32 new and 32 removed package(s)
  • stable extra x86_64: 530 new and 583 removed package(s)
  • stable multilib x86_64: 17 new and 17 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

21 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

(2020-04-19) System with amdgpu won't reboot or power off correctly

This was a kernel regression and has been patched in 5.4.33-2, 5.5.18-2, and 5.6.5-2. Check again for updates.

(2020-04-18) nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

This should normally been fixed by manjaro-system.

If you were using Pamac GTK and got an error message similar to the following (see screenshot below):
thumbnail
try first to simply restart the update with Pamac GTK. This should be enough to continue and finish the system update. Closing Pamac window may not be necessary. Normally, despite what the error message tells, the file conflict(s) should in fact be handled properly when manjaro-system got upgraded; hence restarting the upgrade right after should do the trick.

If the file conflict was not solved automatically by manjaro-system, update your system in a command-line interface with the following command to get through it:

sudo  pacman -Syu --overwrite /usr/lib\*/p11-kit-trust.so

(2020-04-18) Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

(2020-04-18) Thinkpad T460 (Intel Wireless 8260) bluetooth problems

If you have a Thinkpad T460 with kernel 5.5, Intel Wireless 8260 and experience trouble with bluetooth, just reboot several times.

(2020-04-18) Error: signature invalid

If you get:

Error: linux54: signature from "Bernhard Landauer <oberon@manjaro.org>" is invalid

You should follow the solution here


Older issues

Reminder for Gnome users: How to upgrade within TTY?

In order to upgrade from Gnome 3.34 to Gnome 3.36, Manjaro devs strongly recommend to upgrade within TTY and not within a graphical session. Read the announcement above for the instructions on how to do the upgrade as recommended. For a more comprehensive guide on this subject, please read the following article in the FAQ: How do I do a system upgrade "within a tty"?.

error: failed to commit transaction (conflicting files)

If you get

error: failed to commit transaction (conflicting files)
hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc exists in filesystem

Make sure your mirrors are synced and that you have manjaro-system-20200324-4 or newer installed:

$ sudo pacman -S manjaro-system

Sound issues

If you're having sound issues (e.g. on Firefox, hardware keys, panel slider), try disabling User Themes, restarting and then enabling again.


firewalld>=0.8.1-2 update requires manual intervention

(From arch linux post)
The firewalld package prior to version 0.8.1-2 was missing the compiled python modules. This has been fixed in 0.8.1-2, so the upgrade will need to overwrite the untracked pyc files created. If you get errors like these

firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/__init__.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/client.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/dbus_utils.cpython-38.pyc exists in filesystem
...many more...

when updating, use

pacman -Syu --overwrite /usr/lib/python3.8/site-packages/firewall/\*

to perform the upgrade.

8 Likes

Heya!
Had an issue updating nss, but linking the solution here.

Error Message

nss: /usr/lib/p11-kit-trust.so already exists in filesystem
lib32-nss: /usr/lib32/p11-kit-trust.so already exists in filesystem

Solution
pacman -Syu --overwrite /usr/lib*/p11-kit-trust.so

2 Likes

Updated Cinnamon, kernel 5.6 with Nvidia 440xx without problems.

During the update, mkinitcpio was called twice in a row, so all initramfs got build twice in a row before grub was updated. Not the end of the world, but unneccessary all the same.

For this normally manjaro-system should take care of ...

It gets called once by kernel update and once by nvidia update based on different triggers.

1 Like

When updating, it updates manjaro-system along with all the other packages, it doesn't do manjaro-system first.

What's strange is it looks like manjaro-system did try to take care of it, and it didn't spit back an error message.

manjaro-system & nss upgrade
Download of manjaro-system (20200418-1) started                                                                                                         
Download of manjaro-system (20200418-1) finished                                                                                                        
Checking keyring...                                                                                                                                [1/1]
Checking integrity...                                                                                                                              [1/1]
Loading packages files...                                                                                                                          [1/1]
Checking file conflicts...                                                                                                                         [1/1]
Checking available disk space...                                                                                                                   [1/1]
Upgrading manjaro-system (20200325-1 -> 20200418-1)...                                                                                             [1/1]
Configuring manjaro-system...
==> Fixing file conflicts for 'nss' update for you ...
resolving dependencies...
looking for conflicting packages...

Packages (1) nss-3.51.1-1

Total Download Size:   1.42 MiB
Total Installed Size:  5.02 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading nss-3.51.1-1-x86_64.pkg.tar.zst...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading nss...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Fixing file conflicts for 'lib32-nss' update for you ...
resolving dependencies...
looking for conflicting packages...

Packages (1) lib32-nss-3.51.1-1

Total Download Size:   1.00 MiB
Total Installed Size:  2.93 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading lib32-nss-3.51.1-1-x86_64.pkg.tar.zst...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading lib32-nss...
:: Running post-transaction hooks...

Look at the log. It fixed it for nss and lib32-nss ...

==> Fixing file conflicts for 'nss' update for you ...
---
==> Fixing file conflicts for 'lib32-nss' update for you ...

I agree but I still errored out of the pamac upgrade because of the supposed file conflict after everything else downloaded.

Are there additional logs I could provide that might clarify what happened?

We will see on how we can fix file conflicts in pamac.

If you want you can comment on the issue ...

Ah alright, I hadn't realized this was unique to pamac, I'm glad there's already a feature request for it though. Thank you for the help!

erm yes - what do I need to do here?

conflicting files:
nss: /usr/lib/p11-kit-trust.so already exists in filesystem
lib32-nss: /usr/lib32/p11-kit-trust.so already exists in filesystem

I see others have the same issue

1 Like

Can report same issue. Will join on gitlab.

Edit: well ran the update tool again to confirm the error dialog. It updated successfully this time.

If you haven't fixed it yet, run pacman -Syu --overwrite /usr/lib*/p11-kit-trust.so and it should resolve.

Reference

1 Like

I'm currently using that fix - thanks for posting it :slight_smile:

Update the fix works - thanks again.

Would be nice if in future the error message dialogue box would throw up a link to click straight into this forum and allowed the user to report the error message more smoothly.

I've updated a few minutes before the announcement, I've had problems to reboot or power off, it seems that the system hangs...
I've reverted to the previous state with Timeshift.

This is my inxi:

[albert@AMTorre ~]$ inxi -Fxzc0
System:    Host: AMTorre Kernel: 5.5.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: A320M-S2H V2 v: N/A serial: <filter> 
           Mobo: Gigabyte model: A320M-S2H V2-CF v: x.x serial: <filter> UEFI: American Megatrends 
           v: F50 date: 12/02/2019 
CPU:       Topology: Dual Core model: AMD Athlon 220GE with Radeon Vega Graphics bits: 64 type: MT MCP 
           arch: Zen L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 27157 
           Speed: 3082 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 3082 2: 2950 3: 2443 4: 2853 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] driver: amdgpu 
           v: kernel bus ID: 09:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.5.16-1-MANJARO LLVM 9.0.1) v: 4.6 Mesa 20.0.4 
           direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus ID: 09:00.1 
           Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 09:00.6 
           Sound Server: ALSA v: k5.5.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte 
           driver: r8169 v: kernel port: f000 bus ID: 08:00.0 
           IF: enp8s0 state: down mac: <filter> 
           Device-2: Ralink MT7610U (Archer T2U 2.4G+5G WLAN Adapter type: USB driver: mt76x0u 
           bus ID: 1-9:2 
           IF: wlp1s0f0u9 state: up mac: <filter> 
Drives:    Local Storage: total: 698.65 GiB used: 327.60 GiB (46.9%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST9250315ASG size: 232.89 GiB 
Partition: ID-1: / size: 19.56 GiB used: 15.51 GiB (79.3%) fs: ext4 dev: /dev/sda3 
           ID-2: /home size: 435.65 GiB used: 204.98 GiB (47.1%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 29.9 C mobo: N/A gpu: amdgpu temp: 16 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 214 Uptime: 1h 26m Memory: 5.81 GiB used: 1.44 GiB (24.8%) Init: systemd 
           Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.0.37

:grinning:

1 Like

For me have make this fix sudo pacman -Syyu --overwrite /usr/lib/p11-kit-trust.so

Ok I just did some research on this, seems like the fix gets applied successfully (nss gets updated, as expected), yet pamac didn't realize the conflicts have changed? This works correctly in pacman.

If the user tries to do the update again, it will complete successfully, since the conflicts are already gone.

Also, all the fixes suggested by users are completely worthless since pacman doesn't have this issue in the first place. And even if you're using pamac, by the time you see the message, the problem is already fixed on your system.

Can someone confirm my findings and update the wiki post accordingly?

1 Like

This is exactly my issue: Shutdown / Reboot hangs indefinitely.

:grinning:

PD: I've updated my ThinkPad with Intel hardware with no problems to reboot/shutdown.

Forum kindly sponsored by