[Stable Update] 2020-04-18 - Kernels, Browsers, VirtualBox, LibreOffice. KDE-Frameworks

For me have make this fix sudo pacman -Syyu --overwrite /usr/lib/p11-kit-trust.so

Ok I just did some research on this, seems like the fix gets applied successfully (nss gets updated, as expected), yet pamac didn't realize the conflicts have changed? This works correctly in pacman.

If the user tries to do the update again, it will complete successfully, since the conflicts are already gone.

Also, all the fixes suggested by users are completely worthless since pacman doesn't have this issue in the first place. And even if you're using pamac, by the time you see the message, the problem is already fixed on your system.

Can someone confirm my findings and update the wiki post accordingly?

1 Like

This is exactly my issue: Shutdown / Reboot hangs indefinitely.

:grinning:

PD: I've updated my ThinkPad with Intel hardware with no problems to reboot/shutdown.

Same issue here (Cinnamon)

nss: /usr/lib/p11-kit-trust.so already exists in filesystem
lib32-nss: /usr/lib32/p11-kit-trust.so already exists in filesystem

I've refreshed database and then updated successfully. Thank you :green_heart:

1 Like

No errors updating KDE version in TTY using pacman.

Doing a pamac upgrade I got:

Checking keyring...                                                    [149/149]
Checking integrity...                                                  [149/149]
Error: linux54: signature from "Bernhard Landauer <oberon@manjaro.org>" is invalid
Error: Failed to commit transaction: invalid or corrupted package:

Did this to resolve the issue:


Note: Solution already edited into wiki solutions above @philm (First time this happened, I hope I did the right thing...) :innocent:

1 Like

I got a couple of errors failed retrieving file ****** from manjaro.moson.eu : operation too slow

First time I' ve seen this happen but after the installation finished I installed said files manually and no problems so far.

No problem here.

Smooth update
But... arch maintainers updated seamonkey to version 2.49.4-5, but version 2.53.1 is out from a while, with major and security changes.

http://www.seamonkey-project.org/releases/seamonkey2.53.1/

https://www.archlinux.org/packages/community/x86_64/seamonkey/

Are they drunk or there is a valid reason?

KDE Plasma Version: 5.18.4
Kernel Version: 5.5.18

Fixing file conflicts for 'lib32-nss' update for you ...

Many thanks

All good here.

1 Like

no issues, up in a tty and everything ok here. Well done ty s2

i got the same but it seams it was something in their or mine network.

I am having the same kernel shutdown and reboot hang as listed above.

Edit: Can confirm that the patch listed in the link does in fact fix this issue!

1 Like

All good from stable-staging XFCE + linux55 + btrfs

1 Like

no issues here:
update via terminal and rebooted.
System: Cinnamon+linux54+btrfs

Thanks for your good work. :slight_smile:

My machine doesn't power off anymore (KDE)
At shutdown the screen gets black and power stays on. Doesn't react to any inputs.

Created symlink /etc/systemd/system/multi-user.target.wants/add-autologin-group.service → /etc/systemd/system/add-autologin-group.service.
We have enabled autologin for all users.
Reboot your system the first time, so changes will take affect.

I am not sure what to do here.
After reboot, autologin is still enable for all users.
Do i have to disable 'add-autologin-group.service' to recover my login screen ?

I really doubt it is related. This service is just used to do the preparation needed so autologin can be configured easily in LightDM Settings (GUI configuration tool for LightDM and Slick Greeter).

The service does the following:

  • Create the "autologin" group if it does not exist.
  • Add non-system users to the autologin group.

Therefore, it would be really surprising that it would prevent your system from booting properly.

Check here to see what it actually does: https://gitlab.manjaro.org/packages/community/lightdm-settings/-/blob/master/add-autologin-group.script

Have a good day sir.

6 Likes

You are right. I tried to disable the service but nothing changed.
In fact, the solution was very simple. The update has uncommented the 'autologin-user' setting in lightdm.conf. I just had to comment out it again.
Problem solved.

Forum kindly sponsored by