[Stable Update] 2020-04-18 - Kernels, Browsers, VirtualBox, LibreOffice. KDE-Frameworks

AMD 3400G with B450 affected... :confused:

2 Likes

I am affected too. And my girlfriend the same both pcs with Ryzen third generation. One Lenovo e595 ThinkPad Ryzen 7 and the other an Asus Zenbook Ryzen 5

2 Likes

Updated thru pamac gui. I also ran into the error indicated on the Known Issues post. I followed the instructions there, but when I clicked the Apply button again, pamac said "Nothing to do". I clicked the Apply button again later, and it continued updates as normal starting with asking for my password. Other than that little hiccup, I don't think there's anything else worth mentioning and it looks like all's well on my system. Manjaro Cinnamon, kernel 5.4, Intel 2nd gen i3 cpu and graphics.

Don't use kernel 5.6 until it is fixed.

It's a kernel regression so that would be a bit pointless.

Or just switch to kernel 5.4 which is the one of the reasons for having multiple kernel series available?


Edit.

Oh, wait, it looks like the bug is in 5.4 and 5.5. too. There's a patch available, this might want to be fast-tracked.

2 Likes

The problem is that other kernel 5.4 and 5.5 are also affected, at least on my PC.
I think that the best option is to skip this update momentarily.

:grinning:

2 Likes

that one is also affected, just tested. Hence my issue: https://gitlab.manjaro.org/packages/core/linux56/-/issues/3

and report here:

and here:

2 Likes

Yup, saw that after I posted. I'm looking at the patch and the kernel now.

I assume extramodules won't also need a rebuild...


Aaaand my build "server" is down. Let's see if it comes back up, if not I'll have to wait until tomorrow to get it rebooted.

Edit 2, it has come back, I'll look at 5.6 then 5.4 then 5.5.

Edit 3, PKGBUILDs are patched, builds are under way.

6 Likes

not sure about extramodules, don't need any on my systems.
virtualbox is handled by dkms for me.

1 Like

I think the problem may be in firmware because I have tried many kernels and all have this problem

...just switch to kernel 5.4
Users who are affected by the [hanging reboot/shutdown issue ] ... what should do?

I use Kernel 5.4.33-1 on a Ryzen / amdgpu machine - no issues.

1 Like

I had to recompile both the 5.6 and 5.4 kernels as the bug does not restart or shutdown the computer properly. After installing the new kernel with the patch everything went back to working properly. By the way, I helped some manjaro-it users

System:    Host: calogeroelvira-aspire Kernel: 5.6.5-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A315-41 v: V1.13 serial: <filter> 
           Mobo: PK model: Metapod_RR v: V1.13 serial: <filter> UEFI: Insyde v: 1.13 date: 02/11/2019 
Battery:   ID-1: BAT1 charge: 36.3 Wh condition: 36.3/37.0 Wh (98%) 
           model: PANASONIC 0x41,0x50,0x31,0x36,0x4D,0x35,0x0038 status: Full 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP 
           arch: Zen+ rev: 1 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33549 
           Speed: 1214 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1634 2: 1521 3: 1476 4: 1477 
           5: 3692 6: 3691 7: 2954 8: 2954 
Graphics:  Device-1: AMD Picasso vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus ID: 03:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,modesetting FAILED: ati unloaded: fbdev,vesa 
           resolution: 1360x768_60.00~60Hz, 1366x768~60Hz, 1680x1050~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.6.5-2-MANJARO LLVM 9.0.1) v: 4.6 Mesa 20.0.4 
           direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 03:00.1 
           Device-2: AMD Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 03:00.6 
           Device-3: DisplayLink USB3.0 Hub type: USB driver: cdc_ncm,snd-usb-audio,usbfs bus ID: 2-1.1:3 
           Device-4: Microsoft LifeCam HD-3000 type: USB driver: snd-usb-audio,uvcvideo 
           bus ID: 1-1.4.3.4.2:10 
           Sound Server: ALSA v: k5.6.5-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8169 v: kernel port: 2000 bus ID: 01:00.1 
           IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On 
           driver: ath10k_pci v: kernel port: 2000 bus ID: 02:00.0 
           IF: wlp2s0 state: down mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
           IF-ID-2: enp3s0f3u1u1i5 state: down mac: <filter> 
           IF-ID-3: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-4: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 2.95 TiB used: 965.90 GiB (32.0%) 
           ID-1: /dev/mmcblk0 model: SD02G size: 1.84 GiB 
           ID-2: /dev/sda vendor: TCSunBow model: X3 480GB size: 447.13 GiB 
           ID-3: /dev/sdb vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB 
           ID-4: /dev/sdc type: USB vendor: Seagate model: M3 Portable size: 931.51 GiB 
           ID-5: /dev/sdd type: USB vendor: Seagate model: ST750LM0 22 HN-M750MB size: 698.64 GiB 
           ID-6: /dev/sde type: USB vendor: Western Digital model: WD75 00BPVT-80HXZT1 size: 698.64 GiB 
Partition: ID-1: / size: 438.82 GiB used: 145.17 GiB (33.1%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 71.8 C mobo: N/A gpu: amdgpu temp: 71 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 335 Uptime: 10h 02m Memory: 29.34 GiB used: 3.83 GiB (13.1%) Init: systemd Compilers: 
           gcc: 9.3.0 clang: 9.0.1 Shell: bash v: 5.0.16 inxi: 3.0.37 

2 Likes

Think I have the same issue. Where is that file?
Guess I should try that too. One computer did it without issues by my main computer got the lightdm issue... Google and see too

Ah, never mind. Not that problem. The computer behaved strangely when upgrading (XFCE barly responding)... I rebooted and it broke... Pacman -Syu fixed my incomplete update

We need to understand what really happened. Can you give us some more information?

Any volunteers to test 5.6.5-2 ?

  • Works fine
  • Still broken

0 voters

I was able to reboot fine with 5.6.5-2, thanks. I have other issues with 5.5 & 5.6, however. Please patch 5.4 & 5.5 as well.

1 Like

It works perfectly. Apply the patch to kernel 5.5 and 5.4 and release the update. Arch hasn't added the patch yet.

1 Like

lightdm failed loading. Didn't reach GUI.
The package manager still showed some updates that wasn't installed. Mostly "community/extra" components (purple), but I may have missed something important. Anyway... Package manager didn't let me install them.
While I updated via Package Manager the GUI acted strange. No reaction to windows button, logout, go to tty, updates stil left... I could eventually reboot.
Then the lightdm loading error. I checked the lightdm config but not anything automaticlly uncommented as someone else had.
So I ran pacman -Syu an then I could boot again.

The packages that of some reason didn't install first time via Package Manager. Since I now see that some are GUI relevant I can see the problem :wink: But why is the question. Maybe it would have been different if I did it TTY to begin with.

[2020-04-19T17:52:16+0200] [ALPM] upgraded xfce4-taskmanager (1.2.2-1 -> 1.2.3-1)
[2020-04-19T17:52:16+0200] [ALPM] upgraded virtualbox (6.1.4-6 -> 6.1.6-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded libgsf (1.14.46+3+g7f927f0-1 -> 1.14.47-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded lib32-wayland (1.18.0-1 -> 1.18.0-2)
[2020-04-19T17:52:15+0200] [ALPM] upgraded lib32-llvm-libs (9.0.1-1 -> 9.0.1-2)
[2020-04-19T17:52:15+0200] [ALPM] upgraded lib32-harfbuzz (2.6.4-2 -> 2.6.5-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded lib32-glib2 (2.64.1-1 -> 2.64.2-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded lib32-libffi (3.2.1-2 -> 3.3-2)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kitemviews (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kitemmodels (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded ki18n (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kguiaddons (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kcrash (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kwindowsystem (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kcompletion (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kconfig (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kwidgetsaddons (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kauth (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:15+0200] [ALPM] upgraded kcoreaddons (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded karchive (5.68.0-1 -> 5.69.0-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded libinput (1.15.4-1 -> 1.15.5-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded inkscape (0.92.4-15 -> 0.92.5-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded libmagick6 (6.9.11.4-1 -> 6.9.11.6-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded harfbuzz-icu (2.6.4-2 -> 2.6.5-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded guile (2.2.6-1 -> 2.2.6-2)
[2020-04-19T17:52:14+0200] [ALPM] upgraded gobject-introspection-runtime (1.64.1-1 -> 1.64.1-2)
[2020-04-19T17:52:14+0200] [ALPM] upgraded git (2.26.0-1 -> 2.26.1-1)
[2020-04-19T17:52:14+0200] [ALPM] upgraded firefox-developer-edition (75.0b11-1 -> 76.0b5-1)
[2020-04-19T17:52:13+0200] [ALPM] upgraded efibootmgr (16-2 -> 17-1)
[2020-04-19T17:52:13+0200] [ALPM] upgraded dnsmasq (2.80-4 -> 2.81-3)
[2020-04-19T17:52:13+0200] [ALPM] upgraded cmake (3.17.1-1 -> 3.17.1-2)
[2020-04-19T17:52:13+0200] [ALPM] upgraded bluegriffon (3.1-9 -> 3.1-10)
[2020-04-19T17:52:12+0200] [ALPM] upgraded glib-networking (2.64.1-1 -> 2.64.2-1)
[2020-04-19T17:52:12+0200] [ALPM] upgraded bc (1.07.1-3 -> 1.07.1-4)
[2020-04-19T17:52:12+0200] [ALPM] upgraded android-udev (20191103-1 -> 20200410-1)
[2020-04-19T17:52:12+0200] [ALPM] upgraded ca-certificates-mozilla (3.51-1 -> 3.51.1-1)
[2020-04-19T17:52:12+0200] [ALPM] upgraded adwaita-icon-theme (3.36.0-1 -> 3.36.1-1)
[2020-04-19T17:52:12+0200] [ALPM] upgraded harfbuzz (2.6.4-2 -> 2.6.5-1)
[2020-04-19T17:52:12+0200] [ALPM] upgraded glib2 (2.64.1-1 -> 2.64.2-1)
[2020-04-19T17:52:11+0200] [ALPM] upgraded libffi (3.2.1-4 -> 3.3-3)

5.4, 5.5, and 5.6 kernels are patched and uploaded:

User jonathon committed following changes:

 - stable core x86_64:  6 new and 6 removed package(s)

-------------- next part --------------
[New Packages]
linux54-5.4.33-2-x86_64.pkg.tar.zst
linux54-headers-5.4.33-2-x86_64.pkg.tar.zst
linux55-5.5.18-2-x86_64.pkg.tar.zst
linux55-headers-5.5.18-2-x86_64.pkg.tar.zst
linux56-5.6.5-2-x86_64.pkg.tar.zst
linux56-headers-5.6.5-2-x86_64.pkg.tar.zst


[Removed Packages]
linux54-5.4.33-1-x86_64.pkg.tar.xz
linux54-headers-5.4.33-1-x86_64.pkg.tar.xz
linux55-5.5.18-1-x86_64.pkg.tar.xz
linux55-headers-5.5.18-1-x86_64.pkg.tar.xz
linux56-5.6.5-1-x86_64.pkg.tar.xz
linux56-headers-5.6.5-1-x86_64.pkg.tar.xz

These will propagate to mirrors in due course. Check for updates!

6 Likes

It has worked, now I can reboot/shutdown as usual.
1.000.000 Thanks!! :clap: :clap: :clap: :clap: :grinning: :grinning: :grinning:

2 Likes

Forum kindly sponsored by