[Stable Update] 2020-05-03 - Kernels, LXQt 0.15, Vulkan, VLC 3.0.10, Mesa 20.0.6, AMDVLK 20.Q2.2

I am going to put a link of this here since it broke with the last update of Brave Browser:

That is strange. I am using Brave in KDE with the latest stable update of Manjaro and PicturetoPicture works without a problem

Oops. I forgot to post here. I disabled all the extensions and enabled them again and the problem stoped. Could not figure out which extension caused the issue, but it's now solved.

After updating, I had that strange error

sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
error: could not open file /var/lib/pacman/sync/community.db: Unrecognized archive format
warning: lib32-systemd: local (245.5-1) is newer than multilib (244.4-1)
warning: pamac-cli: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: pamac-common: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: pamac-gtk: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: systemd: local (245.5-1) is newer than core (244.4-1)
warning: systemd-libs: local (245.5-1) is newer than core (244.4-1)
warning: systemd-sysvcompat: local (245.5-1) is newer than core (244.4-1)
 there is nothing to do

Which was even worse with yay (which wanted me to full update on some unknown AUR).

I fixed this error with this command :

::INFO Downloading mirrors from repo.manjaro.org
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  2.215 United_States  : https://mirror.clarkson.edu/manjaro/
  0.808 Indonesia      : http://kartolo.sby.datautama.net.id/manjaro/
  3.766 Poland         : https://mirror.tuchola-dc.pl/manjaro/
  0.789 Thailand       : https://mirror.kku.ac.th/manjaro/
  0.804 Thailand       : http://mirror.kku.ac.th/manjaro/
  1.206 Thailand       : ftp://mirror.kku.ac.th/manjaro/
  ..... Portugal       : http://ftp.dei.uc.pt/pub/linux/manjaro/
::INFO Writing mirror list
::Indonesia       : http://kartolo.sby.datautama.net.id/manjaro/stable-staging
::Thailand        : https://mirror.kku.ac.th/manjaro/stable-staging
::United_States   : https://mirror.clarkson.edu/manjaro/stable-staging
::Portugal        : http://ftp.dei.uc.pt/pub/linux/manjaro/stable-staging
::Poland          : https://mirror.tuchola-dc.pl/manjaro/stable-staging
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core                             171,5 KiB   308 KiB/s 00:01 [##################################] 100%
 extra                           2010,9 KiB   599 KiB/s 00:03 [##################################] 100%
 community                          5,9 MiB   244 KiB/s 00:25 [##################################] 100%
 multilib                         193,0 KiB   781 KiB/s 00:00 [##################################] 100%
:: Starting full system upgrade...
warning: lib32-systemd: local (245.5-1) is newer than multilib (244.4-1)
warning: pamac-cli: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: pamac-common: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: pamac-gtk: local (9.5.0beta-2) is newer than extra (9.4.2-1)
warning: systemd: local (245.5-1) is newer than core (244.4-1)
warning: systemd-libs: local (245.5-1) is newer than core (244.4-1)
warning: systemd-sysvcompat: local (245.5-1) is newer than core (244.4-1)
 there is nothing to do

And my yay is fixed too :smiley:

It seems you are on stable-staging which is a development repository. It is common that we downgrade packages there. Simply do a: sudo pacman -Syyuu

1 Like

I found a bug report about this zbar issue:
https://bugs.archlinux.org/task/66444

1 Like

Guwf stop working. Downgrade to previous version solve problem.

I've 5.4.35-1 and 5.6.7-1 kernels installed. Yet I face the above mentioned issue. Sorry if I've misunderstood it, but do you mean the fix is present in 5.4.33-2 + other kernel versions and not in latest versions that I already have?

Thanks for the great work, as always :slight_smile:

No issues. Thanks team!

DE/WM: XFCE & i3wm
Kernel: linux54, linux419

There is an issue with mesa 20.0.6. The update made my Chars and Npc's in Torchlight 2 flickering.
https://youtu.be/Yb6boOpYueY

Solved it by downgrading Mesa to 20.0.4.

Because I'm only playing Torchlight right now, I can't say whether it also affects other games.

Attention:
Wer Chrome unter Linux, macOS oder Windows nutzt,
sollte die aktuelle Version 81.0.4044.138 installieren. Darin haben die Entwickler drei Schwachstellen aus der Welt geschafft.

Wie aus einer Warnmeldung von Google hervorgeht:
(https://chromereleases.googleblog.com/2020/05/stable-channel-update-for-desktop.html),
ist der Bedrohungsgrad als " hoch " eingestuft. Wie gewohnt hält Google sich mit Details zu den Lücken zurück, damit Angreifer so wenig Ansatzpunkte wie möglich haben.
.
................................... in gebräuchlicherer Sprache: ............................................................................
.
If you use Chrome under Linux, macOS or Windows, you should install the current version
81.0.4044.138 . In it, the developers have eliminated three vulnerabilities.

[As shown by a warning message from Google]
(https://chromereleases.googleblog.com/2020/05/stable-channel-update-for-desktop.html), the level of threat is classified as "** high **". As usual, Google retains details about the gaps so that attackers have as few starting points as possible.

THIS AFFECTS CHROMIUM TOO

I stumbled accross a strange bug, that has been introduced after this (or the last stable) update: "Desktop effects have been suspended by another application"

I seem not to be the only one with this problem: Manjaro KDE Desktop effect suspended after login

I just can't point my finger on what causes this problem.

I recently got this issue every time I enable my second screen, it's been a few updates back, it is the Nvidia drivers. Didn't try to troubleshoot more, I just enable the desktop effects back.

My AMD-machine is stuck on boot after update. KDE.

IMG_20200507_171828
IMG_20200507_171810

:flushed:

Edit: Reboots again after several tries. Selfhealing Manjaro.

The original anydesk-bin got updated yesterday and now works again.

1 Like

Please check your hard disk health. I've been here. Your hard disk is about to crash in few weeks.

1 Like

Or simply a bad cable/connection, may check that as well. For health stat, check it with SMART tools like GsmartControl or similar tool able to read the S.M.A.R.T.

1 Like

This was fixed, hopefully it gets backported https://gitlab.freedesktop.org/mesa/mesa/-/issues/2877

If it doesn't maybe @philm can patch it in mesa

Removing openjpeg would also remove another AUR package that depends on openjpeg - would I have to change the dependencies of that package to openjpeg2 and recompile or something else?

Forum kindly sponsored by