[Stable Update] 2020-05-11 - Kernels, Systemd 245.5, Browsers, Thunderbird, Pamac, Deepin 20, Pamac 9.5

Thanks, worked perfectly.

To sum up what I did
sudo systemctl disable plymouth-start.service
sudo systemctl disable lightdm-plymouth.service
sudo systemctl enable lightdm.service
sudo pacman -R plymouth-theme-manjaro-elegant #dependancy!
sudo pacman -R plymouth
reboot

Edit:
Solved the issue for now.
Removal of plymouth hook from /etc/mkinitcpio.conf will be necessary in the future
see: https://wiki.manjaro.org/index.php?title=Plymouth#Removal

3 Likes

Updated 5 machines and everything was smooth.

Two installs both have the same problem. I think out difference might be that I am going through a gateway. Are you using RDP directly?

Updated two machines with KDE. No issues.

I had a similar lightdm/plymouth issue and basing on sum up by @gefri I manged to solve it.

Good on mine!

Thanx Manjaro Team!

(Still some KDE DM Freezing issues, but thinking that must be a hardware error somewhere.)

So a little more on the Deepin 20 update. Didn't seem real stable, overall look certainly wasn't an improvement and last and certainly not least, the User Experience reporting wouldn't uncheck, and
considering the host country of the distro, enough to do a clean install of the latest KDE distro, which
runs great.

Hello, I did a sudo pacman -R plymouth plymouth-theme-manjaro-elegant before the update, as advised, but got a black login screen.

Could start XFCE via startx but after that, plank does not start:

[CRITICAL 20:02:56.256801] [AbstractMain:255] Only X11 environments are supported.

How to properly run XFCE and plank again ?

I removed remmina and replaced it with the version in SNAP. Now it works.

1 Like

I have this exact same problem. Same error on boot and if I press alt + ctrl + F7 I get to the desktop without problems.
I also have that plymouth version installed.

Did you manage to fix this?

Seems we should readd a working Plymouth version. Will try to look into it this week.

1 Like

I'm on Manjaro KDE, I have two issues:

  1. After selecting update, I saw this in my Pamac:
conflicting files:
/usr/share/doc/manpages-zh/COPYRIGHT exists in both man-pages-zh_cn and man-pages-zh_tw

I think right now man-pages-zh_can and man-pages-zh_two are conflicting each other. I have to remove one of these packages to proceed the update.

  1. After the update, during the boot and shutdown, I saw
failed to start load apparmor profiles

Solution there: https://classicarchived.forum.manjaro.org/index.php?topic=14213.msg128429#msg128429

It's weird.

My servers and PC are connected to a router and i use Remmina 1:1.4.3-1 and Freerdp 2:2.1.0-1, both from the community repository.
Did you try a SSH connection to test Remmina ? Maybe the problem is Freerdp only.

ksysguard is not linked to the equivalent latest icu version.

[starterx4@doadgrz ~]$ ksysguard
ksysguard: error while loading shared libraries: libicui18n.so.65: cannot open shared object file: No such file or directory

Repository : extra
Name : ksysguard
Version : 5.18.5-1

Repository : core
Name : icu
Version : 67.1-1

Yup. You added that before I could reply.

Probably before the next update, you should remove the plymouth hook from mkinitcpio, regenerate initramfs for your various kernels, edit /etc/default/grub to remove the "quiet splash" kernel parameters, and update grub thereafter.

Correct, my initial post was a bit misleading.
The follow-up is important.

btw. thanks for your post getting people 'on track'

4 posts were split to a new topic: Boot loop after stable update 2020-05-11

I had the same problem as the other poster. The Plymouth boot screen kept randomly appearing.

Mine is also a several years old XFCE install.
I resolved it by following the 'known issues and solutions' at the top of the thread.

  • Ctrl + Alt + F3 and login
  • sudo pacman -R plymouth

After doing this and rebooting, the desktop wouldn't appear.
Then I reinstalled Plymouth.
Now it works again.

I don't know how to follow the final instruction:

  • you may want to check if the wanted display manager still works and enable its service if needed.

Do I need to install a replacement for Plymouth?

Thank you for the great distro! I'm always praising Manjaro to the masses.

Hello everyone,

after updating I encountered the following problem:
I turn on the PC. > Enter the password to decrypt the bootloader > Bootloader starts working but shows failures (see picture) > after some time the mouse cursor appears and shortly after the normal user login screen > I can log-in but takes much more time than normal > I seem to be logged in but have only a cursor and nothing else, just black screen


What I did so far:
chrooting into my encrypted system via livestick
pacman -Syyu or alike -> nothing to update here
sudo update-grub -> most things seem to work ok, but I get "grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check you device.map."

photo_2020-05-12_12-11-21

inxi:

12System: 12Host manjaro 12Kernel 5.6.11-1-MANJARO x86_64 12bits 64 12Console N/A 12Distro Manjaro Linux

12Machine: 12Type Laptop 12System LENOVO 12product 20ARS21P00 12v ThinkPad T440s 12serial
12Mobo LENOVO 12model 20ARS21P00 12v SDK0E50510 PRO 12serial 12UEFI LENOVO
12v GJET71WW (2.21 ) 12date 02/10/2014

12Battery: 12ID-1 BAT0 12charge 15.2 Wh 12condition 19.5/23.2 Wh (84%)
12ID-2 BAT1 12charge 57.0 Wh 12condition 71.8/71.1 Wh (101%)

12CPU: 12Topology Dual Core 12model Intel Core i5-4300U 12bits 64 12type MT MCP 12L2 cache 3072 KiB
12Speed 798 MHz 12min/max 800/2900 MHz 12Core speeds (MHz) 121 798 122 798 123 798 124 798

12Graphics: 12Device-1 Intel Haswell-ULT Integrated Graphics 12driver i915 12v kernel
12Display 12server X.org 1.20.8 12driver none 12tty N/A
12Message Advanced graphics data unavailable for root.

12Audio: 12Device-1 Intel Haswell-ULT HD Audio 12driver snd_hda_intel
12Device-2 Intel 8 Series HD Audio 12driver snd_hda_intel
12Sound Server ALSA 12v k5.6.11-1-MANJARO

12Network: 12Device-1 Intel Ethernet I218-LM 12driver e1000e
12IF enp0s25 12state down 12mac
12Device-2 Intel Wireless 7260 12driver iwlwifi
12IF wlp3s0 12state up 12mac
12IF-ID-1 wwp0s29u1u4 12state down 12mac

12Drives: 12Local Storage 12total 480.36 GiB 12used 33.08 GiB (6.9%)
12ID-1 /dev/sda 12vendor Samsung 12model SSD 860 EVO 500GB 12size 465.76 GiB
12ID-2 /dev/sdb 12type USB 12vendor Generic 12model Flash Disk 12size 14.60 GiB

12Partition: 12ID-1 / 12size 95.62 GiB 12used 32.91 GiB (34.4%) 12fs ext4 12dev /dev/dm-0

12Sensors: 12System Temperatures 12cpu 39.0 C 12mobo 0.0 C
12Fan Speeds (RPM) 12cpu 0

12Info: 12Processes 196 12Uptime 2h 17m 12Memory 11.58 GiB 12used 1.15 GiB (9.9%)
12Client Unknown Client: systemd 12inxi 3.0.37

(There are lots of "12" added before text, don't know what that is.)


EDIT: I think grub was totally the wrong direction. I got a work around from here which however did not solve the problem. Will make a thread about it.

Forum kindly sponsored by