[Stable Update] 2020-06-13 - Kernels, Systemd, Pamac, Cinnamon, Deepin, Firefox, Thunderbird, Qt, Kodi

Thank you again Manjaro for such an amazing distro! Keep it up and stay safe!

2 Likes

when would this update roll out?
qt 5.15 is required by some packages

Huh? :face_with_hand_over_mouth:

5 Likes

I have made an update on three computers:
2 * KDE and 1 * XFCE

I had an issue: update via tty1 and tried to start with "reboot" on tty1 and the computer did not restart. Hard reset and after that the computer works fine.

Thanks to the Manjaro Team!

1 Like

No problems here on three computers.
3 x KDE

Thanks to the Manjaro Team!

Is the Fix in the "samba" and "smbclient" packages included?

DK3

My wifi card still doesn't work with the last kernel (5.7.0-3), so I have to stay on 5.6.16-1.
The wifi card model:

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)

The log when I use the the last kernel:

13/06/20 11:01	kernel	------------[ cut here ]------------
13/06/20 11:01	kernel	WARNING: CPU: 4 PID: 438 at drivers/net/wireless/intel/iwlwifi/pcie/drv.c:1114 iwl_pci_probe+0x4a0/0x5c0 [iwlwifi]
13/06/20 11:01	kernel	Modules linked in: nls_iso8859_1 aesni_intel(+) snd_hwdep nls_cp437 ofpart vfat cmdlinepart crypto_simd cryptd intel_spi_pci fat snd_pcm fuse glue_helper pcc_cpufreq(-) fjes(-) acpi_cpufreq(-) iwlwifi(+) intel_spi intel_cstate snd_timer intel_uncore spi_nor i915(+) intel_rapl_perf psmouse input_leds pcspkr snd i2c_nvidia_gpu cfg80211 mtd soundcore i2c_i801 alx mei_me i2c_algo_bit intel_lpss_pci tpm_crb mdio intel_lpss mei intel_gtt rfkill intel_pch_thermal idma64 tpm_tis i2c_hid battery ac tpm_tis_core evdev tpm mac_hid wmi rng_core soc_button_array uinput nvidia_drm(POE) nvidia_modeset(POE) drm_kms_helper cec rc_core drm agpgart syscopyarea sysfillrect sysimgblt fb_sys_fops nvidia(POE) ipmi_devintf ipmi_msghandler sg crypto_user ip_tables x_tables hid_generic usbhid hid btrfs blake2b_generic libcrc32c crc32c_generic xor rtsx_usb_sdmmc mmc_core rtsx_usb raid6_pq serio_raw atkbd libps2 xhci_pci xhci_hcd i8042 serio crc32c_intel
13/06/20 11:01	kernel	CPU: 4 PID: 438 Comm: systemd-udevd Tainted: P           OE     5.7.0-3-MANJARO #1
13/06/20 11:01	kernel	Hardware name: Micro-Star International Co., Ltd. GE75 Raider 9SE/MS-17E2, BIOS E17E2IMS.117 08/20/2019
13/06/20 11:01	kernel	RIP: 0010:iwl_pci_probe+0x4a0/0x5c0 [iwlwifi]
13/06/20 11:01	kernel	Code: 8b 7d 38 41 81 f8 09 01 00 00 0f 84 9d 00 00 00 48 c7 c1 3e b5 36 c2 31 d2 31 f6 e8 0a bd ff ff b8 ea ff ff ff e9 36 fe ff ff <0f> 0b b8 ea ff ff ff 48 89 ef 89 44 24 04 e8 5d e5 00 00 8b 44 24
13/06/20 11:01	kernel	RSP: 0018:ffffb603c066fa90 EFLAGS: 00010246
13/06/20 11:01	kernel	RAX: ffffffffc2368800 RBX: ffff945b6a427000 RCX: 0000000000000031
13/06/20 11:01	kernel	RDX: 0000000000000000 RSI: ffffb603c080009c RDI: ffff945b5e4a0018
13/06/20 11:01	kernel	RBP: ffff945b5e4a0018 R08: 0000000000000105 R09: 000000046bc12414
13/06/20 11:01	kernel	R10: 0000000000000005 R11: ffffb603c066f8d8 R12: ffffffffc2368800
13/06/20 11:01	kernel	R13: ffff945b6a4270b0 R14: 0000000000000033 R15: 0000000000000000
13/06/20 11:01	kernel	FS:  00007f7dc30e4a80(0000) GS:ffff945b6db00000(0000) knlGS:0000000000000000
13/06/20 11:01	kernel	CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
13/06/20 11:01	kernel	CR2: 00005639930b0000 CR3: 00000004653b4002 CR4: 00000000003606e0
13/06/20 11:01	kernel	Call Trace:
13/06/20 11:01	kernel	 ? _raw_spin_unlock_irqrestore+0x20/0x40
13/06/20 11:01	kernel	 local_pci_probe+0x42/0x80
13/06/20 11:01	kernel	 ? pci_match_device+0xd7/0x100
13/06/20 11:01	kernel	 pci_device_probe+0xfa/0x1b0
13/06/20 11:01	kernel	 really_probe+0x167/0x410
13/06/20 11:01	kernel	 driver_probe_device+0xb6/0x100
13/06/20 11:01	kernel	 device_driver_attach+0xa1/0xb0
13/06/20 11:01	kernel	 __driver_attach+0x8a/0x150
13/06/20 11:01	kernel	 ? device_driver_attach+0xb0/0xb0
13/06/20 11:01	kernel	 ? device_driver_attach+0xb0/0xb0
13/06/20 11:01	kernel	 bus_for_each_dev+0x89/0xd0
13/06/20 11:01	kernel	 bus_add_driver+0x12b/0x1e0
13/06/20 11:01	kernel	 driver_register+0x8b/0xe0
13/06/20 11:01	kernel	 ? 0xffffffffc2395000
13/06/20 11:01	kernel	 iwl_pci_register_driver+0x21/0x40 [iwlwifi]
13/06/20 11:01	kernel	 iwl_drv_init+0x7f/0x1000 [iwlwifi]
13/06/20 11:01	kernel	 do_one_initcall+0x59/0x240
13/06/20 11:01	kernel	 do_init_module+0x5c/0x260
13/06/20 11:01	kernel	 load_module+0x2358/0x24c0
13/06/20 11:01	kernel	 __do_sys_init_module+0x172/0x1a0
13/06/20 11:01	kernel	 do_syscall_64+0x49/0x90
13/06/20 11:01	kernel	 entry_SYSCALL_64_after_hwframe+0x44/0xa9
13/06/20 11:01	kernel	RIP: 0033:0x7f7dc3fc773e
13/06/20 11:01	kernel	Code: 48 8b 0d 55 f7 0b 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa 49 89 ca b8 af 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 22 f7 0b 00 f7 d8 64 89 01 48
13/06/20 11:01	kernel	RSP: 002b:00007ffdd2ce38a8 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
13/06/20 11:01	kernel	RAX: ffffffffffffffda RBX: 00005639927abd30 RCX: 00007f7dc3fc773e
13/06/20 11:01	kernel	RDX: 00007f7dc3c5b97d RSI: 00000000000ba2f9 RDI: 0000563993159540
13/06/20 11:01	kernel	RBP: 0000563993159540 R08: 0000563992562ce0 R09: 00007ffdd2ce1a49
13/06/20 11:01	kernel	R10: 0000000000000003 R11: 0000000000000246 R12: 00007f7dc3c5b97d
13/06/20 11:01	kernel	R13: 0000000000000001 R14: 00005639927ac840 R15: 00005639927abd30
13/06/20 11:01	kernel	---[ end trace d3c3f119a95a2a96 ]---
13/06/20 11:01	kernel	iwlwifi: probe of 0000:00:14.3 failed with error -22

Edit: It seems to be a known problem that has been reported on both the arch forum and on the kernel's bugzilla

That one was already pushed out before the big Stable update was announced. If you had not booted up your computer until now, then naturally that too will be included.

We are back on the Arch upstream package. I've to check if it is still needed. What does the mailing list say?


Normally I've no time to track issues ...

r cannot be upgraded. I get the following message when running sudo pacman -Syyu:

error: failed to commit transaction (conflicting files)
r: /usr/lib/R/library/KernSmooth/po/it/LC_MESSAGES/R-KernSmooth.mo exists in filesystem
r: /usr/lib/R/library/MASS/po/it/LC_MESSAGES/R-MASS.mo exists in filesystem
r: /usr/lib/R/library/boot/po/it/LC_MESSAGES/R-boot.mo exists in filesystem
r: /usr/lib/R/library/foreign/po/it/LC_MESSAGES/R-foreign.mo exists in filesystem
r: /usr/lib/R/library/foreign/po/it/LC_MESSAGES/foreign.mo exists in filesystem
r: /usr/lib/R/library/nnet/po/it/LC_MESSAGES/R-nnet.mo exists in filesystem
r: /usr/lib/R/library/spatial/po/it/LC_MESSAGES/R-spatial.mo exists in filesystem
Errors occurred, no packages were upgraded.

The issue can be resolved with:

sudo pacman -Syu r --overwrite /usr/lib/R/library/\*

but this is the second or third time that an update to r has failed for this reason.

You can always check with pacman -Qo /usr/lib/R/library/KernSmooth/po/it/LC_MESSAGES/R-KernSmooth.mo to see which package is owning the file. Using overwrite should be avoided. Rather check the ownership of the file and remove them if not owned by another package.

Bit late now. I'll run that command when the updates filter down to Manjaro ARM, then report back. There's a chance that updating R's site packages by launching it as the root user may cause the file ownerships to change in the updated package libraries.

I just ran this command on my ARM laptop and x86_64 desktop.

On the desktop I just updated I get:

/usr/lib/R/library/KernSmooth/po/it/LC_MESSAGES/R-KernSmooth.mo is owned by r 4.0.1-1

On the laptop that has yet to have the update pushed out to the mirrors:

error: No package owns /usr/lib/R/library/KernSmooth/po/it/LC_MESSAGES/R-KernSmooth.mo

Smooth update on KDE machine. Many thanks Manjaro Team. :smile:

1 Like

Everything went fine, my wallpaper did change back to the default one.

Well done team Manjaro !
Another flawless update.

My system (roughly):

Laptop Asus ROG GL552VW optimus (Intel and nvidia card)
OS: KDE plasma 5.18.5
Kernel: 5.4.44 LTS

No issues here except for the annoying ...

sd-unmount[xxxx]: Failed to unmount /oldroot: Device or resource busy
sd-unmount[xxxx]: Failed to unmount /oldroot/sys: Device or resource busy
shutdown[1]:Failed to finalize file systems, ignoring

I thought it would have gone with the new systemd version but it is still here!
I searched all over the web and in particularly, manjaro and arch forums but haven't found any solution ...yet.

Thank you!

Add the shutdown hook to your /etc/mkinitcpio.conf and rebuild your initramfs ─ both the one for the running kernel and the fallback one.

There was a thread about this issue earlier, and the original poster marked my advice ─ the same as I'm giving you here ─ as the solution, so obviously adding the hook is what's needed. :man_shrugging:

1 Like

Updated 2 x Gnome (1 PC and 1VM) and 1 x KDE via TTY, no issues.

Keep up the good work!

Also (in addition to @Aragorn's post) you can resolve this with moving to systemd-based initramfs, which is possible with both mkinitcpio and dracut.

1 Like

Fresh install to a new machine, everything went fine. Thanks.

Forum kindly sponsored by