[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

That's a KDE issue, nothing to do with Manjaro.

Can confirm fonts looked a bit funny after installing the update, a simple "pacman -S ttf-dejavu" and a reboot fixed it right up

Just for the record. I had a problem with Plasma. My system didn't shut down properly. I had black screen after pressing switch off icon. But this solution solved the problem:

i have theses orphans

xorg-bdftopcf
xorg-font-util
xorg-mkfontscale

should i remove theses orphans

keep mkfontscale

I have an issue. I've run the update on a HP Elitebook that works with a docking station. When plugged in to the docking station, the laptop doesn't boot anymore (it is stuck in the black "HP Sure Start" screen and doesn't seem to load SDDM). Now, in order to switch it on, I have to unplug it from the docking station, log in and only then connect it back to the docking station. Besides, when connecting, some effects are disabled and I have to press Alt + Shift + F12 to enable them again. This issue occurs with kernels 5.6.19 and 5.7.9. I've installed also kernel 5.4.52 LTS and with this boot works fine. But then I have issues with mic/audio (see here: No sound card found - HP Elitebook).

Any hint?

Hi 10yearslate,

I think I have the same bug as you. Encountered on my two different machines (laptops).

Sometimes when I log out of the session (1 or 2 times in a row), I get a black screen with the mouse pointer, and the system takes a long time to get back to the login screen. Then, when I try to restart the system, it's again a black screen that appears, and the system seems frozen. On one of the machines, the CPU fan races from time to time during this phase. It forces me to use the magic keys. FYI, I'm on Manjaro 20.1-rc1 KDE with all the latest updates. One of the machines has an Intel graphics card only, and the other has Optimus technology (Intel / Nvidia) with the opensource drivers. Kernel installed (5.7.9). I use the lock/logout plasma applet to logout of the session because the launchpad plasma is my menu.

So, do we have to wait an update of KDE version to fix this problem ?

Otherwise everything works.

On KDE. I previously set up hotkeys to cycle through activities. The Activities Pager widget would pop out of the taskbar, show the current activity, and after I stopped cycling, would autohide.

Now, the widget won't autohide. I've had to right-click on the widget, then left click on "show Activity Manager" to toggle it off.

If I right-click on the Activity Manager widget in the taskbar, click "show Activity Manager," and use the mouse to pick one, the widget autohides.

I can also left-click on the really small icons for each activity in the widget in the taskbar and get there directly. But a couple of hotkeys are much quicker and easier.

I tried alternative widgets: 'Activities' and 'Activity Bar' also failed to autohide after hotkey switching.

1 Like

Okay, so I tried removing ttf-bitstream-vera before shutting down the PC last night to see if anything changes. I just turned the PC on, and the font size on the password field is still bigger than what it used to be. It's not worth making any fuss out of though, since it's only useful for seeing how many characters I have punched in and I can still do that with the slightly bigger fonts. Thanks for the input, though.

Yes, I had something like this. Using Meta-Tab cycles but doesn't exit now - I'm guessing that's a bug (no widget installed, that's just a pop-up sidepanel).

However, I also decided to use a mouse shortcut for presenting activities instead of presenting desktops/windows... so I changed my '' stroke to Meta+Q.

That toggles the sidepanel for choosing activities - toggle on, click and it goes away... good as a mouse gesture.

finally got around to installing it and rebooted maybe I got lucky but I didn't notice any issues after reboot on kde.

Yes, they're safe to remove.

Why? If it's an orphan, it's an orphan. Nothing requires it on my system.

Still new to Manjaro and Linux in general (~3 months), so I don't expect anything to work without learning this or the other lesson ... and so it happened with this update.

I'm mounting a Netgear Nas via fstab (cifs) with the usual options (one of them being 'x-systemd.requires=network-online.target'), and after updating (I was already running kernel 5.7), I ran into a systemd cycle. Found out how to fix that (had to change the mentioned mount param to 'x-systemd.after=network-online.target').

But after that, the whole system got glitchy.

One problem was (harmless) defects in theming - in some dialogs, I could hardly read texts because of lack of contrast. Also, something was wrong with fonts - but I didn't start looking into it.

Much more severely:

  • One of my online accounts (nextcloud) kept loosing it's credentials after rebooting
  • In random situations when working with Nautilus, GDM would freeze completely. The journal shows "gvfsd[15976]: Error calling org.gtk.vfs.MonitorClient.Changed(): Timeout was reached (g-io-error-quark, 24)". This did not happen before the update.

Went back to the previous state via Timeshift (another lesson from a failure in the past ;-)). Only to notice the same glitches.

Tried a couple of things since, including emptying the trashes on the NAS. Still investigating. My journal showed several errors even before the update, and I did pick tricky hardware for my build, it seems. So all that makes troubleshooting a bit difficult, and thus, I'm not calling out for help, but merely wanted to share my experience.

I'm pretty sure I'll learn a lot of interesting things until I find the solution :slight_smile:

Meanwhile, seeing here that there are some issues for some people with this update, I'll try to keep my old system state, continue learning (and hopefully solve the issue with my NAS which is probably not really caused by the update), and only do an update when I notice some more things have been fixed.

It's a bit painful for sure, but don't get me wrong: I'm still enjoying my Manjaro very much!

1 Like

This is quite common after an upgrade, in my experience.

I solved this by restoring desktop effects default then tweaking/enabling/disabling some of them. I guess you just need to let KDE rewrite the config file.

1 Like

Automatically installing half-baked meta packages is bad UX. This needs to be fixed @philm

I was working on configuring the widgets today, as the old temp locks plasma. This new concept to have generic sensor widgets and the user adds the sensors they want is not a bad idea, but it is really early days. You are right, making changes can cause plasma or the widget to crash. Older widgets dissapear and reappear. They widgets arent very customizable from the users perspective either (fonts size, labels, etc.) Hopefully KDE updates plasma soon.

One more thing, they need to set up locking again. I have a few widgets that are interactive but if you go to move the slider, it unlocks the widget and moves the widget because it is a long press.

Here is a discussion about the widget sensor issues on Reddit, https://www.reddit.com/r/kde/comments/h15j0h/system_monitor_widgets/

you need mkfontscale when installing new fonts. Otherwise you wont get all fonts registered. Example would be misc fonts on i3.

This KDE update is just trash. No wonder stable was held back for so long.

3 Likes

So do we have to mark this package as explicitly installed? Up to now I installed new fonts by refreshing the font cache with fc-cache from the fontconfig package, which does not need mkfontscale. Where exactly is mkfontscale needed here and when is it called, if no other package needs it?

Forum kindly sponsored by