[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

Neither kwin nor plasmashell launch on login, when I try to launch kwin_x11 manually I get a libkwin5 so error.

The error specifically is kwin symbol lookup error in /usr/lib/libkwin5 so, undefined symbol, and the undefined symbol is something About Znk Wayland server, I don't even have Wayland installed.

Because built-in support for OpenPGP isn't (production) ready yet - but enigmail will not work anymore either:

3 Likes

I've not idea how to troubleshoot this

Everything seems to be working, so far, here on KDE.
No tray icon issues, and I had pre-emptively installed ttf-dejavu.
No transparency issues, like some have reported.
But I did have my Formats reset.

I got the impression it's a pamac problem rather than being kde's fault?
edit: not sure about that, something fishy is going on:

I can't judge that.
Das kann ich nicht beurteilen.

Precise and full error messages are important, do try to copy+paste them.
Library problems (mismatches?) are almost always some kind of partial update, be sure your mirror is up-to-date and you got/installed all updates.
When in doubt refresh your mirror list and update (again):

$ sudo pacman-mirrors -f5 && sudo pacman -Syu

I am unable to copy paste, kwin doesn't start and neither does its clipboard service.

And updating my mirrors didn't help either

Just noticed the same thing, it's very dim.

I refreshed my mirrors and re updated-- no effect. Was unable to get to forum manjaro on my laptop to paste the error message here.

kwin_x11: symbol lookup error: /usr/lib/libkwin.so.5: undefined symbol: _ZNK14KWaylandServer22XdgShellPopupInterface7surfaceEv
is the error message, I was able to take a smartphone picture of it and use Google Lens to transcribe it.

Just updated on Lenovo T420s with Linux 5.7 and i3-wm. All went great.

Thank you, Manjaro Team!

Package Manager icon has low resolution and its contextual menu has one empty added item

Screenshot_20200719_200003

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.72.0
Qt Version: 5.15.0
Kernel Version: 5.7.9-1-MANJARO
OS Type: 64-bit
1 Like

Ok, I tried to set Formats as they were before (fi_FI) under KDE's Regional Settings -> Formats.
I had trouble logging back in after logout, so I had to reboot the system. Now the Pamac tray icon is dark, just like many have reported.

I have Formats as fi_FI in both Manjaro and KDE settings, since Manjaro ones didn't seem to affect KDE ones anymore.

Edit: The context menu of the Pacman icon has excess space, like in the screenshot by medmedin.

Edit2: I tried going back to en_GB formats, the Pamac icon is still black. I also removed orphans after the update. Maybe some of those shouldn't be orphans after all?

sudo pacman -Rs $(pacman -Qdtq)
[2020-07-19T21:51:13+0300] [PACMAN] Running 'pacman -Rs python-pytoml xorg-font-utils xorg-fonts-alias'
[2020-07-19T21:51:22+0300] [ALPM] transaction started
[2020-07-19T21:51:22+0300] [ALPM] removed xorg-fonts-alias (1.0.3-3)
[2020-07-19T21:51:22+0300] [ALPM] removed xorg-font-utils (7.6-6)
[2020-07-19T21:51:22+0300] [ALPM] removed xorg-mkfontscale (1.2.1-2)
[2020-07-19T21:51:22+0300] [ALPM] removed xorg-font-util (1.3.2-2)
[2020-07-19T21:51:22+0300] [ALPM] removed xorg-bdftopcf (1.1-2)
[2020-07-19T21:51:22+0300] [ALPM] removed python-pytoml (0.1.21-4)
[2020-07-19T21:51:22+0300] [ALPM] transaction completed
[2020-07-19T21:51:22+0300] [ALPM] running '30-systemd-update.hook'...
[2020-07-19T21:51:22+0300] [ALPM] running 'fontconfig.hook'...
[2020-07-19T21:51:22+0300] [ALPM] running 'fontconfig-32.hook'...

Same for me. Got even worse performance with fsync enabled in wine.

A bit off topic but how do I get those colorful icons?

I use dark breeze icon theme.

1 Like

Forum kindly sponsored by