[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

Same here.

Hi!

Just to report a small bug, after this upgrade and a reboot, the X server didn't start with the kernel 5.7 (but does with 5.6). The solution I found was to install manually linux-latest-nvidia-440xx.

Tell me if you want more information :slight_smile:

Just had multiple X session freeze up completely under high CPU load with the linux57 kernel, not alleviated by removing said CPU load. Machine is still responsive to SSH though.

Will now test if the same thing happens under linux56. But this certainly didn't happen before the update.

Update 1: Crash under linux57 just happened with barely any CPU load.

Update 2: X session feels a bit less smooth under linux56, but at least it runs without crashing.
Something is definitely broken for linux57 on my system.

CPU: IntelÂź Core i7-4790K
Mainboard: ASUS Z97-PRO GAMER
Graphics card: AMD Radeon RX 480

^ from a hardware POV, this seem to be the only components that might cause these crashes.
Idk what the changes in the kernel do to cause these crashes.

Update 3:

$ cat /var/log/Xorg.0.log.old | grep "(EE)" (with this logfile being the old one because I'm viewing this from a linux56 boot)

shows the following line:

[ 99.811] (EE) AMDGPU(0): drmmode_do_crtc_dpms cannot get last vblank counter

So, linux57 introduces some issue with AMDGPU now... Going to stay on linux56 in the meantime.

Update 4:

The error message spit into the Xorg.0.log seems to differ with every crash.
With additional tests, I now also got

[   500.224] (EE) client bug: timer event28 debounce short: scheduled expiry is in the past (-1ms), your system is too slow
[  1113.291] (EE) client bug: timer event28 debounce short: scheduled expiry is in the past (-0ms), your system is too slow

I probably should also mention that I can't (visibly) switch to tty when this happens. The only reliable way to reboot is a REISUB.

xps9550,linux419,KDE,smooth update :+1:

But... python2-pillow (not pillow6) is required by calibre !

pacman -Si calibre
DĂ©pĂŽt                    : community
Nom                      : calibre
Version                  : 4.20.0-1
Description              : Ebook management application (python2 build)
Architecture             : x86_64
URL                      : https://calibre-ebook.com/
Licences                 : GPL3
Groupes                  : --
Fournit                  : --
DĂ©pend de                : calibre-common  python2-apsw  python2-beautifulsoup4  python2-cssselect  python2-css-parser
                           python2-dateutil  python2-dbus  python2-dnspython  python2-feedparser  python2-html2text
                           python2-html5-parser  python2-lxml  python2-markdown  python2-mechanize  python2-msgpack
                           python2-netifaces  python2-unrardll  python2-pillow  python2-psutil  python2-pychm  python2-pygments
                           python2-pyqt5  python2-pyqtwebengine  python2-regex  python2-ipaddress
DĂ©pendances opt.         : ipython2: to use calibre-debug
Est en conflit avec      : --
Remplace                 : --
Taille du téléchargement : 5,05 MiB
Taille installée         : 37,52 MiB
Paqueteur                : Eli Schwartz <eschwartz@archlinux.org>
Compilé le               : ven 03 jui 2020 19:01:45
Validé par               : Somme MD5  Somme SHA-256  Signature

Does it mean that from now on calibre cannot be installed ?

I tried install python2-pillow6, then python2-pillow which worked.

Update finished, Calibre's running and I have python2-pillow6 installed.

Run Timeshift to make a snapshot, then run 'flatpak update' to check everything's updated.

IMO better than just 'flatpak update' you could install topgrade and use that - updates snaps and a few other things too.

pacman -S topgrade
topgrade

I have not launched this update by now and the font of my xfce4-terminal (version 0.8.9.2) is also Monospace Regular size 12...

And if the icon were hidden, when I right-click this icon in the hide icon panel, the panel will quickly retract.

1x Xfce on a Thinkpad X1 6th Gen (Type 20KG) and Kernel 5.6.16 (updated to 5.6.19) using the package manager in Xfce - worked fine as far as I can see and test at the moment

1x Xfce on a X570 AMD 9 3900X with 5700XT and Kernel 5.7.0 (updated to 5.7.9) using the package manager in Xfce (with steam and games and more software) - worked fine as far as I can see and test at the moment

You could change to calibre-python3 since python2 is no longer supported.

2 community/calibre-common 4.20.0-1 (24.3 MiB 53.1 MiB) (Installed)
Ebook management application (common files)
1 community/calibre 4.20.0-1 (5.1 MiB 37.5 MiB) (Installed)
Ebook management application (python2 build)

No issues with Calibre here...

Thanks for the advice : I will do it.

But the question still remains.
In the stable repository there is a package named calibre ; this package depends on python2-pillow that doesn't exist anymore in the repository. My conclusion (unless something eludes me) is that the calibre package cannot be installed.

If that is right, there is a broken calibre package in the repository.

But what exactly do you mean by that ? I haven't got any problem with calibre either since I installed it a long time ago. The question is whether it can be installed now by a new user !

I've updated my computers running Manjaro KDE. After the update I've had the same issue that the 2020-06-16 Testing Update: The systray applet icons have gone away despite I mark as "always show", only appears the MSM.

I think I'm the culprit because some time ago I played with the systray icons, I modified its spacing by messing with the main.qml file inside this location:

plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/

I've deleted the folder org.kde.plasma.private.systemtray located on:

/.local/share/plasma/plasmoids/

Logout and login and fixed the issue. Lesson learned, only touch system files when it's really needed.

Regards!! :grinning:

This completely broke qt5 rendering in my deepin de. I have no control over size or location of qt app windows and none of my desktop kwin settings are being honored and my dock does not launch upon start up I have to end the process and it launched correctly after it auto spawns. Running 5.6.17-2rt9 here

I never removed that patch. But feel free to add it @philm
The cleanup only removes outdated patches from the repo which the PKGBUILD no longer uses.

After this update - from a fresh installed manjaro stable "gnome"
GDM did not start. Made 3 times new installation on a new machine (B550-Board)
Some kernels except 5.6

Minor AUR-related issue:
It appears that eigen no longer provides eigen3 which broke gnudatalanguage dependencies. (Simple fix in the gnudatalanguage PKGBUILD of changing the dependency).

Hi,

@Manjaro Team:

I tried your new Manjaro 20.1-rc1 KDE version. No problem with the installation and the system works well, but I encounter two problems:

  1. LibreOffice 6.4.5 wasn't available in the stable branch when I installed the rc1, so I installed the libreoffice version proposed : 6.4.3. I received these errors during the installation of libreoffice:

Updating TeXLive format files...
xetex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
xetex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
xetex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
xetex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
xetex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
pdftex: error while loading shared libraries: libpoppler.so.99: cannot open shared object file: No such file or directory
Error setting up
fmtutil [ERROR]: running xetex -ini -jobname=xetex -progname=xetex -etex xetex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=pdftex -progname=pdftex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running pdftex -ini -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=mptopdf -progname=context -translate-file=cp227.tcx mptopdf.tex </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running pdftex -ini -jobname=pdfetex -progname=pdfetex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=utf8mex -progname=utf8mex -enc *utf8mex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running xetex -ini -jobname=pdfcsplain -progname=pdfcsplain -etex csplain.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=pdfcsplain -progname=pdfcsplain -etex -enc csplain-utf8.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running xetex -ini -jobname=xelatex-dev -progname=xelatex-dev -etex xelatex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=csplain -progname=csplain -etex -enc csplain-utf8.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=pdfcslatex -progname=pdfcslatex -etex cslatex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running pdftex -ini -jobname=mex -progname=mex -translate-file=cp227.tcx *mex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=cont-en -progname=context -8bit *cont-en.mkii </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running xetex -ini -jobname=cont-en -progname=context -8bit *cont-en.mkii </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=cslatex -progname=cslatex -etex cslatex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running pdftex -ini -jobname=etex -progname=etex -translate-file=cp227.tcx *etex.ini </dev/null' return status 127 Error setting up fmtutil [ERROR]: return error due to options --strict Error setting up fmtutil [ERROR]: running pdftex -ini -jobname=pdfmex -progname=pdfmex -translate-file=cp227.tcx *pdfmex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
fmtutil [ERROR]: running `pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini </dev/null' return status 127
Error setting up
fmtutil [ERROR]: return error due to options --strict
Error setting up
Error: the command could not be executed correctly
Updating TeXLive font maps...
Updating the desktop file MIME type cache...
Updating the MIME type database...

  1. I can't install Gimp 2.10. Each time I receive that kind of message:

Install popple(0.88.0-1) breaks the popple dependance=0.90.1 requise by popple - remove popple-qt5 and retry.

It seems to be a problem with poppler.

As you put new updates in the stable branch, I will see if I must do updates. If I've got errors I will come back.

Regards.

Forum kindly sponsored by