[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

I have Manjaro KDE, but use i3 as my main WM. The update wanted to replace xorg-font-utils with xorg-font-utils-misc, which I accepted. Now the fonts are off in dmenu, kitty and possibly other places. Any fix for this?

Please read the Known Issues post. It's there for a reason.

3 Likes

Hello,
There is a little display bug with the KDE Breath2 dark theme: the redshift and pamac icons are now black instead of white. You can see them between the bin and the clipboard.
icons

Otherwise, everything is fine.

2 Likes

A smooth, trouble-free update to three Manjaro KDE 5.4.x LTS machines! Thanks to the Manjaro team!

Updated two Xfce machines. Mac mini went smoothly. Lenovo IdeaPad got stuck booting right after update. I finally powered it off with the switch and restarted. Since then, it's booting up like normal.

telegram is not following gtk theme anymore image fixed with settings

activities screen in gnome is completely bugged and unusable now grafik
it will work once, but any time after that it will show whats on the screenshot

edit: journalctl gives this warning when i open activity

JS ERROR: TypeError: area is null
padArea@resource:///org/gnome/shell/ui/workspace.js:1101:9
_updateWindowPositions@resource:///org/gnome/shell/ui/workspace.js:1334:20
_realRecalculateWindowPositions@resource:///org/gnome/shell/ui/workspace.js:1311:14
_recalculateWindowPositions/this._positionWindowsId<@resource:///org/gnome/shell/ui/workspace.js:1286:18

JS ERROR: TypeError: area is null
padArea@resource:///org/gnome/shell/ui/workspace.js:1101:9
_updateWindowPositions@resource:///org/gnome/shell/ui/workspace.js:1334:20
_realRecalculateWindowPositions@resource:///org/gnome/shell/ui/workspace.js:1311:14
_recalculateWindowPositions/this._positionWindowsId<@resource:///org/gnome/shell/ui/workspace.js:1286:18

Go to your icon theme folder edit index.theme and set: FollowsColorScheme=true to FollowsColorScheme=false

Works most of the time.

3 Likes
sudo pacman-mirrors --fasttrack 5
sudo pacman -Syyu

Hi,

Something went wrong during the update, now it works.

(442/442) checking package integrity                                [#####################################] 100%
error: manjaro-arm-tools-git: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is invalid
:: File /var/cache/pacman/pkg/manjaro-arm-tools-git-2.8.6.r3.ga4db587-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[nicolas@nls-pc ~]$ sudo pacman -Syyuu
[sudo] password for nicolas: 
:: Synchronising package databases...
 core                                   171,4 KiB  1394 KiB/s 00:00 [#####################################] 100%
 extra                                 2007,3 KiB  1487 KiB/s 00:01 [#####################################] 100%
 community                                6,1 MiB  1257 KiB/s 00:05 [#####################################] 100%
 multilib                               195,2 KiB  1727 KiB/s 00:00 [#####################################] 100%
 manjaro-strit                           14,1 KiB   319 KiB/s 00:00 [#####################################] 100%
:: Starting full system upgrade...
:: Replace intel-tbb with extra/tbb? [Y/n] y
warning: manjaro-arm-tools-git: downgrading from version 2.8.6.r4.g3f2e271-1 to version 2.8.6.r3.ga4db587-1
resolving dependencies..

Thanks! I'll try to pay more attention next time!

I no longer have any sound after the update. It says there are no output or input devices found. Further the update icon has changed and the time is displayed really small.

I'm on kernel 5.7.9 ManjaroKDE

Edit: Sound magically returned

I've got the message
python2-pillow6 und python2-pillow stehen miteinander in Konflikt

This isn't in the repos or the AUR so you can probably replace it with the other package without issue.

1 Like

Thank You

Settings > Advanced > System integration > Use system window frame

3 Likes

Would this be problematic?

Preparing...
Synchronizing package databases...
https://manjaro.mirrors.lavatech.top/stable/multilib/x86_64/multilib.db: Socket I/O timed out
Resolving dependencies...
Checking inter-conflicts...
Warning: dependency cycle detected:
Warning: bashrc-manjaro will be installed before its bash dependency
Warning: dependency cycle detected:
Warning: mesa will be installed before its libglvnd dependency
Warning: dependency cycle detected:
Warning: nvidia-440xx-utils will be installed before its libglvnd dependency
Warning: dependency cycle detected:
Warning: usbmuxd will be installed before its libimobiledevice dependency
Warning: dependency cycle detected:
Warning: lib32-mesa will be installed before its lib32-libglvnd dependency
Warning: dependency cycle detected:
Warning: lib32-nvidia-440xx-utils will be installed before its lib32-libglvnd dependency
Transaction cancelled.

Thanks.

Hi!
So far so good x2!!
PC plasma 5.19.3 kernel 5.7.9 nvidia 440.100
Laptop plasma 5.19.3 kernel 5.7.9 amd/nvidia 440.100
Just show up a new hybrid amd/nvidia 440.100 driver, until now I'm using optimus switch, I'll try the new driver later

This update is so GREAT! But, for some reason Fsync doesn't work. Anyone got it working? I indeed use the linux57 kernel.

2 Likes

Plasma tray icon size became little bit bigger. And space between icons became narrower. Somewhat ugly than before. I'm using 4k display and 250% display scale. Fonts dpi 240.

Screenshot_20200720_005812

Thanks for update.

1 Like

Hi Phil,

Thanks for the stable update :slight_smile:

Also, minor typo:

Forum kindly sponsored by