[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

All good here, except that the icon for pamac-manager on the task bar is suddenly low-res for some reason.

1 Like

Mine is gone.

1 Like

Another one:

Transmission doesn't start:

[inigo@azkar ~]$ transmission-qt
[warn] Unable to parse nameserver address fe80::1%enp5s0
couldn't register com.transmissionbt.Transmission

Trying to update Dump your "inxi -Fxxxza --no-host" here and bookmark it

I use pinxi, instead of inxi:

# pinxi -Fxzc0
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "nl_NL.UTF-8",
        LC_NAME = "nl_NL.UTF-8",
        LC_MONETARY = "en_NL.UTF-8",
        LC_PAPER = "nl_NL.UTF-8",
        LC_IDENTIFICATION = "nl_NL.UTF-8",
        LC_TELEPHONE = "nl_NL.UTF-8",
        LC_MEASUREMENT = "en_NL.UTF-8",
        LC_TIME = "en_NL.UTF-8",
        LC_NUMERIC = "en_NL.UTF-8",
        LANG = "en_NL.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

pinxi is not in repo anymore?

Edit:
Tried inxi, gives same result as pinxi but inxi is in repo.
Edit 2:
Another reboot, all ok now.

SUPER
This update fixed the rendering issues of GTK apps running in the KDE DE.

Hi! anyone has tried hybrid-video-amd-nvidia-440-100 driver?

Cinnamon 5.4 kernel, zero issues. Despite all the worry by some about how long it took, clearly this was done well. Stable in fact should be stable. Thanks for another trouble free update.

Just did the update with KDE - reboot - now my icon from Pamac looks like this in the systray:

Screenshot_20200719_200543

Just went back to KDE, I think that was another mistake ... :face_with_raised_eyebrow:

1 Like

Known bug, it was not considered a blocker.

Pamac icon now properly disappears when there is no update if you have selected the setting to hide icon in Pamac Settings. I think previously it was only hiding inside the taskbar hidden icons and was visible if you expanded the hidden icons list, now it completely disappears if there is no system update.

Pamac icon now is low resolution though I can confirm that

Screenshot_20200719_201559

KDE suddenly stops and nothing happens after the update.
If i logged in using kde the whole desktop will stop and hangs after 5 seconds, but if logged in using tty2 nothing happens and the system keeps running.
i use kernel 5.4 and linux-nvidia-440 with the latest updates from today.

This post was flagged by the community and is temporarily hidden.

I have just installed the update. All went fine.
I have faced a minor issue with Grub bootloader and I was able to solve it.

My setup:

  • Nvidia (property drivers, prime, 440.100-4)
  • KDE
  • Kernel: 5.4.52-1-MANJARO

The Issue:
Grub resolution (GFXMODE) got messed up after the update.
It seems like GFXMODE cannot be auto-set any more.

Solution:
Login as root and edit:

nano /etc/default/grub

Search for following line:

GRUB_GFXMODE=auto

You will need to update GFXMODE. Seems like 'auto' fails to auto-set proper mode.
Insert desired resolution mode before the 'auto' (make sure you set proper resolution, note the comma before the 'auto'):

GRUB_GFXMODE=1920x1080x32,auto

Save the file and update grub with following command:

update-grub

Read the output, make sure no errors are thrown and reboot your system.

5 Likes

KDE Plasma update went fine.

So I went for changing the space between the the tray icons annd to my horror this part was edited out:

//Main Layout
    Flow {
        id: tasksRow
        spacing: 15
        height: parent.height - (vertical && expander.visible ? expander.heig>
        width: parent.width - (vertical || !expander.visible ? 0 : expander.w>
        property string skipItems
        flow: vertical ? Flow.LeftToRight : Flow.TopToBottom
        //To make it look centered
        y: Math.round(height/2 - childrenRect.height/2)
        x: (expander.visible && LayoutMirroring.enabled ? expander.width : 0)>


        //Do spacing with margins, to correctly compute the number of lines
        property QtObject marginHints: QtObject {
            property int left: Math.round(units.smallSpacing / 2)
            property int top: Math.round(units.smallSpacing / 2)
            property int right: Math.round(units.smallSpacing / 2)
            property int bottom: Math.round(units.smallSpacing / 2)
        }

So I try to change row space in the new:

 //Main Layout
    GridLayout {
        id: mainLayout

        rowSpacing: 0
        columnSpacing: 0
        anchors.fill: parent
etc.

But changing the numbers don't do anything.

Now that you mention it, same here.

Neither kwin nor plasmashell launch on login, when I try to launch kwin_x11 manually I get a libkwin5 so error.

The error specifically is kwin symbol lookup error in /usr/lib/libkwin5 so, undefined symbol, and the undefined symbol is something About Znk Wayland server, I don't even have Wayland installed.

Because built-in support for OpenPGP isn't (production) ready yet - but enigmail will not work anymore either:

3 Likes

I've not idea how to troubleshoot this

Everything seems to be working, so far, here on KDE.
No tray icon issues, and I had pre-emptively installed ttf-dejavu.
No transparency issues, like some have reported.
But I did have my Formats reset.

Forum kindly sponsored by