Startup notify missing

After the big stable update around the 29th of Oct, the StartupNotify animation doesn't work anymore where the application that's being launched's icon bounces under the cursor. Even if though its .desktop has StartupNotify=true. Is this a bug in this plasma update? After another update wave of around 84 packages today, it's still the same. I know it's got to be caused by that stable update, because it worked fine before on both my main pc and laptop.

Here's my inxi just in case:

System:    Host: Kiko-LM Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Console: tty 1 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: AB350M-HD3 v: N/A serial: N/A 
           Mobo: Gigabyte model: AB350M-HD3-CF v: se1 serial: N/A UEFI: American Megatrends v: F42a date: 07/31/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L1 cache: 768 KiB 
           L2 cache: 4096 KiB L3 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95848 
           Speed: 1855 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 2287 2: 1277 3: 2926 4: 1273 5: 2134 
           6: 2237 7: 1293 8: 1317 9: 2557 10: 1277 11: 2426 12: 2219 13: 1296 14: 1300 15: 2909 16: 1276 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nvidia v: 440.26 bus ID: 06:00.0 
           chip ID: 10de:13c2 
           Display: server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 440.26 direct render: Yes 
Audio:     Device-1: NVIDIA GM204 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 06:00.1 
           chip ID: 10de:0fbb 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 08:00.3 chip ID: 1022:1457 
           Device-3: Logitech [G533 Wireless Headset Dongle] type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 
           chip ID: 046d:0a66 
           Sound Server: ALSA v: k5.3.8-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 7.73 TiB used: 3.11 TiB (40.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST8000DM004-2CX188 size: 7.28 TiB speed: 6.0 Gb/s rotation: 5425 rpm 
           serial: <filter> rev: 0001 scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WDS500G2B0B-00YS70 size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 00WD scheme: GPT 
RAID:      Device-1: ZFS type: zfs status: ONLINE raid: no-raid size: 7.27 TiB free: 4.13 TiB allocated: 3.13 TiB Components: 
           online: N/A 
Partition: ID-1: / size: 92.48 GiB used: 67.12 GiB (72.6%) fs: ext4 dev: /dev/sdb7 
           ID-2: swap-1 size: 5.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb6 
Sensors:   System Temperatures: cpu: 34.4 C mobo: N/A gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 34% 
Info:      Processes: 437 Uptime: 3h 17m Memory: 15.65 GiB used: 5.25 GiB (33.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: bash (sudo) v: 5.0.11 running in: yakuake inxi: 3.0.36 

(in the future please use inxi -Fxxxza --no-host)

Also - It works here on Unstable [Plasma 5.17.2]

System Settings >Applications > Launch Feedback

It's enabled but not working Screenshot_20191106_010224

What about what version of plasma you have ?

It says KDE Plasma 5.17.2

Well I hate to bump this, but are there any other suggestions? After another stable update that brought plasma to 5.17.3 and even after I tried to disable and re-enable the launch feedback option, nothing's changed. The only thing I noticed is that when I manually disable the animation in the settings above, not even a circle appears on the icon of the program I'm launching in the taskbar. So this bug only removes the cursor feedback animation, the other half of the launch feedback is still present.

There is a bug in Plasma with the launch feedback animation.

Go into System Settings and change the mouse cursor size from "Resolution dependent" to a fixed size, that should get you your bounce back :grin:.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by