Steam Unable to Boot Dark Souls II

I've run steam with a few games already such as Final Fantasy III and Alan Wake, but I can't get steam to boot. It'll boot to a white screen in windowed mode and then the window closes. I'm not sure how to check the steam logs, and if it helps I'm using 'primusrun %command%' in the properties of the game (though this issue occurred before and after this). I'm also running on the Dell XPS 9560 with bumblebee for my nvidia driver.

To see some output in steam run it in a terminal. (Just open a terminal type steam and hit enter.) Wait for steam to launch properly and look in the terminal to see where the output ends. Assuming steam itself runs okay (this was not clear to me) then launch Dark Souls II and see what else is in the output.

According to it should more or less work.

1 Like

steam also logs things itself by default.
I'm too busy to look it up for you right now.

magnanimous of you :wink:

There are various logs kept by steam itself in /home/USERNAME/.steam/steam/logs/, in fact 15 updated when I ran steam earlier today. Although there is generally not much of use in them unless you already know approximately what you are looking for. (Maybe you can add more?)

A lot of games also keep their own logs (of game problems rather than steam ones) in their own locations, often somewhere like /home/USERNAME/Documents/GAMENAME/ or /home/USERNAME/Documents/My Games/GAMENAME/.

Here though I suspect it may be a case of a missing library on the Manjaro side. Regardless the terminal output is likely to be of much more use, at least for the early stages of diagnosis/triage.

Have you tried switching proton versions in the Steam settings?

I have tried running it with both non-beta versions of proton. This game worked previously when I was using ubuntu without issues.

When I ran it from steam it gave the following issues:

>>> Adding process 4163 for game ID 335300
GameAction [AppID 335300, ActionID 1] : LaunchApp changed task to WaitingGameWindow with ""
GameAction [AppID 335300, ActionID 1] : LaunchApp changed task to Completed with ""
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4164 for game ID 335300
JS method call SharedConnection.SendMsgAndAwaitResponse with 3 arguments
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4215 for game ID 335300
>>> Adding process 4216 for game ID 335300
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4218 for game ID 335300
>>> Adding process 4221 for game ID 335300
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4223 for game ID 335300
>>> Adding process 4226 for game ID 335300
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4235 for game ID 335300
>>> Adding process 4240 for game ID 335300
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4246 for game ID 335300
Game update: AppID 335300 "", ProcID 4216, IP
Xlib:  extension "NV-GLX" missing on display ":0".
Game update: AppID 335300 "", ProcID 4216, IP
Xlib:  extension "NV-GLX" missing on display ":0".
wine: Unhandled page fault on read access to 0x00000000 at address 0x14095825b (thread 0024), starting debugger...
ERROR: object '/home/robert/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 4256 for game ID 335300
Unhandled exception: page fault on read access to 0x00000000 in 64-bit code (0x000000014095825b).
Register dump:
 rip:000000014095825b rsp:000000000022ee20 rbp:000000000022ef20 eflags:00010202 (  R- --  I   - - - )
 rax:0000000000000000 rbx:0000000000000000 rcx:0000000000000000 rdx:00000000005000b0
 rsi:000000000022f580 rdi:00007ffffed60cf0  r8:0000000000000000  r9:0000000000500178 r10:0000000000500000
 r11:000000000052b8b0 r12:0000000000103a68 r13:0000000000000000 r14:00000000647761c0 r15:0000000000103a68
Stack dump:
0x000000000022ee20:  0000000000000000 000000000022f160
0x000000000022ee30:  00007f8509ba32a0 0000000000103a68
0x000000000022ee40:  0000000000000000 0000000000000040
0x000000000022ee50:  0000000000000000 0000000000103a68
0x000000000022ee60:  0000000000000000 0000000000000000
0x000000000022ee70:  0000000000000000 0000000000000000
0x000000000022ee80:  0000000000000000 0000000000000000
0x000000000022ee90:  0000000000000000 0000000000000000
0x000000000022eea0:  0000000000000000 0000000000000000
0x000000000022eeb0:  0000000000000000 0000000000000000
0x000000000022eec0:  000000000022f0f0 fffffffffffffffe
0x000000000022eed0:  000000000022f0f0 000000000022f0f0
=>0 0x000000014095825b in darksoulsii (+0x95825b) (0x000000000022ef20)
  1 0x0000000140ae3b7e in darksoulsii (+0xae3b7d) (0x000000000022f620)
  2 0x0000000140ae74b2 in darksoulsii (+0xae74b1) (0x000000000022f879)
  3 0x00000001402e550f in darksoulsii (+0x2e550e) (0x000000000022f9e0)
  4 0x0000000140c295e0 in darksoulsii (+0xc295df) (0x000000000022ffd0)
  5 0x000000007b4779ee start_process+0xfd() in kernel32 (0x000000000022ffd0)
0x000000014095825b: movq        (%rax),%rcx
Module  Address                                 Debug info      Name (110 modules)
PE                230000-          2b4000       Deferred        fmod_event64
PE                630000-          6c4000       Deferred        openvr_api_dxvk
PE              3b400000-        3b421000       Deferred        steam_api64
PE              6a340000-        6a54c000       Deferred        d3d11
PE              6f200000-        6f3a1000       Deferred        dxgi
ELF             7b400000-        7b811000       Export          kernel32<elf>
  \-PE          7b420000-        7b811000       \               kernel32
ELF             7bc00000-        7bd37000       Deferred        ntdll<elf>
  \-PE          7bc20000-        7bd37000       \               ntdll
ELF             7c000000-        7c003000       Deferred        <wine-loader>
PE             140000000-       1420b6000       Export          darksoulsii
PE             180000000-       1801c6000       Deferred        fmodex64
ELF         7f85060af000-    7f85060d0000       Deferred
ELF         7f8506500000-    7f8506515000       Deferred        api-ms-win-core-localization-l1-2-1<elf>
  \-PE      7f8506510000-    7f8506515000       \               api-ms-win-core-localization-l1-2-1
ELF         7f8506515000-    7f850673e000       Deferred
ELF         7f850673e000-    7f85080eb000       Deferred
ELF         7f85080eb000-    7f850832f000       Deferred        lsteamclient<elf>
  \-PE      7f85081a0000-    7f850832f000       \               lsteamclient
ELF         7f850832f000-    7f850836d000       Deferred        uxtheme<elf>
  \-PE      7f8508340000-    7f850836d000       \               uxtheme
ELF         7f850836d000-    7f85083c6000       Deferred
ELF         7f85083c6000-    7f85085cc000       Deferred
ELF         7f85085cc000-    7f85087d6000       Deferred
ELF         7f85087d6000-    7f85087e3000       Deferred
ELF         7f85087e3000-    7f85087f6000       Deferred
ELF         7f85087f6000-    7f85089f9000       Deferred
ELF         7f85089f9000-    7f8508bff000       Deferred
ELF         7f8508bff000-    7f8508e02000       Deferred
ELF         7f8508e14000-    7f8508e28000       Deferred        api-ms-win-core-fibers-l1-1-1<elf>
  \-PE      7f8508e20000-    7f8508e28000       \               api-ms-win-core-fibers-l1-1-1
ELF         7f8508e28000-    7f8508e3d000       Deferred        api-ms-win-core-synch-l1-2-0<elf>
  \-PE      7f8508e30000-    7f8508e3d000       \               api-ms-win-core-synch-l1-2-0
ELF         7f8508e3d000-    7f8508ee6000       Deferred        winex11<elf>
  \-PE      7f8508e50000-    7f8508ee6000       \               winex11
ELF         7f8508f9b000-    7f8508fd7000       Deferred
ELF         7f8508fd7000-    7f850901e000       Deferred
ELF         7f850901e000-    7f8509091000       Deferred
ELF         7f8509091000-    7f85090b6000       Deferred
ELF         7f85090b6000-    7f85091d9000       Deferred
ELF         7f85091d9000-    7f85092da000       Deferred
ELF         7f85092da000-    7f85094f1000       Deferred
ELF         7f85094f1000-    7f8509529000       Deferred
ELF         7f8509529000-    7f850953c000       Deferred
ELF         7f850953c000-    7f8509805000       Deferred
ELF         7f8509840000-    7f8509859000       Deferred        xinput1_3<elf>
  \-PE      7f8509850000-    7f8509859000       \               xinput1_3
ELF         7f8509859000-    7f85098a7000       Deferred        usp10<elf>
  \-PE      7f8509860000-    7f85098a7000       \               usp10
ELF         7f85098a7000-    7f85099fe000       Deferred        comctl32<elf>
  \-PE      7f85098b0000-    7f85099fe000       \               comctl32
ELF         7f85099fe000-    7f8509b47000       Deferred
ELF         7f8509b50000-    7f8509b59000       Deferred
ELF         7f8509b59000-    7f8509b82000       Deferred        imm32<elf>
  \-PE      7f8509b60000-    7f8509b82000       \               imm32
ELF         7f8509b82000-    7f8509bdf000       Deferred        dinput8<elf>
  \-PE      7f8509b90000-    7f8509bdf000       \               dinput8
ELF         7f8509bdf000-    7f8509d57000       Deferred        oleaut32<elf>
  \-PE      7f8509c00000-    7f8509d57000       \               oleaut32
ELF         7f8509d57000-    7f8509e2d000       Deferred        msvcrt<elf>
  \-PE      7f8509d70000-    7f8509e2d000       \               msvcrt
ELF         7f8509e2d000-    7f8509e7a000       Deferred        winevulkan<elf>
  \-PE      7f8509e40000-    7f8509e7a000       \               winevulkan
ELF         7f8509e7a000-    7f8509e93000       Deferred        vulkan-1<elf>
  \-PE      7f8509e80000-    7f8509e93000       \               vulkan-1
ELF         7f8509e93000-    7f8509ec3000       Deferred        iphlpapi<elf>
  \-PE      7f8509ea0000-    7f8509ec3000       \               iphlpapi
ELF         7f8509ec3000-    7f8509ee0000       Deferred        wsock32<elf>
  \-PE      7f8509ed0000-    7f8509ee0000       \               wsock32
ELF         7f8509ee0000-    7f8509f23000       Deferred        ws2_32<elf>
  \-PE      7f8509ef0000-    7f8509f23000       \               ws2_32
ELF         7f8509f23000-    7f8509fb4000       Deferred        shlwapi<elf>
  \-PE      7f8509f40000-    7f8509fb4000       \               shlwapi
ELF         7f8509fb4000-    7f850a9bb000       Deferred        shell32<elf>
  \-PE      7f8509fd0000-    7f850a9bb000       \               shell32
ELF         7f850a9bb000-    7f850a9e9000       Deferred        msacm32<elf>
  \-PE      7f850a9c0000-    7f850a9e9000       \               msacm32
ELF         7f850a9e9000-    7f850aa82000       Deferred        rpcrt4<elf>
  \-PE      7f850aa00000-    7f850aa82000       \               rpcrt4
ELF         7f850aa82000-    7f850ac24000       Deferred        ole32<elf>
  \-PE      7f850aab0000-    7f850ac24000       \               ole32
ELF         7f850ac24000-    7f850ac3f000       Deferred        version<elf>
  \-PE      7f850ac30000-    7f850ac3f000       \               version
ELF         7f850ac3f000-    7f850acd1000       Deferred        advapi32<elf>
  \-PE      7f850ac50000-    7f850acd1000       \               advapi32
ELF         7f850acd1000-    7f850ae4f000       Deferred        gdi32<elf>
  \-PE      7f850acf0000-    7f850ae4f000       \               gdi32
ELF         7f850ae4f000-    7f850b0b2000       Deferred        user32<elf>
  \-PE      7f850ae70000-    7f850b0b2000       \               user32
ELF         7f850b1b2000-    7f850b278000       Deferred        winmm<elf>
  \-PE      7f850b1c0000-    7f850b278000       \               winmm
ELF         7f850cb05000-    7f850cd17000       Deferred
ELF         7f850cd17000-    7f850cdd3000       Deferred
ELF         7f850cdd3000-    7f850ce06000       Deferred
ELF         7f850d0af000-    7f850d0e2000       Deferred
ELF         7f850d0e7000-    7f850d2ed000       Deferred
ELF         7f850d2ed000-    7f850d4f1000       Deferred
ELF         7f850d4f1000-    7f850d51b000       Deferred
ELF         7f850d51d000-    7f850d537000       Deferred
ELF         7f850d537000-    7f850d676000       Deferred
ELF         7f850d676000-    7f850d7fb000       Deferred
ELF         7f850d98a000-    7f850d98f000       Deferred
ELF         7f850d98f000-    7f850d999000       Deferred
ELF         7f850d99b000-    7f850d9df000       Deferred
ELF         7f850d9df000-    7f850dba3000       Deferred
ELF         7f850dba3000-    7f850dbc4000       Deferred
ELF         7f850dbca000-    7f850dbdf000       Deferred
ELF         7f850dbff000-    7f850dfa5000       Export
ELF         7f850dfa5000-    7f850e1e0000       Deferred
ELF         7f850e1e2000-    7f850e20e000       Deferred
process  tid      prio (all id:s are in hex)
0000000c services.exe
        0000001f    0
        0000001a    0
        00000016    0
        00000013    0
        00000012    0
        00000011    0
        0000000e    0
        0000000d    0
0000000f winedevice.exe
        00000017    0
        00000015    0
        00000014    0
        00000010    0
00000018 plugplay.exe
        0000001c    0
        0000001b    0
        00000019    0
0000001d winedevice.exe
        00000022    0
        00000021    0
        00000020    0
        0000001e    0
00000023 (D) Z:\home\robert\.local\share\Steam\steamapps\common\Dark Souls II Scholar of the First Sin\Game\DarkSoulsII.exe
        0000002e    0
        0000002d   -1
        0000002c    0
        0000002b    0
        0000002a    0
        00000024    0 <==
00000025 explorer.exe
        00000029    0
        00000028    0
        00000027    0
        00000026    0
System information:
    Wine build: wine-3.16
    Platform: x86_64
    Version: Windows 7
    Host system: Linux
    Host version: 4.19.16-1-MANJARO
pid 4219 != 4218, skipping destruction (fork without exec?)
Game removed: AppID 335300 "", ProcID 4216 
No cached sticky mapping in ActivateActionSet.

I looked up the LD_PRELOAD cannot be preloaded on the wiki and it said that was safe to ignore, but I don't know what I'm looking at with the rest of the error.

I believe your issue is with Bumblebee, see issue #137;

The above issue was caused by Bumblebee somehow messing things up. After I switched to using nvidia-xrun instead of Bumblebee, Dark Souls works fine in full screen. I've yet to try other resolutions than my laptop's native one but i expect it to be only a matter of configuring Xorg and/or Openbox.

follow jonathons prime guide and get rid of bumblebee

you will never come back

I tried setting up prime with that the other day after I installed Manjaro but then something happened with my display manager and I had to reinstall Manjaro.

Also is there a difference between nvidia-xrun and prime?

I have always been curious, and this seems to fit the bill here, why do you need the Intel GPU?

I have both nvidia card and baked-in Intel GPU from my motherboard, but I see no reason to ever use the Intel since Nvidia with the nvidia drivers works so well in Manjaro. I was always curious why people need to switch back and forth.

Honestly I have no need to switch between the two but im still super new to Manjaro so I'm not sure how to just use my Nvidia. I've been on ubuntu for like 2 years but got this new laptop and wanted to try Manjaro.

I use nvidia-xrun for proton games (kingdom come/ Project cars 2/DS2 soon, still need to finish the first).
When I have to launch a game through proton I just go to an other TTY, and type nvidia-xrun which will start a DE depending on ~/.nvidia-xinitrc, kde for me:

$ cat .nvidia-xinitrc

No need to remove bumblebee.

That is kind of what I was hoping you would say. For me, wouldn't worry about using the Intel GPU, and all that Bumblebee/nvidia-xrun/prime hocus-pocus.

  1. Remove Bumblebee (you will have to google that, I have never used it myself)
  2. There is a Manjaro settings manager in your toolbox (applications menu), fasten on your tool belt and hit the 'hardware configuration' application.
  3. Hit the 'Auto install proprietary drivers' button, and that should install the proprietary nvidia graphics drivers...reboot, and hello Dark Souls II (hopefully.)

And ALWAYS... Ask your doctor if Bumblebee is right for you! :stuck_out_tongue_winking_eye:

the optimus-manager git give a nice summary of available tools:

On Windows, the Optimus technology works by dynamically offloading rendering to the Nvidia GPU when running 3D-intensive applications, while the desktop session itself runs on the Intel GPU.

However, on Linux, the Nvidia driver does not provide such offloading capabilities (yet), which makes it difficult to use the full potential of your machine while keeping a reasonable battery life.

Currently, if you have Linux installed on an Optimus laptop, there are three methods to use your Nvidia GPU :

1 Run your whole X session on the Intel GPU and use Bumblebee to offload rendering to the Nvidia GPU. While this mimic the behavior of Optimus on Windows, this is an unofficial, hacky solution with three major drawbacks : 1. a noticeable performance hit (because Bumblebee has to use your CPU to copy frames over to the display) 2. no support for Vulkan (therefore, it is incompatible with DXVK and any native game using Vulkan, like Shadow of the Tomb Raider for instance) 3. you will be unable to use any video output (like HDMI ports) connected to the Nvidia GPU, unless you have the open-source nouveau driver loaded to this GPU at the same time.

2 Use nvidia-xrun to have the Nvidia GPU run on its own X server in another virtual terminal. You have to keep two X servers running at the same time, which can be detrimental to performance. Also, you do not have acess to your normal desktop environment while in the virtual terminal of the Nvidia GPU, and in my own experience, the nvidia driver is prone to crashing when switching between virtual terminals.

3 Run your whole X session on the Nvidia GPU and disable rendering on the Intel GPU. This allows you to run your applications at full performance, with Vulkan support, and with access to all video outputs. However, since your power-hungry Nvidia GPU is turned on at all times, it has a massive impact on your battery life. This method is often called Nvidia PRIME, although technically PRIME is just the technology that allows your Nvidia GPU to send its frames to the built-in display of your laptop via the Intel GPU.

An acceptable middle ground could be to use the third method on demand : switching the X session to the Nvidia GPU when you need extra rendering power, and then switching it back to Intel when you are done, to save battery life.

Unfortunately the X server configuration is set-up in a permanent manner with configuration files, which makes switching a hassle because you have to rewrite those files every time you want to switch GPUs. You also have to restart the X server for those changes to be taken into account.

This is what this tool does for you : it dynamically writes the X configuration at boot time, rewrites it every time you need to switch GPUs, and also loads the appropriate kernel modules to make sure your GPUs are properly turned on/off.

Note that this is nothing new : Ubuntu has been using that method for years with their prime-select script.

So you're telling me this will just allow me to use Nvidia without needing bumblebee/prime/nvidia-xrun?


As Yoy0 pointed out, if you need to switch to the Intel GPU for power saving, given you are on a laptop, then you can use the method they mentioned, else just install the proprietary driver from Manjaro Settings Mgr and you are running pure Nvidia...and hopefully have no issues with Proton in Steam. Good luck, and mark the thread as 'solved' if it works.

Is Dark Souls II using DX11? If so, you need working vulkan and bumblebee is not supporting it. For vulkan you need to switch to nvidia-xrun or Prime, or optimus-manager. There are guides how to use them on this forum.

However, I'm just guessing, this may be caused by something different thou, but it's good to remember that dxvk won't be working when using bumblebee, so lot of Steam Play games are not playable with bumblebee (among them Witcher 3) so it's worth to look for alternatives. Optimus-manager worked well for me.

I got it solved. Using nvidia-xrun works flawlessly. It seemed like a pretty simple solution and worked great!


There is a simple solution to play this game in Linux via steam play on optimus laptop without nvidia-xrun
just use start command:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by