steam wont launch the game

i was searching for a long time now and no one with the same problem as Iam

whenever i launch stem game, pop up appears and then the game is stop running
i already download the newest graphic card driver

this is my basic info

System:
  Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=c07b08eb-d311-4264-ab05-7426fc0fe65a rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: H61M-S2-B3 serial: <filter> 
  BIOS: Award v: F5 date: 03/27/2012 
CPU:
  Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24754 
  Speed: 1596 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1596 2: 1596 
  3: 1596 4: 1596 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Turks LE [Radeon HD 5570/6510/7510/8510] 
  vendor: PC Partner Limited driver: radeon v: kernel bus ID: 01:00.0 
  chip ID: 1002:675f 
  Display: x11 server: X.org 1.20.8 driver: radeon compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.6.16-1-MANJARO LLVM 10.0.0) 
  v: 3.3 Mesa 20.0.7 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aa90 
  Device-3: Barco Display Systems type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-1.5:4 
  chip ID: 0600:6216 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Gigabyte 
  driver: atl1c v: 1.0.1.1-NAPI port: df00 bus ID: 03:00.0 
  chip ID: 1969:1083 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
  driver: r8188eu bus ID: 2-1.4:5 chip ID: 0bda:8179 serial: <filter> 
  IF: wlp0s29u1u4 state: up mac: <filter> 
Drives:
  Local Storage: total: 577.56 GiB used: 299.84 GiB (51.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKS-00A7B2 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 3.0 Gb/s serial: <filter> rev: 3B01 scheme: MBR 
  ID-2: /dev/sdb vendor: SanDisk model: SSD PLUS 120GB size: 111.80 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 00RL scheme: MBR 
Partition:
  ID-1: / raw size: 19.53 GiB size: 19.10 GiB (97.79%) 
  used: 14.33 GiB (75.0%) fs: ext4 dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: radeon temp: 46 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 207 Uptime: 17m Memory: 3.83 GiB used: 1.09 GiB (28.4%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37

Screenshot from 2020-06-29 07-14-24 Screenshot from 2020-06-29 08-11-53 Screenshot from 2020-06-29 08-18-53

Hi there..
How did you install your drivers?
Are these linux native games?
Also see this:

Basic system info:

inxi -Fxxxza --no-host

im installing my driver by simply use this into terminal

sudo pacman -S lib32-mesa vulkan-radeon lib32-vulkan-radeon vulkan-icd-loader lib32-vulkan-icd-loader

this is not linux native game but got pretty good feedback in protondb

ah sorry im not english speaker
i already wanna to include some basic info like that but i still cannot find it anywhere
i edit it rn

We use mhwd or MSM for drivers..
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

So you might want to look through that.
But really you just want to make sure to have video-linux installed/force-reinstall.
(your card is not new enough for AMDGPU)

We should also make sure you are all up to date:

sudo pacman-mirrors -f && sudo pacman -Syyu

OK .. so did you turn proton on ?
I am pretty sure it is still the same as shown here (random link):

I just want to confirm, are you using Linux Steam Native, aka the Steam program within our repo? And you are using Proton 5.0, which you downloaded within Steam itself?

ty for more info but i already uninstalled my current manjaro and looking up for another variant of manjaro
because all of youtube video i was searching is not using gnome variant (yeah i know this is silly, too greedy to uninstall a whole os because of small issues like this)
will be back soon if i face the same issues after installing the new os and new driver like in this link

im pretty sure enable it in setting
because i researching this issues in 2 days rn

i use the native version of steam because in forum i read this is the most stable version of steam

Forum kindly sponsored by