Steam won't open

Just installed the latest version of Manjaro Gnome and it's awesome but unfortunately when I click on the steam icon nothing happens, the first time the User License Agreement thing popped up, I accepted and clicked continue then nothing happened. Restarted my notebook and tried again but nothing happens after I click on the icon in menu.

i'm afraid you need to do a little more than that, generally speaking.

  • run steam from terminal, paste any errors
  • search on this forum, there have been steam related posts in the past. Things change on a rolling distro, sure, but the basic troubleshooting steps remain the same.
  • since graphics cards/drivers are always in the mix when gaming is involved, share your hardware info

Let's begin...

1 Like

Hi badbodh, I also reinstalled steam :slight_smile: I did do a search but as I'm such a noob I was finding it difficult to follow some of the advice given as it assumed a basic knowledge of Linux which I'm severely lacking in, for instance; how do I run steam from terminal? :sweat_smile:

System:    Host: jb-notebook Kernel: 4.15.0-1-MANJARO x86_64
           bits: 64 gcc: 7.2.1
           Desktop: Gnome 3.26.2 (Gtk 3.22.26) Distro: Manjaro Linux
Machine:   Device: laptop System: Dell product: XPS 13 9360 serial: N/A
           Mobo: Dell model: 0839Y6 v: A00 serial: N/A
           UEFI [Legacy]: Dell v: 1.3.5 date: 05/08/2017
Battery    BAT0: charge: 32.8 Wh 58.5% condition: 56.1/60.0 Wh (94%)
           model: SMP DELL TP1GT61 status: Discharging
CPU:       Dual core Intel Core i7-7500U (-MT-MCP-)
           arch: Kaby Lake rev.9 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11620
           clock speeds: max: 3500 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: N/A driver: i915 tty size: 80x24
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-1-MANJARO
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 3a:00.0
           IF: wlp58s0 state: up mac: <filter>
           Card-2: Qualcomm Atheros usb-ID: 001-002
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 512.1GB (4.7% used)
           ID-1: /dev/nvme0n1 model: THNSN5512GPUK_NVMe_TOSHIBA_512GB size: 512.1GB
Partition: ID-1: / size: 452G used: 6.5G (2%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: swap-1 size: 18.04GB used: 0.00GB (0%)
           fs: swap dev: /dev/nvme0n1p2
Sensors:   System Temperatures: cpu: 25.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 1:07 Memory: 1464.4/15642.3MB
           Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.56

Here is my attempt at running steam from terminal:

[james@jb-notebook ~]$ steam
Repairing installation, linking /home/james/.steam/steam to /home/james/.local/share/Steam
Running Steam on manjarolinux 17.1.3 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/james/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib32/ undefined symbol: xcb_send_request_with_fds
/home/james/.local/share/Steam/ line 444: no match: ssfn*

1 Like

Thank you!

This solved the issue:


Well done ! :clap: :tada:
From here on, you are no longer severely lacking.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by