Strange behaviour with appium-desktop: won't start, "bootloop".

I am on:
Community-Edition: Awesome

~ >>> lsb_release -a 
LSB Version: n/a 
Distributor ID: ManjaroLinux 
Description: Manjaro Linux 
Release: 20.0.1 
Codename: Lysia 
~ >>> uname -a 
Linux user-pc 4.19.122-1-MANJARO #1 SMP Sun May 10 14:02:27 UTC 2020 x86_64 GNU/Linux 

Something strange happens when I'm starting appium-desktop (appium cli is ok, i.e. there is no such output and it's not shutting down xscreensaver daemon, and there is no bootloop...):

~/Applications >>> ./Appium-linux-1.17.0_988604e59967803bee91ec0d7af22a38.AppImage 
qt5ct: using qt5ct plugin 
[3] 85359 
[4] 85360 
[3] - done xscreensaver-command -exit
(node:85314) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, rename '/home/user/.config/appium-desktop/Settings-tmp' -> '/home/user/.config/appium-desktop/Settings' 
(node:85314) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, rename '/home/user/.config/appium-desktop/Settings-tmp' -> '/home/user/.config/appium-desktop/Settings' 
(node:85314) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1) 
(node:85314) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1) 
(node:85314) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. 
(node:85314) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. 

Especially this line bothers me: [3] - done xscreensaver-command -exit
Why is that? Why appium-desktop supposed to conflict with xscreensaver or anyhow to interact with it?!

But this is the least of the problem now. For some time later appium-desktop just won't start and keeps forking for some reason and creates lots of processes...
Video of the whole problem.

I've created an issue on appium-desktop's github. One of the developers assumed that this behaviour may be somehow connected with Electron-Qt stuff (I'm not much aware of it's intercommunication though).
I noticed that there were updates with some Qt packages.
Here are list of my Qt and Qt-related (dependent) packages and theirs versions that installed right now on my system:

Summary

Name : accounts-qml-module
Version : 0.7-2
Description : Expose the Online Accounts API to QML applications
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : None
Depends On : signond libaccounts-qt qt5-declarative
Optional Deps : None
Required By : purpose
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 458,00 KiB
Build Date : Сб 10 ноя 2018 04:03:23
Install Date : Вт 17 мар 2020 16:57:28
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : appimagelauncher
Version : 2.1.3-1
Description : A Helper application for running and integrating AppImages.
Architecture : x86_64
Licenses : MIT
Groups : None
Provides : None
Depends On : cairo desktop-file-utils gtest hicolor-icon-theme libappimage libbsd libxpm qt5-base shared-mime-info
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1933,83 KiB
Build Date : Ср 22 апр 2020 01:41:48
Install Date : Вс 03 мая 2020 18:04:48
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Name : attica
Version : 5.70.0-1
Description : Qt library that implements the Open Collaboration Services API
Architecture : x86_64
Licenses : LGPL
Groups : kf5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : kxmlgui
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1557,82 KiB
Build Date : Вс 03 мая 2020 14:53:14
Install Date : Пн 25 мая 2020 03:01:42
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : libaccounts-qt
Version : 1.16-2
Description : Qt-based client library for accessing the online accounts database
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : libaccounts-qt5
Depends On : libaccounts-glib qt5-base
Optional Deps : None
Required By : accounts-qml-module signon-ui
Optional For : None
Conflicts With : libaccounts-qt5
Replaces : libaccounts-qt5
Installed Size : 156,66 KiB
Build Date : Ср 15 апр 2020 22:43:27
Install Date : Вс 03 мая 2020 18:05:09
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : openfortigui
Version : 0.8.2-1
Description : OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5.
Architecture : x86_64
Licenses : GPL3
Groups : None
Provides : None
Depends On : qt5-base qtkeychain qt5-translations openssl ppp sudo
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1098,18 KiB
Build Date : Вт 17 мар 2020 13:46:39
Install Date : Вт 17 мар 2020 13:47:11
Install Reason : Explicitly installed
Install Script : No
Validated By : None

Name : phonon-qt5
Version : 4.11.1-2
Description : The multimedia framework by KDE
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : None
Depends On : libpulse qt5-base phonon-qt5-backend
Optional Deps : pulseaudio: PulseAudio support [installed]
qt5-tools: Designer plugin [installed]
Required By : goldendict okular phonon-qt5-gstreamer
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1312,15 KiB
Build Date : Вт 19 мая 2020 14:05:34
Install Date : Пн 15 июн 2020 02:46:09
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : phonon-qt5-gstreamer
Version : 4.10.0-2
Description : Phonon GStreamer backend for Qt5
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : phonon-qt5-backend
Depends On : gst-plugins-base qt5-x11extras phonon-qt5
Optional Deps : pulseaudio: PulseAudio support [installed]
gst-plugins-good: PulseAudio support and good codecs [installed]
gst-plugins-bad: additional codecs [installed]
gst-plugins-ugly: additional codecs [installed]
gst-libav: libav codec [installed]
Required By : phonon-qt5
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 424,49 KiB
Build Date : Вт 19 мая 2020 15:46:14
Install Date : Пн 15 июн 2020 02:46:09
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : polkit-qt5
Version : 0.113.0-2
Description : A library that allows developers to access PolicyKit API with a nice Qt-style API
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : None
Depends On : polkit qt5-base
Optional Deps : None
Required By : kauth
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 294,37 KiB
Build Date : Вт 19 мая 2020 14:12:09
Install Date : Пн 15 июн 2020 02:44:53
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : poppler
Version : 0.88.0-1
Description : PDF rendering library based on xpdf 3.0
Architecture : x86_64
Licenses : GPL
Groups : None
Provides : libpoppler.so=99-64 libpoppler-cpp.so=0-64
Depends On : libjpeg gcc-libs cairo fontconfig openjpeg2 lcms2 nss cOptional Deps : poppler-data: encoding data to display PDF documents containing CJK characters [installed]
Required By : cups-filters libreoffice-fresh poppler-glib poppler-qt5 texlive-bin
Optional For : None
Conflicts With : poppler-qt3<0.88.0 poppler-qt4<0.88.0
Replaces : None
Installed Size : 5,26 MiB
Build Date : Пт 01 мая 2020 16:03:13
Install Date : Пт 15 мая 2020 23:09:10
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : poppler-qt5
Version : 0.88.0-1
Description : Poppler Qt5 bindings
Architecture : x86_64
Licenses : GPL
Groups : None
Provides : libpoppler-qt5.so=1-64
Depends On : poppler=0.88.0 qt5-base
Optional Deps : None
Required By : okular
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 665,98 KiB
Build Date : Пт 01 мая 2020 16:03:13
Install Date : Пт 15 мая 2020 23:10:35
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : python-pyqt5
Version : 5.15.0-2
Description : A set of Python bindings for the Qt5 toolkit
Architecture : x86_64
Licenses : GPL
Groups : pyqt5
Provides : None
Depends On : python-pyqt5-sip qt5-base
Optional Deps : python-opengl: enable OpenGL 3D graphics in PyQt applications
python-dbus: for python-dbus mainloop support [installed]
qt5-multimedia: QtMultimedia, QtMultimediaWidgets [installed]
qt5-tools: QtHelp, QtDesigner [installed]
qt5-svg: QtSvg [installed]
qt5-webkit: QtWebKit, QtWebKitWidgets [installed]
qt5-xmlpatterns: QtXmlPatterns
qt5-declarative: QtQml, qmlplugin [installed]
qt5-serialport: QtSerialPort
qt5-websockets: QtWebSockets
qt5-connectivity: QtNfc, QtBluetooth
qt5-x11extras: QtX11Extras [installed]
qt5-networkauth: QtNetworkAuth
qt5-remoteobjects: QtRemoteObjects
qt5-quick3d: QtQuick3D
Required By : manjaro-printer pulseaudio-equalizer
Optional For : hplip kauth kcodecs kcompletion kconfig kconfigwidgets kcoreaddons kdbusaddons kguiaddons ki18n kitemmodels kitemviews kjobwidgets kwidgetsaddons python-pillow
Conflicts With : pyqt5-common
Replaces : None
Installed Size : 26,70 MiB
Build Date : Ср 03 июн 2020 22:14:27
Install Date : Пн 15 июн 2020 02:46:18
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : python-pyqt5-sip
Version : 12.8.0-1
Description : The sip module support for PyQt5
Architecture : x86_64
Licenses : GPL
Groups : None
Provides : None
Depends On : python
Optional Deps : None
Required By : python-pyqt5
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 152,70 KiB
Build Date : Пн 01 июн 2020 15:26:58
Install Date : Пн 15 июн 2020 02:46:18
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qca
Version : 2.3.0-1
Description : Qt Cryptographic Architecture
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : qca-qt5
Depends On : qt5-base nss ca-certificates
Optional Deps : pkcs11-helper: PKCS-11 plugin [installed]
botan: botan plugin
Required By : genymotion okular
Optional For : None
Conflicts With : qca-qt5
Replaces : qca-qt5
Installed Size : 3,18 MiB
Build Date : Вт 25 фев 2020 18:37:03
Install Date : Вт 17 мар 2020 16:57:27
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qdirstat
Version : 1.6.1-1
Description : Qt-based directory statistics (KDirStat/K4DirStat without any KDE - from the original KDirStat author)
Architecture : x86_64
Licenses : GPL2
Groups : None
Provides : qdirstat-git
Depends On : qt5-base xdg-utils hicolor-icon-theme desktop-file-utils
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : qdirstat-git
Replaces : None
Installed Size : 2,08 MiB
Build Date : Пт 03 апр 2020 21:59:31
Install Date : Пт 03 апр 2020 22:02:00
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None

Name : qt5-base
Version : 5.15.0-3
Description : A cross-platform application and UI framework
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : libjpeg-turbo xcb-util-keysyms xcb-util-renderutil libgl fontconfig xdg-utils shared-mime-info xcb-util-wm libxrender libxi sqlite xcb-util-image mesa tslib libinput libxkbcommon-x11 libproxy libcups double-conversion md4c icu
Optional Deps : qt5-svg: to use SVG icon themes [installed]
qt5-wayland: to run Qt applications in a Wayland session [installed]
qt5-translations: for some native UI translations [installed]
postgresql-libs: PostgreSQL driver
mariadb-libs: MariaDB driver
unixodbc: ODBC driver
libfbclient: Firebird/iBase driver
freetds: MS SQL driver
gtk3: GTK platform plugin [installed]
perl: for fixqt4headers and syncqt [installed]
Required By : appimagelauncher attica compton-conf karchive kcodecs kconfig kcoreaddons kitemmodels kitemviews kjs kvantum-qt5 kwidgetsaddons libaccounts-qt libdbusmenu-qt5 libkexiv2 manjaro-settings-manager openfortigui phonon-qt5 polkit-qt5 poppler-qt5 python-pyqt5 qca qdirstat qt5-declarative qt5-imageformats qt5-multimedia qt5-script qt5-sensors qt5-svg qt5-tools qt5-translations qt5-x11extras qtkeychain quazip signond simplescreenrecorder smplayer solid sonnet threadweaver virtualbox
Optional For : avahi libde265 openal pinentry v4l-utils
Conflicts With : qtchooser
Replaces : None
Installed Size : 64,06 MiB
Build Date : Пт 12 июн 2020 05:56:30
Install Date : Пн 15 июн 2020 02:44:52
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-declarative
Version : 5.15.0-1
Description : Classes for QML and JavaScript languages
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : accounts-qml-module ki18n qt5-graphicaleffects qt5-location qt5-quickcontrols qt5-quickcontrols2 qt5-wayland qt5-webchannel
Optional For : kactivities kitemmodels python-pyqt5 qt5-multimedia qt5-sensors solid
Conflicts With : qtchooser
Replaces : None
Installed Size : 24,72 MiB
Build Date : Вт 26 мая 2020 12:51:28
Install Date : Пн 15 июн 2020 02:44:53
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-graphicaleffects
Version : 5.15.0-1
Description : Graphical effects for use with Qt Quick 2
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative
Optional Deps : None
Required By : kirigami2
Optional For : qt5-quickcontrols2
Conflicts With : None
Replaces : None
Installed Size : 529,93 KiB
Build Date : Вт 26 мая 2020 14:20:09
Install Date : Пн 15 июн 2020 02:46:09
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-imageformats
Version : 5.15.0-1
Description : Plugins for additional image formats: TIFF, MNG, TGA, WBMP
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base jasper libmng libwebp
Optional Deps : None
Required By : telegram-desktop
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 208,13 KiB
Build Date : Вт 26 мая 2020 14:20:36
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-location
Version : 5.15.0-1
Description : Provides access to position, satellite and area monitoring classes
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative
Optional Deps : None
Required By : qt5-webengine qt5-webkit
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 11,04 MiB
Build Date : Вт 26 мая 2020 12:55:44
Install Date : Пн 15 июн 2020 02:44:56
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-multimedia
Version : 5.15.0-1
Description : Classes for audio, video, radio and camera functionality
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base gst-plugins-base libpulse openal
Optional Deps : qt5-declarative: QML bindings [installed]
gst-plugins-good: camera support, additional plugins [installed]
gst-plugins-bad: camera support, additional plugins [installed]
gst-plugins-ugly: additional plugins [installed]
gst-libav: ffmpeg plugin [installed]
Required By : qt5-speech wireshark-qt
Optional For : python-pyqt5
Conflicts With : None
Replaces : None
Installed Size : 3,51 MiB
Build Date : Вт 26 мая 2020 14:22:05
Install Date : Пн 15 июн 2020 02:44:53
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-quickcontrols
Version : 5.15.0-1
Description : Reusable Qt Quick based UI controls to create classic desktop-style user interfaces
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative
Optional Deps : None
Required By : kirigami2
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 4,76 MiB
Build Date : Вт 26 мая 2020 14:26:39
Install Date : Пн 15 июн 2020 02:46:09
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-quickcontrols2
Version : 5.15.0-1
Description : Next generation user interface controls based on Qt Quick
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative
Optional Deps : qt5-graphicaleffects: for the Material style [installed]
Required By : kirigami2
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 8,56 MiB
Build Date : Вт 26 мая 2020 14:27:24
Install Date : Пн 15 июн 2020 02:46:10
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-script
Version : 5.15.0-1
Description : Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : genymotion smplayer
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 3,57 MiB
Build Date : Вт 26 мая 2020 14:29:32
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-sensors
Version : 5.15.0-1
Description : Provides access to sensor hardware and motion gesture recognition
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : qt5-declarative: QML bindings [installed]
Required By : qt5-webkit
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 908,85 KiB
Build Date : Вт 26 мая 2020 12:58:32
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-speech
Version : 5.15.0-1
Description : Qt module to make text to speech and speech recognition easy
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-multimedia
Optional Deps : flite: flite TTS backend
speech-dispatcher: speech-dispatcher TTS backend
Required By : knotifications ktextwidgets
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 172,84 KiB
Build Date : Вт 26 мая 2020 14:31:50
Install Date : Пн 15 июн 2020 02:44:53
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-svg
Version : 5.15.0-1
Description : Classes for displaying the contents of SVG files
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : goldendict keepassxc kiconthemes kvantum-qt5 qt5ct wireshark-qt
Optional For : python-pyqt5 qt5-base
Conflicts With : None
Replaces : None
Installed Size : 490,37 KiB
Build Date : Вт 26 мая 2020 14:32:20
Install Date : Пн 15 июн 2020 02:44:53
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-tools
Version : 5.15.0-2
Description : A cross-platform application and UI framework (Development Tools, QtHelp)
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base hicolor-icon-theme
Optional Deps : clang: for qdoc
qt5-webkit: for Qt Assistant [installed]
Required By : goldendict
Optional For : phonon-qt5 python-pyqt5
Conflicts With : qtchooser
Replaces : None
Installed Size : 16,26 MiB
Build Date : Вт 02 июн 2020 13:41:16
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-translations
Version : 5.15.0-1
Description : A cross-platform application and UI framework (Translations)
Architecture : any
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : openfortigui
Optional For : qt5-base
Conflicts With : None
Replaces : None
Installed Size : 11,80 MiB
Build Date : Вт 26 мая 2020 13:02:01
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-wayland
Version : 5.15.0-1
Description : Provides APIs for Wayland
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative libxcomposite
Optional Deps : None
Required By : None
Optional For : qt5-base
Conflicts With : None
Replaces : None
Installed Size : 6,24 MiB
Build Date : Вт 26 мая 2020 14:34:24
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-webchannel
Version : 5.15.0-1
Description : Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-declarative
Optional Deps : None
Required By : qt5-webengine qt5-webkit
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 222,88 KiB
Build Date : Вт 26 мая 2020 13:02:33
Install Date : Пн 15 июн 2020 02:44:56
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-webengine
Version : 5.15.0-1
Description : Provides support for web applications using the Chromium browser project
Architecture : x86_64
Licenses : LGPL3 LGPL2.1 BSD
Groups : qt qt5
Provides : None
Depends On : qt5-webchannel qt5-location libxcomposite libxrandr pciutils libxss libevent snappy nss libxslt minizip ffmpeg re2 libvpx krb5 ttf-font
Optional Deps : None
Required By : signon-ui
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 144,73 MiB
Build Date : Вт 26 мая 2020 13:03:06
Install Date : Пн 15 июн 2020 02:45:01
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-webkit
Version : 5.212.0alpha4-6
Description : Classes for a WebKit2 based implementation and a new QML API
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : None
Provides : None
Depends On : qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2
Optional Deps : gst-plugins-good: Webm codec support [installed]
Required By : genymotion goldendict
Optional For : python-pyqt5 qt5-tools
Conflicts With : None
Replaces : None
Installed Size : 46,72 MiB
Build Date : Вт 26 мая 2020 14:57:40
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5-x11extras
Version : 5.15.0-1
Description : Provides platform-specific APIs for X11
Architecture : x86_64
Licenses : GPL3 LGPL3 FDL custom
Groups : qt qt5
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : goldendict kdbusaddons keepassxc kguiaddons kjobwidgets kvantum-qt5 kwindowsystem phonon-qt5-gstreamer simplescreenrecorder virtualbox
Optional For : python-pyqt5
Conflicts With : None
Replaces : None
Installed Size : 40,64 KiB
Build Date : Вт 26 мая 2020 14:36:50
Install Date : Пн 15 июн 2020 02:44:52
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : qt5ct
Version : 0.41-5
Description : Qt5 Configuration Utility
Architecture : x86_64
Licenses : BSD
Groups : None
Provides : None
Depends On : qt5-svg
Optional Deps : None
Required By : None
Optional For : manjaro-awesome-settings-18.0
Conflicts With : None
Replaces : None
Installed Size : 795,17 KiB
Build Date : Пт 05 июн 2020 02:43:47
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Name : qtkeychain
Version : 0.10.0-2
Description : Provides support for secure credentials storage
Architecture : x86_64
Licenses : BSD
Groups : None
Provides : None
Depends On : libsecret qt5-base
Optional Deps : kwallet: kwallet backend [installed]
Required By : openfortigui
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 201,12 KiB
Build Date : Чт 12 мар 2020 23:33:48
Install Date : Чт 26 мар 2020 09:42:50
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : quazip
Version : 0.9.1-1
Description : C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package
Architecture : x86_64
Licenses : LGPL
Groups : None
Provides : None
Depends On : qt5-base
Optional Deps : None
Required By : keepassxc
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 343,45 KiB
Build Date : Вс 24 мая 2020 21:34:46
Install Date : Пн 15 июн 2020 02:46:19
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Any help would be greatly appreciated!
Please help me investigate problem further or any advice for where to look further would be greatly appreciated! My work heavily depends on this application.

The error message is quite clear - this is a situation the developers did not foresee - at least they have not included handling of it.

I cannot see any /home/user/.config/appium-desktop/Settings-tmp file.
Now it just "bootlooping" and creates a lot of processes (see video in the first post) of appium-desktop in memory without actually starting it:

 ~/Applications >>>  ./Appium-linux-1.17.0_988604e59967803bee91ec0d7af22a38.AppImage
 qt5ct: using qt5ct plugin
 [3] 8077
 [4] 8078
 [3]  - done       xscreensaver-command -exit
 [3] 8172
 [4] 8173
 [3]  - done       xscreensaver-command -exit
 [3] 8236
 [4] 8237
 [3]  - done       xscreensaver-command -exit
 [3] 8311
 [4] 8312
 [3]  - done       xscreensaver-command -exit
 [3] 8375
 [4] 8376
 [3]  - done       xscreensaver-command -exit
 [3] 8439
 [4] 8440
 [3]  - done       xscreensaver-command -exit
 zsh: terminated  ./Appium-linux-1.17.0_988604e59967803bee91ec0d7af22a38.AppImage

ps output:

 ~ >>> ps axjf | grep appium-desktop | grep -v grep                                                                                     
    7920    8735    8735    7920 pts/10      9383 Sl    1001   0:04  |           \_ /tmp/.mount_AppiumSs25ZH/appium-desktop
    8735    8758    8735    7920 pts/10      9383 S     1001   0:00  |               \_ /tmp/.mount_AppiumSs25ZH/appium-desktop --type=zygote --no-sandbox
       1    8773    8773    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumSVvsGz/appium-desktop -no-splash
    8773    8816    8773    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumSVvsGz/appium-desktop --type=zygote --no-sandbox
       1    8832    8832    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumsWwrL3/appium-desktop -no-splash
    8832    8876    8832    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumsWwrL3/appium-desktop --type=zygote --no-sandbox
       1    8890    8890    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumIyixfq/appium-desktop -no-splash
    8890    8934    8890    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumIyixfq/appium-desktop --type=zygote --no-sandbox
       1    8948    8948    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumEJ69jO/appium-desktop -no-splash
    8948    8991    8948    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumEJ69jO/appium-desktop --type=zygote --no-sandbox
       1    9005    9005    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumuFYew9/appium-desktop -no-splash
    9005    9048    9005    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumuFYew9/appium-desktop --type=zygote --no-sandbox
       1    9062    9062    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumLiLbip/appium-desktop -no-splash
    9062    9105    9062    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumLiLbip/appium-desktop --type=zygote --no-sandbox
       1    9119    9119    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumY1UrFL/appium-desktop -no-splash
    9119    9162    9119    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumY1UrFL/appium-desktop --type=zygote --no-sandbox
       1    9177    9177    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumaI8V15/appium-desktop -no-splash
    9177    9220    9177    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumaI8V15/appium-desktop --type=zygote --no-sandbox
       1    9267    9267    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_AppiumWEGRUW/appium-desktop -no-splash
    9267    9310    9267    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_AppiumWEGRUW/appium-desktop --type=zygote --no-sandbox
       1    9325    9325    7920 pts/10      9383 Sl    1001   0:04 /tmp/.mount_Appium89LWnk/appium-desktop -no-splash
    9325    9368    9325    7920 pts/10      9383 S     1001   0:00  \_ /tmp/.mount_Appium89LWnk/appium-desktop --type=zygote --no-sandbox
       1    9383    9383    7920 pts/10      9383 Sl+   1001   0:04 /tmp/.mount_AppiumVhqrfI/appium-desktop -no-splash
    9383    9426    9383    7920 pts/10      9383 S+    1001   0:00  \_ /tmp/.mount_AppiumVhqrfI/appium-desktop --type=zygote --no-sandbox

Out of curiosity I added appimagelauncher - downloaded the appium thing - and launched appium gui without any issues.

So I am fairly certain it is an issue local to your system - and I have no idea what.

Screenshot

20200620-132929_1326x640_screenshot

Thank you for the help! I will try to remove/reinstall Qt-related and probably other related packages. Also I will try to start appium-desktop on the clean system.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by