Stuck during boot

Hi :slight_smile:

My problem is that Manjaro suddenly gets stuck while booting at a message that says A start job is running for dev-mapper-special.device. (I waited for up to 15 minutes and nothing happened.)

I'm on an a few days old install of the Awesome edition. I encrypted it by ticking the option in the installer – no manual changes. The only thing that I changed later that I know might cause trouble is that I made an encrypted hard drive mount automatically by adding it to my crypttab (using a keyfile) and fstab. But that worked without problems, and now that I commented these lines out, Manjaro still doesn't boot. I don't remember doing any other noteworthy things since it last worked.

I couldn't get to a tty, so I used a live system and manjaro-chroot to poke around. I tried some things that are supposed to solve problems that sounded vaguely similar, but to no success.

I found one error in journalctl: systemd[1]: /run/systemd/generator/systemd-cryptsetup@special.service:14: RequiresMountsFor= path is not absolute, ignoring: device
I don't know what that refers to. I'm also not sure if I know how to use journalctl.

I'm posting in the Newbie Corner because I think I'll need some hand holding. I'm pretty new to Manjaro, and my general Linux knowledge is superficial. And I'll be super grateful for any help :green_heart:

(Simply reinstalling wouldn't be a problem, but I'd love to understand what is even happening.)

inxi -Fxz (in the live OS – I compared it to when I do that in the chroot thingie and for most of the things it says the same, except it isn't formatted as nicely. So I thought the more readable one would be better, please tell me if I should post the other one):

  Host: manjaro-awesome 
  Kernel: 4.19.1-1-MANJARO x86_64 
  bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Awesome 4.2 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO 
  product: 23255NG v: ThinkPad X230 
  serial: <filter> 
  Mobo: LENOVO model: 23255NG 
  serial: <filter> UEFI: LENOVO 
  v: G2ET94WW (2.54 ) 
  date: 04/30/2013 
  ID-1: BAT0 charge: 31.6 Wh 
  condition: 61.6/62.6 Wh (98%) 
  model: SANYO 45N1172 
  status: Discharging 
  Topology: Dual Core 
  model: Intel Core i5-3320M 
  bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 
  L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 
  sse4_1 sse4_2 ssse3 vmx 
  bogomips: 20756 
  Speed: 1210 MHz 
  min/max: 1200/3300 MHz 
  Core speeds (MHz): 1: 1197 
  2: 1197 3: 1197 4: 1197 
  Device-1: Intel 3rd Gen Core 
  processor Graphics 
  vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: 1.20.3 
  driver: intel 
  unloaded: modesetting 
  resolution: <xdpyinfo missing> 
  Message: Unable to show advanced 
  data. Required tool glxinfo 
  Device-1: Intel 7 Series/C216 
  Family High Definition Audio 
  vendor: Lenovo 
  driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA 
  v: k4.19.1-1-MANJARO 
  Device-1: Intel 82579LM Gigabit 
  vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 5080 
  bus ID: 00:19.0 
  IF: enp0s25 state: down 
  mac: <filter> 
  Device-2: Intel Centrino 
  Advanced-N 6205 [Taylor Peak] 
  driver: iwlwifi v: kernel 
  port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up 
  mac: <filter> 
  Local Storage: total: 1.14 TiB 
  used: 367.94 GiB (31.6%) 
  ID-1: /dev/sda 
  vendor: Western Digital 
  model: WD10SPZX-00Z10T0 
  size: 931.51 GiB 
  ID-2: /dev/sdb vendor: TCSunBow 
  model: M3 240GB size: 223.57 GiB 
  ID-3: /dev/sdc type: USB 
  model: 090c USB size: 7.50 GiB 
  ID-1: / size: 5.71 GiB 
  used: 337.2 MiB (5.8%) 
  fs: overlay source: ERR-102 
  System Temperatures: cpu: 52.0 C 
  mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 200 Uptime: 44m 
  Memory: 7.61 GiB 
  used: 1.29 GiB (16.9%) 
  Init: systemd Compilers: 
  gcc: 8.2.1 Shell: zsh v: 5.6.2 
  inxi: 3.0.27 

Not sure, but did you use absolute paths in your modified crypttab/fstab?
Please also post lsblk -f, so that we can see your drives' setup.

I used absolute paths in the fstab, and the UUID in the crypttab (the crypttab entries that were created automatically also use UUIDs). Also, the lines that I added are currently commented out, so I hope they don't influence anything.

lsblk -f in the live system:

NAME      FSTYPE      LABEL    UUID                                 MOUNTPOINT
loop0     squashfs                                                  /run/miso/sfs/livefs
loop1     squashfs                                                  /run/miso/sfs/mhwdfs
loop2     squashfs                                                  /run/miso/sfs/desktopfs
loop3     squashfs                                                  /run/miso/sfs/rootfs
sda       crypto_LUKS          0549c3ea-3df1-428f-b215-a715f7e443fb 
├─sdb1    vfat                 CBF5-53E1                            
├─sdb2    crypto_LUKS          2753c8f7-94c2-43e1-bacb-86baca951e6a 
│ └─crypt ext4                 81d562f7-a6ec-4266-bc28-1b4c06dfbf0f /mnt
└─sdb3    crypto_LUKS          1be08caa-37f2-45d9-8b51-361e07b88bf4 
sdc       iso9660     MJRO180  2018-11-07-21-35-56-00               
├─sdc1    iso9660     MJRO180  2018-11-07-21-35-56-00               /run/miso/bootmnt
└─sdc2    vfat        MISO_EFI 8A8D-0EAD                            

Have you installed on UEFI or MSDOS-Legacy mode?
You seem to have booted in MSDOS.

Oh! I installed in UEFI mode. How is this possible and what do I do to fix it? Simply check in my Bios if it is still set to the right thing?

Yes and read the tutorial

1 Like

Thank you for your help.

I ended up reinstalling Manjaro, because figuring out how to apply the tutorial to my encrypted installation didn't seem worth the time (everything that I found on the topic assumed a familiarity with Grub that I don't have). I still learned a lot from reading about these things and am, weirdly, kind of happy about how this went down.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by