Stuck in screen off - suspend limbo :(

I have the issue where almost every time my screen times out and turns off, but before auto sleep/suspend, the system gets stuck. It doesn't go to sleep and I can't get the screen to turn back on. The system appears responsive, as the keyboard backlight lights up when I hit keys, but have to hard restart to be able to use again. I assume it's hardware related as it doesn't just happen on Manjaro, but Windows too. What can I do to track down the offending hardware? Or other suggestions? Maybe a BIOS issue?

Ps. On a rare occasion, it also happens when I attempt to manually put it to sleep/suspend;
Pps. Sometimes it will allow the screen to resume/turn on again. But this is very rare;
Ppps. In any scenario, it almost never auto sleeps/suspends.

System deets:

  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
  root=UUID=fe7bed61-f826-4d2b-ad09-5bbaaf1598c5 rw quiet 
  resume=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef apparmor=1 
  security=apparmor udev.log_priority=3 pci=nommconf 
  Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux 
  Type: Convertible System: Acer product: Spin SP513-52N v: V1.15 
  serial: <filter> 
  Mobo: KBL model: Woody_KL v: V1.15 serial: <filter> UEFI: Insyde v: 1.15 
  date: 04/18/2019 
  ID-1: BAT0 charge: 14.4 Wh condition: 40.4/54.2 Wh (74%) volts: 12.2/11.6 
  model: PANASONIC AP15O5L type: Li-ion serial: <filter> status: Charging 
  Device-1: hid-0003:04F3:2560.0001-battery model: ELAN Touchscreen 
  serial: N/A charge: N/A status: N/A 
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: B4 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 400 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 400 2: 400 
  3: 400 4: 400 5: 400 6: 400 7: 400 8: 400 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Display: x11 server: 1.20.5 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3040 bus ID: 01:00.0 
  chip ID: 168c:003e 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 238.47 GiB used: 44.00 GiB (18.5%) 
  ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: A020 scheme: GPT 
  ID-1: / raw size: 64.00 GiB size: 62.50 GiB (97.65%) 
  used: 43.95 GiB (70.3%) fs: ext4 dev: /dev/dm-0 
  System Temperatures: cpu: 54.0 C mobo: 50.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 263 Uptime: 1h 02m Memory: 7.70 GiB used: 2.55 GiB (33.1%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: gnome-terminal inxi: 3.0.36

In orde for forum members to have some info about your system please read the following:

1 Like

I don't know about Windows, but I think I have the same problem on Manjaro. When it happens, try CTRL+Alt+F1 and then CTRL+Alt+F7. It works for me. :smile:

1 Like

it might have something to do with networkmanager? i've been looking around in threads old and new, and it seems a likely culprit.
I did some poking around with journalctl and found that the suspend signal is sent but that's where the trail ends. there were also some other errors but i checked them and found they were nothing related to this.

I am also facing the same issue...Switching between TTYs does not seem to work for journalctl has some error message from the bluez package...But it may be something entirely unrelated...

I use, Manjaro XFCE edition.

Thanks for the suggestion, but didn't work for me. Have you tracked any deeper to what causes the issue for you? Just random luck that that key combo works for you?

How would I check further into the potential for network manager being the culprit? I'm a fair noob. Can I post any logs that could help? Thanks, dead

Do you have any suggestions that I could try... Gonna be honest, I dunno what you said there lol. I'll do some googling to catch myself up on it, but if you have any guidance on what I could try, I'd be extremely appreciative. Thanks, raining

Install kernel 5.3 and then reboot. Use Manjaro Settings Manager to install kernels. Do not uninstall 5.2.

Thanks for the suggestion... tried it and didn't help, though


sudo systemctl mask tlp


If that doesn't help you can reverse the change by running the command again using unmask instead.

Also, be sure your bios is up to date.

Here's another one to try:

The following command will add a GRUB kernel boot parameter to /etc/default/grub:

sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 


Whether by coincidence or something actually happening, after my second reboot after updating the kernel and doing ...mask tlp I could bring my system back after screen blank and it suspended on its own, which I could bring it back from also!

However, a bunch of things broke after the kernel update (dock, theme, gnome extensions, ...), so I rolled the kernel back again, thinking it might have been the mask tlp did the trick (and that reverting the kernel back was a non-issue). But back on 5.2 it was back to the same issue screen blank. So, I went back to 5.3. This time things didn't break, but back to no revive after screen blank again. My guess is that it was a coincidence that it worked the previous time. What do you think? (sorry, I hope my explanation is clear enough)

I tried the last suggestion you made too, but the problem still persists.

Is there a way I can make a log of what's happening when the system goes blank screen that will still be available after I hard reboot, so I can post it here?

I have a similar problem, I also had it back when using windows and also on my previous install of gnu/linux(debian9).
It could be sth. with the graphic drivers If I remember correctly, but I haven't solved it on manjaro yet.. I'll come back to this topic when I know more.

Not nice to know you're suffering, but nice not to be in it alone :sweat_smile::sleepy:

Please keep me posted if you get somewhere with it... For now, I've just accepted having Caffeine permanently preventing the system attempting to suspend and manually putting it to sleep.

Anyone know if messing around with system sleep states might be able to help? Maybe the system is having trouble to transition to the default allocated state? If it's a device / driver issue, could conflicts be overcome by making changes here?


Re.: Intel Graphics for Linux - How to debug suspend-resume issues

Hey friend, not sure if this is exactly suitable to diagnose this problem, but it might help to diagnose... I haven't been able to get it running yet cause of a permission denied issue (to /sys/power/state despite including sudo (maybe I need to use legit root, but I'm scared of that lol)), but sending it through anyway. Maybe you'll have more luck with it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by