Stuck in the login screen

Yesterday evening, there was an update in Dolphin file manager. I did it via the terminal.
Continued to work after that for about an hour, and then I tried to shutdown to go to sleep. However, from the menu, it didn't work. I tried logout, switch user, nothing. So, I executed a shutdown via the console.

Today, although it seems to boot normally, I cannot login. Just after I enter my pass, it stays there and does nothing. I cannot click on any button, nothing.

Manjaro 18.1
KDE Plasma 5.16
Kernel (don't remember version, but latest stable 5.x)

What can I do?

It looks like the login screen has issue. I think I am using the default though...

I tried to timeshift back, didn't help.
Restart/shutdown/change user work, but before I click the "Login" button. As soon as I click it, does nothing, except, after some time it shuts down monitors.

What can I do? Is there a way to switch login screens and try another one?

Some general things you can do:

And if you still have an issue provide better information (inxi -Fxxxza --no-host,journalctl -p3 -b 0, ..):

Try to switch to another tty , e.g. via ctrl+alt+f2 and login there. Check your journal for errors

$ journalctl -xb -p err

There are no errors before I try to login, but as soon as I hit "Login" this comes up.

Now what...?


As you can see sddm-greeter is dying. Since you mentioned the dolphin-upgrade, you can try downgrading to it's previous version if it's still in your package cache:

$ ls -lh /var/cache/pacman/pkg/dolphin-*
-rw-r--r-- 1 root root 3,9M  5. Sep 19:13 /var/cache/pacman/pkg/dolphin-19.08.1-1-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 4,0M 25. Okt 21:06 /var/cache/pacman/pkg/dolphin-19.08.2-1.1-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 4,0M 10. Okt 17:07 /var/cache/pacman/pkg/dolphin-19.08.2-1-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 280K 24. Aug 21:03 /var/cache/pacman/pkg/dolphin-plugins-19.08.0-1-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 280K  5. Sep 19:13 /var/cache/pacman/pkg/dolphin-plugins-19.08.1-1-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 281K 10. Okt 17:07 /var/cache/pacman/pkg/dolphin-plugins-19.08.2-1-x86_64.pkg.tar.xz
$ pacman -U /var/cache/pacman/pkg/dolphin-19.08.2-1-x86_64.pkg.tar.xz

Did you change anything else besides the dolphin upgrade?

Tried all of them but didn't work. What is that "duplicate database entry" error?


I've never encountered that before, searching the interwebs brought this to light:

After many tries, and with fear that I totally ruined my installation, I tried re-installing, but with keeping my Home folder intact (it is on a separate partition).

I had the same issue! This makes me assume that the problem was on my profile, and not on some package. Maybe a setting? Who knows...?

Anyway, I reinstalled everything from scratch and now I am setting up all over again.
Thank you for your time and efforts.

In such cases, it's better to test with a newly created user.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by