Stuck on boot after changing gfx card

So about a week ago my GTX 1060 malfunctioned suddenly, while I was working on an office document. Everyone I know advised me to buy a new graphics card since even if I send it for repairs it won't be worth it.

Following my friends' advice, I ordered a more mediocre card (RX 560) until I buy a better card in a few years. Shipping was delayed so my pc technician (who hasn't worked with Linux before) installed a very old card just so I can have a pc until my card arrives.

The thing is, he warned me that he couldn't get past "the letters" after booting and that he instead tried a windows live USB (ugh) that worked OK. On getting the pc home, I HOPED I could find a solution, but indeed manjaro won't boot, as shown in the picture. I can access TTY so what should I do here? It's very important that I fix the issue today, because I need to access some documents.


in tty, do

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux
sudo rm /etc/X11/xorg.conf

the last command is the most essential one as that file will still try to hard load the nvidia driver although it won't work and is not even present any more. (That file is only used by proprietary drivers)

The video-linux metapackage contains all free drivers for all manufacturers, that is the one you want to use on Intel and AMD GPU's.

The last command didn't work because it couldn't find the directory. I then rebooted in case it would boot normally but now after selecting Manjaro it won't even display the screen from the photo. In fact I think I can't access TTY anymore... Is this my tombstone?

did you boot to tty with a 3 added to the boot parameter in grub? If not, can you try?

The last command deletes a file, not a directory. Are you sure you typed all commands correctly?

If that does not work, you might want to take a look at that guide:

Once you have chrooted into the installation, post the output of mhwd -li and ls -l /etc/X11
the first one should only show video-linux, the last one should only show directories.

Can you explain in detail where I should add the number 3 so I can access TTY?

when in grub, select the entry for manjaro and press "e", then at the end of the line that also contains quiet and loglevel stuff, simply add a space and a 3 (inside the quotation marks if there are some) and press F10 to boot with that parameter temporarily added.

When it boots to tty, the system is still repairable.
if not, you need to chroot it like told in the guide that I linked earlier.

Thanks, I added the 3 but it after a few seconds it displayed a hardware error. No tty. I'll look into the other solution...

What does this mean?
Drive/partition or pci something?

1 Like

Do you think doing a live usb boot with chroot to reinstall the nvidia driver would help OP? (since it sounds like a drive compatibility issue to me)

when mhwd installs video-nvidia it creates
which is symlinked to

/etc/X11/xorg.conf only gets created if you do something like run nvidia-xconfig without specifying an output location.

1 Like

please read the whole thread. Installing the nvidia driver on an AMD card will not help.

mhwd also removes that one on removal of the driver in mhwd. It does not remove the other file which is present in most cases because it is not created by mhwd. Most users use the nvidia control panel and thus the file is present.

1 Like

The file is not automatically created, only

or the same from GUI.

Go to TTY with Ctrl+Alt+F4 and check journal and Xorg errors

journalctl -b -p3 --no-pager --no-hostname
systemctl status sddm --no-pager 
cat /var/log/Xorg.0.log

I couldn't access TTY in any way possible, so I'm currently downloading manjaro from another computer to perform a live USB boot. Any idea what I should do from there to get the system up and running again? Can I fix the driver issue from there?

you need a live USB to be able to chroot. How did you try chrooting without using a Live USB?

I never attempted chrooting. Sorry if it's not very obvious what I've tried so far, it's just I've been busy irl and following advice from a smartphone isn't the easiest thing on earth.

To clarify, the gfx card is a very old model that my technician didn't even bother telling me its brand because it's a temporary replacement until RX 560 arrives. So far I've only attempted the fix from your first reply, after which for some reason I can't access tty anymore. I will now use the live USB to chroot as you suggested.

20190519_205302 Excellent.. Booting from USB returns an incomprehensible error. The letters appear this way because the card is that old, but can anyone recognize what's the error here based on the layout of the text?

that looks like the "very old" gpu is no good or not seated properly. have you checked if the CPU has integrated graphics you could use instead?

if you know the model/serial # of the CPU you can look it up. if your system wasnt originally built with a dedicated GPU like nvidia or amd then it probably has an integrated gpu you could use. if does have one there's probably an option in bios to enable/disable it. just a thought.

1 Like

Your what now?

Who do you work for? Who else do you employ?

I've checked, it doesn't. I'll probably ask for another card until the other one arrives. How come the technician was able to run a windows 10 live USB and I can't use one with manjaro in it, though?

So to speak.

IDK, but that picture you posted looks like failed hardware. power everything down, disconnect power cord and try re-seating the card. also try another cable for the monitor, those go bad more often than you would expect, and usually go bad after moving/unplugging/plugging them for obvious reasons.

the reason i say this is because your first post shows a working monitor and no video corruption and now you have a fubar'd corrupted display.

you also have not provided any info as to what kind of card this is (make/model)? so try reseating the gpu or even try a different pci slot if you have more than 1 available, try different cable and make sure cables are plugged in all the way. and provide some hardware info, without that this is only a guessing game.


Forum kindly sponsored by