Sudoers setting not working

Just did a fresh install of manjaro i3 minimal 20.0.3
this is the groups my username belongs to

groups $USERNAME                                                                                                                                          
wheel lp sys network power autologin vijay

this is the line i uncommented in sudoers

## Same thing without a password
 %wheel ALL=(ALL) NOPASSWD: ALL

i even tried using my username instead of group name

## Same thing without a password
$USERNAME ALL=(ALL) NOPASSWD: ALL

but its still asking me for password for any sudo command.

sudo nano
[sudo] password for $USERNAME: 

i didn't change anything in the system other than installing firefox and removing palemoon. I even tried rebooting. Just removing the # used to work in arch, do i need to do something else?

For some unknown reason (in the past, anyway) Manjaro put an override in.

Look in /etc/sudoers.d/ I'll bet you'll find a file that has:

%wheel ALL=(ALL) ALL

Delete that file, and you'll be good to go.

2 Likes

It worked like a charm. Thanks a lot.

Forum kindly sponsored by