Suspend and hibernate: computer wakes up without reason

Hi community,
I am trying to fix suspend and hibernation issues on my pc, an Intel NUC6i5 running Manjaro i3, up-to-date (hardware details below).
The strange behaviour is that when I suspend or hibernate my system, both work. However, the system just wakes up by itself after few seconds or few minutes.
I explored the forum and search on internet but did not find any fix or clear duplicate of what I am having here. Likely hardware related as I do not have this problem with other machine. I tried many BIOS options but without success so far. I also tried with 4.19 kernel but it didn't help.
Swap is activated with a huge size.

swapon --show
NAME           TYPE       SIZE USED PRIO
/dev/nvme0n1p3 partition 31.3G   0B   -2

Here are the outputs of blkid -o list and cat /etc/fstab as it was asked in a somehow related post by @tbg .

device     fs_type label    mount point    UUID
-------------------------------------------------------------
/dev/nvme0n1p1
           vfat             /boot/efi      43EA-0250
/dev/nvme0n1p2
           ext4             /              7f591131-119c-4253-8e1b-3b2f286f763d
/dev/nvme0n1p3
           swap             [SWAP]         494faa6d-3099-4a79-8e66-0de4999bb8f8
/dev/sda1  crypto_LUKS      (not mounted)  166c7bf5-55b7-4f3b-9bc0-221c15bb9bf5
/dev/mapper/luks-166c7bf5-55b7-4f3b-9bc0-221c15bb9bf5
           ext4    SSD500_TimeShift /mnt/5550ee7f-bac1-448d-81a8-a3010fd5f8f6 5550ee7f-bac1-448d-81a8-a3010fd5f8f6
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=43EA-0250                            /boot/efi      vfat    umask=0077 0 2
UUID=7f591131-119c-4253-8e1b-3b2f286f763d /              ext4    defaults,noatime 0 1
UUID=494faa6d-3099-4a79-8e66-0de4999bb8f8 swap           swap    defaults,noatime 0 2
/dev/disk/by-uuid/5550ee7f-bac1-448d-81a8-a3010fd5f8f6 /mnt/5550ee7f-bac1-448d-81a8-a3010fd5f8f6 auto nosuid,nodev,nofail,x-gvfs-show 0 0

System:
  Host: NUC6i5 Kernel: 5.4.34-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.3.0 Desktop: i3 4.18.1 info: i3bar 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Intel model: NUC6i5SYB v: H81131-503 
  serial: <filter> UEFI: Intel 
  v: SYSKLi35.86A.0072.2019.1001.1636 date: 10/01/2019 
CPU:
  Topology: Dual Core model: Intel Core i5-6260U bits: 64 
  type: MT MCP arch: Skylake rev: 3 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 
  ssse3 vmx 
  bogomips: 14404 
  Speed: 706 MHz min/max: 400/2900 MHz Core speeds (MHz): 
  1: 735 2: 795 3: 781 4: 770 
Graphics:
  Device-1: Intel Iris Graphics 540 driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1926 
  Display: x11 server: X.Org 1.20.8 driver: modesetting 
  alternate: fbdev,intel,vesa compositor: compton 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel Iris Graphics 540 (SKL GT3) 
  v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  chip ID: 8086:9d70 
  Sound Server: ALSA v: k5.4.34-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V driver: e1000e 
  v: 3.2.6-k port: f040 bus ID: 00:1f.6 chip ID: 8086:1570 
  IF: eno1 state: up speed: 1000 Mbps duplex: full 
  mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel 
  port: f040 bus ID: 01:00.0 chip ID: 8086:24f3 
  IF: wlp1s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 704.24 GiB 
  used: 363.61 GiB (51.6%) 
  ID-1: /dev/nvme0n1 vendor: Samsung 
  model: SSD 950 PRO 256GB size: 238.47 GiB 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B0QBXX7 
  scheme: GPT 
  ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB 
  size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
  rev: 2B6Q scheme: GPT 
Partition:
  ID-1: / size: 191.25 GiB used: 33.92 GiB (17.7%) 
  fs: ext4 dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 31.25 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 65.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 176 Uptime: 2h 16m Memory: 7.67 GiB 
  used: 3.61 GiB (47.0%) Init: systemd v: 244 Compilers: 
  gcc: 9.3.0 Shell: bash v: 5.0.16 running in: urxvtd 
  inxi: 3.0.37 

Any guidance much appreciated!

In sleep mode: there might be an application that is preventing the computer from going to sleep (BitTorrent clients are the most likely culprit) so:

  • Close applications one by one and see which one is preventing sleep mode.

In Hibernation mode: it is possible to turn on a shut down computer through Wake-on-LAN (WoL) packets. (IOT devices are the most likely culprit)

  • Shut down your IOT devices before hibernating and start them one by one and see which one wakes up your computer. (Don't forget to check your router as that can do this too)

For both:

I'd try the latest and greatest stable kernel first: 5.6 instead of 4.19 LTS...

:innocent:

Hi Fabby,
Thanks for the tips. Wake-on-LAN does not seem to be the issue, as it happens even when I disconnect the cable and turn the Wifi off, and it is disable in the BIOS. Not really sure what are the 'IOT' things that can be running here by the way.
As I am running kernel 5.4, will check the 5.6 but have few hopes that it will fix the thing.
Last night the suspend was fine. I suspend the machine after a cold boot without any startup application added. But today, the problem is back, even if very few things are running in my session. Am trying to identify the application that might suspend the sleep mode. Not that obvious so far...

1 Like

Disconnecting my protonmail account from thunderbird solve the issue. Nothing directly related to Manjaro.
Autocorrect, blueman is causing the issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by