Suspend issue

I just installed Manjaro.
When several applications are open and I want to suspend the laptop, it causes the manjaro to freeze or hang.
I have to physically turn the laptop off and on again by holding the on / off button of the laptop and holding this button for a few seconds.

Please please help me

Please provide from terminal:
inxi -Fxxxza --no-host
Use ``` above and bellow it, or use Preformatted text button </> when you paste it here.

Power management basics are described here
Probably your system needs some tweaking, but in order to know, we need more details about it.

Changed the title from "Freeze Manjaro" as is misleading.

Might be totally unrelated and providing the log bogdancovaciu asked for will get you more information. I was having the same problem on my msi laptop and saw something in my xsession logs about my Bluetooth mouse. If I switch my mouse on before the laptop wakes up then I get black screen, I have to wait for the laptop to wake up before switching the mouse on

1 Like

Hello my friends
Is this output what you want?
Did I do what you said?

inxi -Fxxxxza --no-host
System: Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=0d170757-0931-4fc1-963e-c0f835c36a43
rw quiet apparmor=1 security=apparmor resume=UUID=deeb8ec5-a1a9-406c-ac73-17c3a43608bd
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine: Type: Laptop System: ASUSTeK product: N552VW v: 1.0 serial:
Mobo: ASUSTeK model: N552VW v: 1.0 serial: UEFI: American Megatrends v: N552VW.300
date: 08/31/2016
Battery: ID-1: BAT0 charge: 18.6 Wh condition: 33.0/48.2 Wh (68%) volts: 14.4/14.4
model: ASUSTeK ASUS Battery type: Li-ion serial: status: Discharging cycles: 705
CPU: Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S family: 6
model-id: 5E (94) stepping: 3 microcode: D6 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41621
Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 802 3: 800 4: 800 5: 800
6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Graphics: Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:191b
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: ASUSTeK driver: nouveau v: kernel
bus ID: 01:00.0 chip ID: 10de:139b
Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa compositor: kwin_x11 resolution: 2560x1440~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:a170
Sound Server: ALSA v: k5.4.52-1-MANJARO
Network: Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0
chip ID: 8086:095a
IF: wlp2s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: d000 bus ID: 03:00.1 chip ID: 10ec:8168
IF: enp3s0f1 state: down mac:
Drives: Local Storage: total: 931.51 GiB used: 38.56 GiB (4.1%)
ID-1: /dev/sda vendor: Toshiba model: MQ02ABD100H size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: 1J scheme: GPT
Partition: ID-1: / raw size: 532.10 GiB size: 522.75 GiB (98.24%) used: 16.54 GiB (3.2%) fs: ext4
dev: /dev/sda4
ID-2: /home raw size: 390.62 GiB size: 383.49 GiB (98.17%) used: 22.02 GiB (5.7%) fs: ext4
dev: /dev/sda3
ID-3: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60)
cache pressure: 100 (default) dev: /dev/sda2
Sensors: System Temperatures: cpu: 41.5 C mobo: N/A gpu: nouveau temp: 35 C
Fan Speeds (RPM): cpu: 2100
Info: Processes: 231 Uptime: 9m Memory: 7.67 GiB used: 1.39 GiB (18.2%) Init: systemd v: 245
Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 running in: konsole inxi: 3.0.37

Thanks for the tips

Not quite, but is fine.

Usually Asus laptops with that dGPU in the hybrid configuration require:

  • kernel boot parameter acpi_osi=! acpi_osi='Windows 2009' with the existing ones
  • proprietary drivers instead of the nouveau that your system is using right now

Consider following this:

Hello my friend
You helped me a lot and my problem was solved
thank you
Now something else happened that was unexpected for me
I expected my charge to decrease when I used an Intel graphics card
But now it drains the battery by one percent every minute, and that's annoying
Where do you think the problem comes from?
What solution do you suggest?

Did you use the kernel parameters i mentioned? Or others as mentioned here

Is important. Also some tweaks can be done following this:

Ask any question if you get stuck at some point.

I installed the graphics card well
And I can use Intel, Nvidia or Hybrid every time
In Intel mode, battery consumption is high, but the hybrid is better than Intel mode and consumes less, but it is not interesting!

But regarding this tutorial that you sent me, my only operating system is Linux (Manjaro) and I do not know what to do with the Windows version!
Please help me further

Thank you very much for posting and explaining to me

No, no ... Windows as OS is not involved in the ACPI kernel arguments. Is just a way to inform the kernel for better support on machines that where made with Windows OS in mind, and how those information tables are propagated. The better choice is made by testing. Usually as i mentioned before

is the most suitable in most cases.

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=deeb8ec5-a1a9-406c-ac73-17c3a43608bd udev.log_priority=3"


GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi='Windows 2009' rd.udev.log-priority=3 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash nvme_core.default_ps_max_latency_us=5500"

Do I have to edit and replace this command as you said in the file?
I've not mastered Linux yet, so I ask a lot of questions

Forgive me

acpi_osi='OSI String' 3
Note on acpi_osi=!
acpi_osi=! acpi_osi='Windows 2009'

Do I have to add a few commands or just add this command and that's it? Do not need anything else?

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi='Windows 2009' rd.udev.log-priority=3 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash nvme_core.default_ps_max_latency_us=5500"

Just addacpi_osi=! acpi_osi='Windows 2009'to the end of the existing GRUB_CMDLINE_LINUX_DEFAULT= making sure it is inside the double parentheses"

So if this is your existing line
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=deeb8ec5-a1a9-406c-ac73-17c3a43608bd udev.log_priority=3"

it would now look like this

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=deeb8ec5-a1a9-406c-ac73-17c3a43608bd udev.log_priority=3 acpi_osi=! acpi_osi='Windows 2009'"
1 Like

thank you
For your guidance

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by