Suspend to RAM doesn't work

When I try to suspend my PC to RAM screen goes black but PC stays on. I can hear fans running and the power LED is still on. How can I fix this? I am using vanilla 5.4 kernel. My file system is btrfs. And swap is not enabled. I tried s2ram module from AUR.

System:    Kernel: 5.4.31-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2020-04-09_12-20-37/@/boot/vmlinuz-5.4-x86_64 
           root=UUID=817108a0-84c0-4e70-b712-c0f9b140d4c5 rw rootflags=subvol=timeshift-btrfs/snapshots/2020-04-09_12-20-37/@ 
           quiet udev.log_priority=3 nouveau.config=NvBios=PRAMIN 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 dm: LightDM 1.30.0, SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq dc7800 Convertible Minitower v: N/A serial: <filter> 
           Chassis: type: 6 serial: <filter> 
           Mobo: Hewlett-Packard model: 0AACh serial: <filter> BIOS: Hewlett-Packard v: 786F1 v01.35 date: 10/23/2015 
CPU:       Topology: Quad Core model: Intel Core2 Quad Q8300 bits: 64 type: MCP arch: Penryn family: 6 model-id: 17 (23) 
           stepping: A (10) microcode: A0E L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 19963 
           Speed: 2085 MHz min/max: 1998/2500 MHz Core speeds (MHz): 1: 2085 2: 2100 3: 1995 4: 1995 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GT218 [GeForce 210] vendor: ZOTAC driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:0a65 
           Display: x11 server: X.Org 1.20.8 driver: nouveau compositor: kwin_x11 resolution: 1920x1080_60.00~60Hz 
           OpenGL: renderer: NVA8 v: 3.3 Mesa 20.0.4 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:293e 
           Device-2: NVIDIA High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0be3 
           Sound Server: ALSA v: k5.4.31-1-MANJARO 
Network:   Device-1: Intel 82566DM-2 Gigabit Network vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: 2100 
           bus ID: 00:19.0 chip ID: 8086:10bd 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus ID: 2-5:3 chip ID: 148f:7601 
           IF: wlp0s29f7u5 state: up mac: <filter> 
Drives:    Local Storage: total: 596.18 GiB used: 339.78 GiB (57.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-00L7A0 size: 298.09 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 3E01 scheme: MBR 
           ID-2: /dev/sdb vendor: Seagate model: ST3320418AS size: 298.09 GiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC38 scheme: MBR 
Partition: ID-1: / raw size: 98.09 GiB size: 98.09 GiB (100.00%) used: 49.66 GiB (50.6%) fs: btrfs dev: /dev/sda3 
           ID-2: /home raw size: 98.09 GiB size: 98.09 GiB (100.00%) used: 49.66 GiB (50.6%) fs: btrfs dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A gpu: nouveau temp: 58 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 225 Uptime: 27m Memory: 3.77 GiB used: 1.40 GiB (37.3%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           clang: 9.0.1 Shell: zsh v: 5.8 running in: konsole inxi: 3.0.37 

Welcome to Manjaro.

Did you try it because suspend would not work otherwise or did you install it first and suspend would not work afterwards?

1 Like

I tried it because systemctl suspend didn't work.

Btw I added inxi output.

Thanks for adding detailed system info.

Do you see any hints/errors in journal for the times when suspending fails?
Does the machine still react to ping and/or remote login via ssh when the "screen goes black"?

This is your problem.

1 Like

I enabled swap but still doesn't work.


Your details are sadly lacking.


blkid -o list 

cat /etc/fstab

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by