Suspension broken

The stable update from 2018-10-08 broke my suspension. The computer gets a black screen and is not reacting on any of my inputs. I'm on kernel 4.18.12-1-MANJARO.

EDIT: Maybe it's the screensaver which never wakes up again. With disabled settings this problem still appears after a while of being AFK.

Try updating to kernel 4.19, if no better try going back to 4.14.

If that doesn't help, post:

inxi -Fxxxz

Say again. You're breaking up!!!

Ok tried again on 4.19 and 4.20, still broken for me. Mouse is powered off, screen turns black but power light stays normal (blue) should be blinking in orange when suspended. After I get into this state I have to hard power off since I cannot wakeup the laptop anymore.

inxi -Fxxxz
  Host: felix-manjaro Kernel: 4.20.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Gnome 3.30.2 wm: gnome-shell dm: GDM 3.30.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire VN7-591G v: V1.15 
  serial: <filter> 
  Mobo: Acer model: Aspire VN7-591G v: V1.15 serial: <filter> UEFI: Insyde 
  v: 1.15 date: 08/06/2015 
  ID-1: BAT0 charge: 35.9 Wh condition: 37.2/52.5 Wh (71%) volts: 12.4/11.4 
  model: LGC AC14A8L type: Li-ion serial: <filter> status: Not charging 
  Topology: Dual Core model: Intel Core i5-4210H bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23159 
  Speed: 798 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 798 2: 799 
  3: 798 4: 798 
  Device-1: Intel 4th Gen Core Processor Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0416 
  Device-2: NVIDIA GM107M [GeForce GTX 960M] driver: N/A bus ID: 01:00.0 
  chip ID: 10de:139b 
  Display: x11 server: 1.20.3 driver: N/A compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.1 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:03.0 chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-3: C-Media type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 2-1:2 chip ID: 0d8c:0012 
  Sound Server: ALSA v: k4.20.0-1-MANJARO 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Foxconn driver: ath10k_pci v: kernel port: 5040 bus ID: 07:00.0 
  chip ID: 168c:003e 
  IF: wlp7s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: 3000 bus ID: 08:00.0 
  chip ID: 10ec:8168 
  IF: enp8s0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 88.05 GiB (18.9%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ02ABF050H size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 5A scheme: GPT 
  ID-1: / size: 249.80 GiB used: 88.00 GiB (35.2%) fs: ext4 dev: /dev/sda7 
  ID-2: swap-1 size: 14.65 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 260 Uptime: 2m Memory: 7.71 GiB used: 1.53 GiB (19.8%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 clang: 7.0.1 Shell: bash 
  v: 4.4.23 running in: gnome-terminal inxi: 3.0.28

Relatively sure this is the same thing I am currently battling.
Machine kept dying when it was shut with almost full battery. Seemed odd.
Then tracked it to the buggy QCA6174.

Partial fix was to nmcli networking off before suspend then on again after. Automated.
This fixed suspends.

But .. sometimes network commands (and more) get stuck because the firmware crashed.

There was an update to the firmware for this card just 2 weeks ago. Which is already in Unstable. I'm testing now a combination of solutions.


Yeah indeed, that's the problem.
I fixed it with the scripts from [SOLVED] QCA6174 freez after suspend.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by