Switch from bumblebee to optimus-manager

I tried following this Wiki guide about it:

https://wiki.manjaro.org/index.php?title=Optimus_Manager

But it clearly says that you have to disble/uninstall Bumblebee to be able to run it. I've tried the later, uninstalling bumblebee and all related packages. However, when I install optmus-manager and restart the system, it completely freezes. I had to reinstall the whole OS again (not a very big deal since I just switched to Manjaro a couple hours ago) so here I am in the same place.

Also, this may be important: in Manjaro Settings Manager I've got video-hybrid-intel-nvidia-bumblebee installed for my card. Is that the correct driver I need to use? I tried switching to video-nvidia but with that one I wasn't even able to log in to my session because I was getting a black screen after booting (had to reinstall the first one through a TTY).

Any help is appreciated!

This could help.

and this.

1 Like

I've read those posts and I still don't know if video-hybrid-intel-nvidia-bumblebee is a driver that can be used with optimus-manager, because by it's name I don't know if it's strictly related to bumblebee. That's my primary concern, because in the first post it only says that that's the name mhwd gives to the driver when doing an automatic installation... Is it only a naming thing? Thanks for your help!

Yes, it's a naming thing. You have automatically installed by mhwd:

  • nvidia driver: nvidia-utils and lib32-nvidia-utils plus kernel modules in form of linuxXX-nvidia, where XX is a number of the kernel
  • bumblee as: bumblebee
  • intel driver: not sure which package is responsible for it, never needed it to know

Mhwd made an automatic configuration to make bumblebee work, so by default you use intel driver and have access to nvidia through bumblebee.

Optimus manager require to disable bumblebee and disable those automatic graphic confics so optimus-manager could create own configs needed for the switch.

Basically, if you never messed with graphics and just installed manjaro with non-free drivers on hybrid laptop and graphic session works, you can start installing and configuring optimus-manager.

So, just disabling bumblebee service should be enough?

Yes, it's enough, just as posted in the guide above. Note, that my tutorial is more recent, so some information on the first one is outdated, but has some parts that I deliberately omitted. I focused for easy GUI experience when using optimus-manager.

You also must try out if the noveau is working for you as a switch method or maybe bbswitch is better. There is a danger that the other setting will cause the system unable to use graphic. Use tty and change manually back:

/etc/optimus-manager/optimus-manager.conf

Then reboot.

Can you expand on this? Sorry for bothering you but I prefer to know what I'm doing before doing it :sweat_smile:

By default optimus-manager uses noveau to switch GPUs (power off and on) but you can use bbswitch (which is usually already installed) if the noveau won't work for you. If it does, then don't touch that setting. However, there is a possibility one of these won't work correctly so the system won't boot into X session, hence the need to revert it back manually in tty.

You will see it in optimus-manager settings if things go well. It is also always accessible in the config file.

Finally made it work! As you said, noveau wasnt't working for me, but bbswitch does it perfectly! However, the conf file wasn't located in

/etc/optimus-manager/optimus-manager.conf

Instead. it was in:

/usr/share/optimus-manager.conf

Maybe it has to do with a new version, I don't know about it. However I prefer to tell you because someone may have the same problem!

Thank you very much @michaldybczak and @admdb!

1 Like

The /usr/share/optimus-manager.conf is the BASE CONFIG FILE (a blueprint) and shouldn't be edited. If you don't have /etc/optimus-manager/optimus-manager.conf just copy it from the base file and edit the one in /etc/optimus-manager/

I'd like to join in thanking you guys for the tutorial. It worked great on my Kde edition (after i borked it first time by leaving bumblebee on and not renaming the X11 files).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by