Switched from Nvidia 970 to 2080Ti, Stuck at Started TLP system startup/shutdown

Hi, first post here.

I know the issue is being discussed in some other posts. But as far as I can tell they are mostly about new installations of Manjaro.

I have been running my Manjaro installation happily for the last 6 months with a Nvidia 970 GPU.
This week I had a 2080Ti delivered and installed it in the computer.
When booting the systems stops at Stuck at Started TLP system startup/shutdown.
So I tried some of the flags found here.
Like this one: acpi_osi=! acpi_osi="Windows 2009" and this one: nouveau.modeset=0. But no luck there.
I think it's strange since I have been running my 970 without any troubles what so ever. Sure the new one is probably really different from the old one.
If it helps I guess I can put the old one in and boot using that one.

I also tried to create a Live USB to boot from, that did not work either. Even when using the above flags.
So here I am with a really expensive graphics card, and my computer won't boot :slight_smile:
I would really appreciate your help!

Hot swapping a video card and just expecting it to work may not be the best idea, especially an old gpu for a state of the art gpu.

This is a very new video card, are you sure it is stable in Linux yet? Nvidia support in Linux usually lags behing nvidia support in Windoze.

The current nvidia driver in Manjaro is 410.57, first step is to check this driver supports 2080ti.

What kernel are you using? It may well require kernel 4.19 to operate properly, most very recent hardware requires the latest kernel (usually).

To properly troubleshoot a non booting system boot using a live ISO, chroot into your sytem, check journal logs and xorg logs for specific errors that can be used to diagnose the issue.

System info via inxi -Fxx wouldn't hurt either.

4 Likes

Thank you for the answer.
Of course you are totally correct. Expecting it to work right away without any hickups would be to much to ask.
But I didn't see any reason not to try it out.
What I can gather the driver 410.57 supports 2080 cards.
I will keep researching using the answer you provided.
If I can get the live ISO to boot. Unfortunately that seems problematic, so I guess I'll have to put the old card in again. From there I'm not really sure what to do. But I'll start with drivers.

Try the 18.0-rc1 ISO that have just been built, they have the 4.19 kernel I think.

If you can get into a live environment, chroot and try to remove then re-install the driver.

Check your xorg config.

You could try TTY2 to do some preliminary investigation (CTRL+ALT+F2).

Once you have either a journalctl or xorg error message you can start researching a fix.

2 Likes

And what driver do you currently have installed for your old card?

The 970 would require the latest mainline nvidia driver to work, which is 410.57 in our repos.

Fair enough. Just thought he might be running 390x or 340x for some odd reason. :stuck_out_tongue:

Well, you were right.
Of course I should have checked the driver version before putting the card in.
I guess I was a bit to eager getting up and running.
Seems to work fine with the 4.14.74 kernel.

Thanks for the help guys, I should've figured this one out myself..

Here's system info, for what it's worth. If some one else is finding this thread.

System:    Host: simon-manjaro Kernel: 4.14.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: Gnome 3.30.0 wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: MSI product: MS-7971 v: 2.0 serial: <root required> 
           Mobo: MSI model: Z170A PC MATE (MS-7971) v: 2.0 serial: <root required> UEFI: American Megatrends 
           v: A.40 date: 09/07/2015 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S serial: 4069-5c-5d-09-7e 
           charge: 10% (should be ignored) status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S rev: 3 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64152 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 801 
           7: 800 8: 800 
Graphics:  Device-1: NVIDIA driver: nvidia v: 410.57 bus ID: 01:00.0 chip ID: 10de:1e07 
           Display: x11 server: X.org 1.20.1 driver: nvidia compositor: gnome-shell 
           resolution: <xdpyinfo missing> 
           OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 410.57 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a170 
           Device-2: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f7 
           Sound Server: ALSA v: k4.14.74-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: d8:cb:8a:cc:b3:5e 
           IF-ID-1: br-94f6f449899b state: down mac: 02:42:e1:92:78:14 
           IF-ID-2: docker0 state: down mac: 02:42:81:7b:74:a4 
Drives:    Local Storage: total: 465.76 GiB used: 73.34 GiB (15.7%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s 
           serial: S21JNXAH202169H 
Partition: ID-1: / size: 83.03 GiB used: 73.32 GiB (88.3%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 32.0 C mobo: 29.8 C gpu: nvidia temp: 35 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
Info:      Processes: 251 Uptime: N/A Memory: 31.37 GiB used: 1.61 GiB (5.1%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 alt: 5/7 Shell: zsh v: 5.6.2 running in: gnome-terminal inxi: 3.0.26
1 Like

What driver version was installed? Were you still on the 396 series for some reason?

How does it perform?

Benchmark testing on Phoronix was pretty impressive, although given the cost it would want to be ... :slight_smile: .

1 Like

Correct, still on 396. Well I guess there's no excuse, I've been lazy and not updated for some time.

It's a bit of a though one, going on vacation on friday, not sure how much testing I manage to do before that. :slight_smile:
But will try to run the Phoronix test suite as soon as I get some time over :slight_smile:

@simtrax So did all you do was switch to kernel 4.14? I'm currently running a 6700K like you, but on 4.18 and have mhwd-nvidia (410.66-1), *-34xx, and *-390xx installed. Tried using KDE 18.0 RC3 and still got the TLP error.

Is it literally just kernel 4.14 and the bundled nvidia drivers or do I need to install other packages? Asking because it seems really strange that to get support for a new GPU I would need to downgrade from 4.19 or 4.18 to 4.14....

I too was once stuck at Started TLP system startup/shutdown.
Follow these steps and please reply.

From thread won't boot beyond login screen

Forum kindly sponsored by