Switching to nonfree drivers from free after install?

I'm using a PC running Windows 8.1, with an i5-4670k, an EVGA GTX 970, and a Samsung 840 Pro SSD as the boot drive. I have both Fast Boot and Secure Boot disabled in the UEFI. I can only get to the live environment from my KDE live USB drive if I select the free drivers, which I understand are optimized for AMD and Intel integrated graphics rather than Nvidia cards. If I select the nonfree drivers, my boot process gets stuck on the "TLP system startup/shutdown" item that so many other users seem to have experienced. I figured it would be easier to just get a partition going and deal with the problem from there, where I can more readily access the command line to save logs, etc., instead of wrestling with the install.

Also, one thing I've noticed is that, when I do use the free drivers to run the installer from the live environment, I don't get all of the partition items I'm supposed to. There's no option for me to install Manjaro alongside Windows, or to replace a partition--only the "erase disk" and "manual partitioning" options.

EDIT: Information added per request:

  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MJRO1812 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.17.1 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z87X-D3H v: N/A 
  serial: <filter> Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z87X-D3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F9 date: 08/25/2014 
  Topology: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 27146 
  Speed: 1197 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1197 
  2: 1198 3: 1197 4: 1198 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0412 
  Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:13c2 
  Display: x11 server: X.Org 1.20.5 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: NV124 v: 4.3 Mesa 19.2.2 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Device-3: NVIDIA GM204 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb 
  Sound Server: ALSA v: k5.3.7-2-MANJARO 
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e 
  v: 3.2.6-k port: f080 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter 
  driver: ath9k v: kernel port: e000 bus ID: 03:00.0 chip ID: 168c:0030 
  IF: wlp3s0 state: down mac: <filter> 
  Local Storage: total: 2.51 TiB used: 134.9 MiB (0.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 6B0Q scheme: MBR 
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 EVO 500GB 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: BB6Q scheme: MBR 
  ID-3: /dev/sdc vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC24 scheme: MBR 
  ID-4: /dev/sde type: USB vendor: PNY model: USB 2.0 FD size: 3.73 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 4096 
  scheme: MBR 
  ID-1: / raw size: N/A size: 5.75 GiB used: 134.9 MiB (2.3%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 33 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 502 
  Processes: 203 Uptime: 2m Memory: 7.67 GiB used: 966.3 MiB (12.3%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: konsole inxi: 3.0.36 ```

When I ran `sudo dmesg` in the live boot with free drivers, the only error I could find was this:
```[    3.781326] [TTM] Initializing DMA pool allocator
[    3.781338] nouveau 0000:01:00.0: DRM: VRAM: 4096 MiB
[    3.781339] nouveau 0000:01:00.0: DRM: GART: 1048576 MiB
[    3.781342] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    3.781343] nouveau 0000:01:00.0: DRM: DCB version 4.1
[    3.781344] nouveau 0000:01:00.0: DRM: DCB outp 00: 01000f02 00020030
[    3.781345] nouveau 0000:01:00.0: DRM: DCB outp 01: 02000f00 00000000
[    3.781347] nouveau 0000:01:00.0: DRM: DCB outp 02: 04011f82 00020030
[    3.781348] nouveau 0000:01:00.0: DRM: DCB outp 03: 02022f62 00020010
[    3.781349] nouveau 0000:01:00.0: DRM: DCB outp 05: 02833f76 04400020
[    3.781349] nouveau 0000:01:00.0: DRM: DCB outp 06: 02033f72 00020020
[    3.781351] nouveau 0000:01:00.0: DRM: DCB outp 15: 01df5ff8 00000000
[    3.781352] nouveau 0000:01:00.0: DRM: DCB conn 00: 00001030
[    3.781366] nouveau 0000:01:00.0: DRM: DCB conn 01: 01000131
[    3.781367] nouveau 0000:01:00.0: DRM: DCB conn 02: 00010261
[    3.781368] nouveau 0000:01:00.0: DRM: DCB conn 03: 00020346
[    3.781369] nouveau 0000:01:00.0: DRM: DCB conn 05: 00000570
[    3.781860] nouveau 0000:01:00.0: DRM: MM: using COPY for buffer copies
[    3.802514] nouveau 0000:01:00.0: DRM: failed to create encoder 1/8/0: -19

Running `journalcl -p3 -b -0 netted the following:

-- Logs begin at Fri 2019-11-01 16:52:28 UTC, end at Fri 2019-11-01 17:09:22 UTC. --
Nov 01 16:52:28 manjaro kernel: nouveau 0000:01:00.0: bus: MMIO write of 80000140 FAULT at 10eb14 [ IBUS ]
Nov 01 16:52:28 manjaro kernel: sd 7:0:0:0: [sde] No Caching mode page found
Nov 01 16:52:28 manjaro kernel: sd 7:0:0:0: [sde] Assuming drive cache: write through
Nov 01 17:03:07 manjaro systemd-coredump[3216]: Process 3087 (less) of user 1000 dumped core.
                                                Stack trace of thread 3087:
                                                #0  0x00007fb7b5d00f25 raise (libc.so.6)
                                                #1  0x00007fb7b5cea897 abort (libc.so.6)
                                                #2  0x00007fb7b5d44258 __libc_message (libc.so.6)
                                                #3  0x00007fb7b5d4b77a malloc_printerr (libc.so.6)
                                                #4  0x00007fb7b5d4c178 malloc_consolidate (libc.so.6)
                                                #5  0x00007fb7b5d4e2b3 _int_malloc (libc.so.6)
                                                #6  0x00007fb7b5d4fe84 malloc (libc.so.6)
                                                #7  0x00007fb7b5d39b44 _IO_file_doallocate (libc.so.6)
                                                #8  0x00007fb7b5d485c0 _IO_doallocbuf (libc.so.6)
                                                #9  0x00007fb7b5d4754c _IO_file_underflow@@GLIBC_2.2.5 (libc.so.6)
                                                #10 0x00007fb7b5d48676 _IO_default_uflow (libc.so.6)
                                                #11 0x000056403949e4a0 n/a (less)
                                                #12 0x000056403949eeb3 n/a (less)
                                                #13 0x00005640394a444f n/a (less)
                                                #14 0x00005640394a5d3a n/a (less)
                                                #15 0x000056403949a68c n/a (less)
                                                #16 0x000056403949bd47 n/a (less)
                                                #17 0x000056403949433f n/a (less)
                                                #18 0x00007fb7b5cec153 __libc_start_main (libc.so.6)
                                                #19 0x00005640394943de n/a (less)

First off, read the following post and make the needed edits to your first post.

Without this information, nobody can really help you. You can do all of the above post in a Live session while using free drivers.

Second, to get past the "TLP" error, you may need a kernel parameter.

Read it carefully and follow the directions.

1 Like

Have booted the iso in UEFI or legacy mode?

Here is also a guide on dual booting Manjaro and Windows:

Thank you for the suggestions, the OP has been updated accordingly. I tried the fix presented in your article by opening the terminal using Ctrl+Alt+F2 after the boot hung up on the TLP command. Then I modified the pertinent line in Grub to read:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi='Windows 2013'"
However, even after doing and rebooting, the boot continues to hang up on that line.

I made sure to disable legacy mode before booting, yes.

Are you sure your Windows install uses UEFI? All your drives use MBR. That is normally used for legacy boot systems. If your Windows install runs in legacy you should also install Manjaro in legacy mode.
please provide the output of lsblk -f

I assumed it did, since my motherboard uses UEFI. I'll return the output of lsblk -f momentarily.

The output of lsblk -f is as follows:

     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
│    ntfs         01D590656AFAB6D0                                   
│    ntfs         FC1226C1122680AE                                   
     ntfs         E8B07887B0785E4E                                   
     ntfs   Steam Games
│    ntfs   System Reserved
│                 6EFEC50EFEC4CF8F                                   
     ntfs   Multimedia
sde  iso966 MJRO1812
│                 2019-10-28-13-18-58-00                             
│    iso966 MJRO1812
│                 2019-10-28-13-18-58-00                     0   100% /run/miso/
     vfat   MISO_EFI

Your Windows system is using legacy boot not UEFI as there is no efi partition on your system present. sde2 is the efi partition of the manjaro live-usb stick.
The install-option should appear if you boot the live-system with legacy-boot enabled. In any case I recommend you to install Manjaro in Legacy-Mode.

As you already have multiple drives in your system, how about resizing your second SSD with your Steam-library and installing Manjaro there, so that the two OS are on separate drives?
It would be beneficial to shrink the partition from Windows (and maybe create a backup beforehand). Afterwards you'd have to use the manual partitioning (it is doable) option to define where the partition(s) should be.
If you don't feel comfortable with that another option would be to move your steam library somewhere else, remove all other drives and install Manjaro on the entire drive.
However, a specialized install will always require manual partitioning to an extend.
If you install with the auto-option, AFAIK Manjaro will be installed on your primary windows drive and the manjaro bootloader will be placed in the MBR of that drive. That can lead to boot issues later (e.g. a windows update removes the manjaro bootloader from the MBR or Windows may become unbootable if the manjaro bootloader is broken).

I think you could run the installer semi-automatic by first shrinking the disc space, creating a partition where Manjaro should be located and then selecting replace partition in the installer and then selecting the partition you just created. :thinking:

Anyway keep attention as the installer will tell you what it will do. After the setup you will see a summary. Double check that and make sure it does what you want

I think this wiki page and especially the section in the user guide might be useful for you:

Regarding the partition names this explains you the device names:

Installing on a different drive is a possibility which I might do. If I just format my current boot drive and install Manjaro on there, would I still need to do manual partitioning, or would the formatting process allow me to reconfigure the drive to work with UEFI? Since the only reason I'm dual-booting is for games, I figure I'll just reinstall windows 8 on my Steam Games volume at a later date and configure it for UEFI.

You can use the auto partitioning and select erase disk. The installer will create an GPT-based partition table and configure EFI-boot if you booted via UEFI. You can also see that in the installation dialog (there should be an EFI partition, GPT as partition table, ...).
You will need to run

sudo update-grub

after you installed Windows to your other SSD. I don't know if Windows messes with a separate drive, but I recommend to disconnect the SSD with Manjaro while you are installing Windows. Make sure that you install Windows also as an EFI system. Otherwise GRUB will not detect it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by