Synaptics TouchpadOff=1 after unlocking screen

For a while now, when logging back in after hybernating the system, my ThinkPad P1's touch pad sometimes has not been responding. Oddly, while on the lock screen the touchpad is always responding just fine.

I've done some investigation and using synclient found out that after login that SynTouchpadOff=1 instead of 0. Setting it to 0 immediately made the touchpad work again.

I'd like to get to the bottom of this. Any clues? Open questions to begin with:

  1. On the locks screen, is the touchpad still run via the Synaptics driver?
  2. What could cause setting SynTouchpadOff to 1? I certainly did not configure this anywhere myself.

I am on anjaro 20.0.3, Linux 5.4.40-1-MANJARO and Xfce4.

Finding out why this is happening is going to need lot of time, whereas solving the issue is going to be straightforward:

  • Just create a script that turns the trackpad back on at each login:

    sudo nano --backup /usr/local/bin/TouchpadOn
    
  • Add the following text:

    #!/bin/bash
    synclient SynTouchpadOff=0
    
  • Save and exit: Ctrl+X Y Enter

  • Make the script executable for all users:

    sudo chmod a+x /usr/local/bin/TouchpadOn
    
  • Add it to your startup programs. (Example given below for KDE as this is my Desktop Environment. If you have something else, seacht how to do this on your own DE)

  • On KDE this is accomplished by:

    • Going to System Settings
    • Typing start
    • Clicking on Autostart
    • Clicking on Add Script
    • Copy-paste (or browse to) /usr/local/bin/TouchpadOn
    • Click OK

Done!

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

I am aware of that. Considering I managed to find out why the trackpad was not working, it wouldn't take much to fix it when starting my Xfce4 desktop :wink:

I'd nevertheless be more interested in finding the actual deeper root cause despite the additional effort, just to learn a thing or two about Linux. So any hints on how to get started would be highly appreciated :bowing_man:

Start here:

But don't post anything: try to analyse all the log files yourself...

:innocent:

Thank you @Fabby! I've experienced the problem twice after a reboots today so I took the occasion looking at some of these logs. This caught my eye:

[ 13.477256] psmouse serio1: synaptics: Your touchpad (PNP: LEN0099 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.

Although, it seems unrelated but led me to this interesting thread.

More interestingly:

$ pacman -Q {synaptics,libinput}
xf86-input-synaptics
libinput

I've also got both a

  • /usr/share/X11/xorg.conf.d/70-synaptics.conf
  • /usr/share/X11/xorg.conf.d/40-libinput.conf

This Arch wiki article is talking about having both drivers a bit.

$ cat /var/log/Xorg.0.log | egrep -i "(synaptics|libinput).*touchpad"
...
[ 21.227] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "libinput touchpad catchall"
> [ 21.231] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
...
[ 3841.371] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 3871.693] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 3934.641] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found

Not sure what is triggering the last three lines but it shows 70-synaptics.conf is taking precedence as one would expect.

Question: Does this mean synaptics drivers are being used the whole time, or could it be that libinput is taking over at some point? Or is this impossible if it doesn't show up in the Xorg log?

I am still not much closer to figuring out why the touchpad sometimes gets disabled. Even worse, I noticed that my solution of fixing the issue seems to have a side-effect of some other touchpad options being affected, basically typing doesn't disable the touchpad anymore which can drive one crazy.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by