system becomes unusable some time after resume from suspend

Hi, I'm using a Dell XPS 15 9570 with Manjaro 20.0 and kernel 5.6.8-1. But I've experienced the same problem with kernels 4.19.x and 5.4.x and Manjaro 19.x.

Some time after resume from suspend (both s2idle and deep variants) the system becomes practically unusable. I usually notice it first because a web page fails to load. I look into Gnome's wifi or wired connection settings and am told that NetworkManager isn't running - but ps -ef | grep Network shows it is.

At this point I usually can't do much else, because trying to run sudo hangs. For example sudo -i never completes, or sudo systemctl restart NetworkManager or trying to send a signal to NetworkManager with sudo kill -HUP ... etc.

I can't produce many useful diagnostics at that point because inxi, mhwd and others also never complete.

So I save my files (that works) and try to log out (usually doesn't work) and then tell the system to reboot. It goes through many minutes of "a stop job is running ..." usually for tlp, PackageKit, user 1000 (me) and sometimes others. I press Ctrl-Alt-Del more than 7 times in 2 seconds, and then get many minutes of occasional messages of shutdown waiting for processes. At that point I hold down the power button for long enough that the system switches off. I've waited before for everything to finish and after 15 minutes it was still working on it, so I've stopped waiting.

I'm not running a VPN. (E.g. Internet connection doesn't work after suspend.)

Anyway I'll post the info that I've seen requested in other threads on resume problems after suspend. Any suggestions are most welcome.

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status":

  Model: "Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter"
  Driver: "ath10k_pci"
  Device File: wlp59s0
  Link detected: yes
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Model: "Qualcomm Atheros Bluetooth Device"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Model: "Realtek RTL8153 Gigabit Ethernet Adapter"
  Driver: "r8152"
  Device File: ens20u1u2
  Link detected: yes
    Driver Status: r8152 is active
    Driver Activation Cmd: "modprobe r8152"

inxi -Fxxz:

System:
  Host: ararat Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.2 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0D0T05 v: A00 serial: <filter> UEFI: Dell v: 1.15.0 
  date: 12/25/2019 
Battery:
  ID-1: BAT0 charge: 75.1 Wh condition: 75.1/97.0 Wh (77%) volts: 12.6/11.4 
  model: LGC-LGC8.33 DELL 5XJ288B serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 
  serial: <filter> charge: 55% (should be ignored) status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1c8c 
  Display: x11 server: X.Org 1.20.8 driver: intel compositor: gnome-shell 
  resolution: 3840x2160~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.6 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.6.8-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: efa0 
  bus ID: 3b:00.0 chip ID: 168c:003e 
  IF: wlp59s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:3 
  chip ID: 0cf3:e301 
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 4-1.2:3 chip ID: 0bda:8153 
  IF: ens20u1u2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.84 TiB used: 731.36 GiB (38.8%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 1024GB 
  size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  ID-2: /dev/sda type: USB vendor: Western Digital model: WD10JMVW-11AJGS3 
  size: 931.48 GiB serial: <filter> 
Partition:
  ID-1: / size: 937.40 GiB used: 365.20 GiB (39.0%) fs: ext4 dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 69.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2495 fan-2: 2469 
Info:
  Processes: 355 Uptime: 16m Memory: 31.02 GiB used: 5.75 GiB (18.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 clang: 10.0.0 Shell: fish 
  v: 3.1.1 running in: gnome-terminal inxi: 3.0.37 

mhwd -li:

Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI

Warning: No installed USB configs!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:

    How to reboot / turn off your frozen computer: REISUB/REISUO

  2. Try with the proprietary nVidia driver only:

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd --remove pci video-hybrid-intel-nvidia-430xx-bumblebee 
    sudo mhwd --install pci video-nvidia-440xx 
    sudo reboot
    
  • Log on etc and manually invoke suspend:

    sudo systemctl suspend
    
  • Better?

  1. If that doesn't work, please turn off:
    • Bluetooth
    • WiFi
  • Hook up an Ethernet cable and see if it still happens
    • If yes: Sorry, I'm all out of ideas!
    • If no:
      • Reboot
      • Note and provide the exact time
      • sudo systemctl suspend
      • wake up
      • dmesg --ctime from the exact time you suspended
      • Remove Ethernet cable
      • Turn on WiFi
      • sudo systemctl suspend
      • wake up
      • dmesg --ctime from the exact time you suspended the second time

:innocent:

1 Like

That's brilliant, thank you! I've been using Linux for 4 years and have never come across the REISUB/REISUO tip. The SysRq combo is Alt-PrtScr on a Dell XPS 15 9570, and it seems like Alt-PrtScr-B, the final step to reboot, doesn't do anything, but Alt-PrtScr-O does shut down the machine, which is good enough.

I tried this, but rebooted to a black screen with only a cursor in the upper left corner. I could open a TTY so undid the changes.

I see plenty of posts online about proprietary nvidia drivers and black screens so will have to follow up on them when I have a bit more time - whether or not this solves the problem with resume from suspend.

This is likely caused by your wifi (rarely bluetooth).

That Atheros adapter is very problematic. Adding kernel boot parameters sometimes helps fix that adapters issues.

Try this:

Add ipv6 disable & pcie_aspm=off via grub boot parameters.

The following command will add the GRUB kernel boot parameters to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test for improvement.

*sed magic courtesy of @dalto



If that does not solve your problem then I would suggest you search the terms "mask tlp" and temporarily disable tlp via masking it. Tlp usually required on a laptop, so it would be best to determine which setting needs to be modified in tlp's configuration file. Do your own research on this as I do not use tlp. Generally it will be the power saving settings for your adapter in tlp's configuration file that requires modification.



The final option you are left with is to write your own suspend service to disable your network components prior to suspending and reload them upon resume.

See my systemd thread for many working suspend service examples:

This service with modification may work for you.

2 Likes

Thank you @tbg, the following advice

seems to have solved the problem in my case. After several days of running with these boot parameters I haven't had a single problem with resumes from suspend.

I've tried disabling ipv6 before from network manager and it hasn't made a difference. I assume pcie_aspm=off is the real solution in my case, unless the two interact somehow. Anyway doesn't matter - I'm not using ipv6.

I've tried looking online to see what the drawbacks of pcie_aspm=off might be - seems like slightly higher power draw is about it.

Thanks again to both @tbg and @Fabby.

2 Likes

Awesome, so glad that helped, and you're very welcome.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by