System boots but freezes on login (no keyboard, no mouse)

Hey gang,
I am posting this from Windows 10 which I haven't used in weeks.
As of today, I can't log in to Manjaro KDE.

I have use of the keyboard keys to select the grub boot entry but as soon as the login screen shows up, both, mouse and keyboard become unresponsive. I tried unplugging the keyboard to see if it would auto detect but it didn't.

I didn't install anything new lately and didn't change any settings in the last few days. I did notice that since the last upgrade, things have become a little shaky but still, this shouldn't happen.

Has anyone experienced this and if yes, how did you fix it? - Thanks - v

I can log into Manjaro "if I boot Win10 first" and then reboot. :frowning:

Update 2!
And as of today, I can't. Even booting Windows first will not let me log in.
Everything comes up normally but nether keyboard nor mouse function.
Time to reinstall?

Perhaps but it might be worth trying to find/fix the problem. :smiley:

Try first to boot to TTY (see How to provide good information in your posts, specifically the section 'Booting to Command Prompt from Grub').

Once logged in try startx if this succeeds in initiating the graphic environment correctly then the problem is likely to be the DM (probably sddm but it could also be lightdm or gdm).

Whether that succeeds or not it will be useful to follow procedure in the link above for finding out some information about the problem. (Possibly sudo journalctl -b-1 -p3 is a good place to start - returns journal messages of 'error' or above from previous boot, but dmesg and Xorg logs might also help.) Definitely provide inxi -Fxxxz if you need more help. :smile:

Hi grinner,
I tried that and other things but without keyboard input nothing matters.

Earlier, I let manjaro boot and then I used another computer for a while, maybe 10 minutes or so.
By then, both mouse and keyboard functioned again.
Maybe itโ€™s related to my theme which messed up grub somewhat. Iโ€™ll look into it more when I take a break.
Thanks for your suggestions.

The point of booting into TTY is to avoid the graphical environment (e.g. login screen provided by the display manager - DM).

If there is no keyboard input in a TTY after booting in from the command prompt then try chroot from a live usb.

1 Like

I am glad that I didn't reinstall because it turned out that the culprit is the printer or the USB stick.
As soon as I unplugged the printer USB cable, and removed the USB stick, I was able to enter the password and log in normally.
Who knew. :slight_smile:


I would suggest you try to narow down which one, if any, is the problem, since you said they work on Windows.
It maybe a bug in some updated package, or a starting HW failure, or something else..

1 Like

Hey petsam,
you are right. It would be best to plug in the printer once more and try booting but for now, I am happy to have everything back to normal.
I hunch is that the USB stick is causing the delay. I had issues with that particular USB stick before and decided not to use it anymore as it sometimes won't mount.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by