System can't start after update 06.07


Today I have installed update 06.07 (I guess that) and after that I can't run my manjaro. When computer starts it only shows me GRUB_ on black screen and nothing else. My manjaro XFCE is installed on separate disk, everything was fine until this update. What can I do?


PS. (I could not post it under update thread)

No solution found here?

Do you mean the Grub prompt, or after grub selection to black screen with a cursor at top-left?

Yea, GRUB with a cursor at top-left part of screen but I can't even see list of installed systems. Turn on computer-> BIOS things (computer specification and so on)->GRUB in top-left corner

Like this?


If yes, try this to get into your installation.

More like:


I tried this, it boot up my system but when I turn off my computer and turn on, problem appear again.

IIRC that topic advices to re-install grub and investigate - repair the problem (grub failure). Have you done any repair action?

When I try to run sudo install-grub /dev/sda:

Installation for the i386-pc platform.
grub-install: note: this GPT partition label does not have a boot partition BIOS; deposition will not result.
grub-install: note: Embedding is not possible. The GRUB program can be installed with these settings only on the block list. And, blocking is UNCERTAINTY, there is not recommended ..
grub-install: error: no use is continued using the block list.

sudo update grub works fine but do not take any effect

Also, when I booted successfully my manjaro from installation media there was a error (occurred for a second) like "grubenv not found"

ooo... is this manjaro32 ?

What do you mean? 32bits? No, it is 64bits version from the official website

EDIT; Tried to run grub-install on /dev/sda4 where boot partition exists but still got these errors

Boot to your Manjaro installation (like you did) and at a terminal run these and return the outputs here in proper code tags </> :

inxi -SMCDPIxxxz
pacman -Qs grub
fdisk -l | grep Disk

Also confess: how many OSes do you have on this PC?

You are trying to install a bios-legacy grub in a gpt partitioned device.
You need to show "sudo parted -l"

inxi -SMCDPIxxxz

  Host: seba_linux Kernel: 4.14.54-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Console: tty 0 dm: lightdm 1.26.0 
  Distro: Manjaro Linux 17.1.11 Hakoila 
  Type: Desktop Mobo: MSI model: H61M-P31/W8 (MS-7788) v: 1.0 serial: N/A 
  BIOS: American Megatrends v: 3.6 date: 09/29/2013 
  Topology: Dual Core model: Intel Core i3-2120 bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26410 
  Speed: 1600 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1600 2: 1600 
  3: 1600 4: 1600 
  HDD Total Size: 232.88 GiB used: 18.10 GiB (7.8%) 
  ID-1: /dev/sda vendor: Samsung model: SP2504C size: 232.88 GiB speed: 3.0 Gb/s 
  serial: <filter> rev: 0-50 scheme: GPT 
  ID-1: / size: 47.81 GiB used: 11.01 GiB (23.0%) fs: ext4 dev: /dev/sda1 
  ID-2: /boot size: 399.9 MiB used: 51.8 MiB (12.9%) fs: vfat dev: /dev/sda4 
  ID-3: /home size: 164.40 GiB used: 7.03 GiB (4.3%) fs: ext4 dev: /dev/sda2 
  ID-4: swap-1 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
  Processes: 164 Uptime: 4m Memory: 7.75 GiB used: 1.23 GiB (15.9%) 
  Init: systemd v: 239 Compilers: gcc: 8.1.1 clang: 6.0.0 Shell: bash (sudo) 
  v: 4.4.23 running in: xfce4-terminal inxi: 3.0.12

pacman -Qs grub

local/grub 2.03.0-7.1
    GNU GRand Unified Bootloader (2)

fdisk -l | grep Disk - no output


sda      8:0    0 232,9G  0 disk 
├─sda1   8:1    0  48,8G  0 part /
├─sda2   8:2    0   168G  0 part /home
├─sda3   8:3    0  15,6G  0 part [SWAP]
└─sda4   8:4    0 400,7M  0 part /boot
sr0     11:0    1   1,7G  0 rom  

sudo parted -l

Model: ATA SAMSUNG SP2504C (scsi)
Disk / dev / sda: 250 GB
Sector size (logical / physical): 512B / 512B
Partition table: gpt
Disk flags:

Number Beginning End Size System files Name Flag
1 1049 kB 52.4 GB 52.4 GB ext4
2 52.4 GB 233 GB 180 GB ext4
3 233 GB 250 GB 16.8GB linux-swap (v1)
4 250 GB 250 GB 420 MB fat32 msftdata

I have 2 systems on 2 separate disks 250GB - Manjaro, 750GB - Windows 7 (currently pin off due to this problem)

Show all disks.

We need to see the $esp partition for windows.

And these..since you're here (from Manjaro sda2)

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

sudo parted - l

Model: ATA WDC WD7500AZEX-0 (scsi)
Disk / dev / sda: 750 GB
Size of the sector (logical / physical): 512B / 4096B
Partition table: msdos
Disk flags:

Start End Size Type File system Flag
1 1049kB 545GB 545 GB main ntfs
2 545 GB 645 GB 100 GB extended
3 645GB 645 GB 105MB primary ntfs rechargeable
4,645 GB 750 GB 105 GB of main NTFS files

Model: ATA SAMSUNG SP2504C (scsi)
Disk / dev / sdb: 250GB
Sector size (logical / physical): 512B / 512B
Partition table: gpt
Disk flags:

Number Beginning End Size System files Name Flag
1 1049 kB 52.4 GB 52.4 GB ext4
2 52.4 GB 233 GB 180 GB ext4
3 233 GB 250 GB 16.8GB linux-swap (v1)
4 250 GB 250 GB 420 MB fat32 msftdata

efibootmgr -v

EFI variables are not supported on this system.

sudo blkid

/dev/sda1: UUID="BC7AFCF77AFCAEF0" TYPE="ntfs" PARTUUID="5e20ff7a-01"
/dev/sda3: LABEL="System Reserved" UUID="94087CC8087CAABE" TYPE="ntfs" PARTUUID="5e20ff7a-03"
/dev/sda4: UUID="80D48D84D48D7CE2" TYPE="ntfs" PARTUUID="5e20ff7a-04"
/dev/sdb1: UUID="f66c8a8b-b450-46a6-b1b4-99f2660091c6" TYPE="ext4" PARTUUID="84232cc9-512c-4284-b859-e1f838e8c375"
/dev/sdb2: UUID="a18f796e-f97e-49ab-9f28-c2c1c2765476" TYPE="ext4" PARTUUID="afc313c0-d9bc-4772-bd81-bc7852f9b492"
/dev/sdb3: UUID="c055da64-5b09-4467-85fc-3d3ac903b4e6" TYPE="swap" PARTUUID="ecfcfe63-9790-487d-83c1-45fd4c7268e7"
/dev/sdb4: UUID="9F3E-F879" TYPE="vfat" PARTUUID="c8ba6391-ce52-4dfe-8a7f-31293f1873bd"
/dev/sr0: UUID="2018-03-17-14-37-03-00" LABEL="MJRO1717" TYPE="iso9660" PTTYPE="dos"

findmnt -s

TARGET SOURCE                                    FSTYPE OPTIONS
/      UUID=f66c8a8b-b450-46a6-b1b4-99f2660091c6 ext4   defaults,noatime
/home  UUID=a18f796e-f97e-49ab-9f28-c2c1c2765476 ext4   defaults,noatime
swap   UUID=c055da64-5b09-4467-85fc-3d3ac903b4e6 swap   defaults,noatime
/boot  UUID=9F3E-F879                            vfat   defaults,noatime

findmnt /boot/efi - no output

Lucky for you that you provide the whole 'parted -l' (lucky because we would have advised you wrongly by assuming windows is uefi)
Your windows is bios-legacy and widnows disk is msdos, not gpt.

Your Manjaro is also bios-legacy but you are suing a gpt disk for it.

Suggest you reinstall Manjaro.
But first make your manjaro disk msdos, not gpt.

That will wipe out evrything in that disk.
Then reinstall manjaro.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by