System crashes on reboot or poweroff

Hi
I had removed exactly as per your instructions but nevertheless i wiped everything and fresh installed everything.

here are the
cat /etc/modprobe.d/*.conf

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
options bbswitch load_state=0 unload_state=0
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
blacklist nouveau
blacklist nvidia
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist ttm
blacklist drm_kms_helper
blacklist drm
blacklist pcspkr
blacklist r8169

cat /etc/modules-load.d/*.conf

# List of modules to load at boot

systemctl status bumblebeed

bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2019-02-12 22:55:20 IST; 8min ago
 Main PID: 30660 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 13.6M
   CGroup: /system.slice/bumblebeed.service
           └─30660 /usr/bin/bumblebeed --use-syslog

Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) intel(0): Failed to claim DRM device.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) Screen(s) found, but none have a usable configuration.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE)
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) no screens found(EE)
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE)
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE)
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) Server terminated with error (1). Closing log file.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: X did not start properly
~

No errors during reinstallation
Still facing the issue

bumblebeed status is different now and has some errors we can work with, i couldnt find anything relevant related to the previous errors in bumblebeed status, looking....

can you post output of
optirun glxspheres64
primusrun glxspheres64
probably just error but post anyway.

pacman -Qs bbswitch

optirun glxspheres64

[  178.218829] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Screen 1 deleted because of no matching config section.

[  178.218880] [ERROR]Aborting because fallback start is disabled.

primusrun glxspheres64

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) Screen 1 deleted because of no matching config section.

pacman -Qs bbswitch

local/linux316-bbswitch 0.8-47 (linux316-extramodules)
    kernel module allowing to switch dedicated graphics card on Optimus laptops
local/linux419-bbswitch 0.8-16 (linux419-extramodules)
    kernel module allowing to switch dedicated graphics card on Optimus laptops
local/linux420-bbswitch 0.8-6 (linux420-extramodules)
    kernel module allowing to switch dedicated graphics card on Optimus laptops

Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) intel(0): Failed to claim DRM device.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) Screen(s) found, but none have a usable configuration.
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE)
Feb 12 22:56:31 Vedant-pc bumblebeed[30660]: [XORG] (EE) no screens found(EE)

im thinking you need a screen section specified in one of the conf files, i just dont know how this is done properly with bumblebee, does it go into a bumblebee .conf? or just added to /etc/X11/xorg.conf.d ? @bogdancovaciu any ideas, if your not busy?

@ivedantlodha post current outputs of
cat /etc/X11/mhwd.d/*
cat /etc/X11/xorg.conf.d/*

1 Like

cat /etc/X11/mhwd.d/*

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
	Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

cat /etc/X11/xorg.conf.d/*


# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "in"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "eng"
EndSection
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
EndSection
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
	Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 

I tried to follow what was going on here, but ... it crashed before, or only after trying to install the hybrid drivers for GPU ?
I didn't see the inxi -Fxxxz and that helps me look around for that particular laptop model.
My experience with optimus laptops is limited to only reading.
What is the goal here, to have one of this working?

AFAIK any of the 3 creates the default and working configs. But, @ivedantlodha - chose only one, as described in the links and also look for some boot parameters for your laptop.

2 Likes
System:    Host: Vedant-pc Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16 info: i3bar 
           dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx v: Type1ProductConfigId serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8478 v: 70.39 serial: <filter> UEFI: Insyde v: F.11 date: 08/13/2018 
Battery:   ID-1: BAT1 charge: 32.0 Wh condition: 50.2/52.8 Wh (95%) volts: 11.4/11.6 model: Hewlett-Packard PABAS0241231 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36872 
           Speed: 900 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 1529 2: 1321 3: 992 4: 1037 5: 914 6: 923 7: 1188 
           8: 1191 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard driver: nvidia v: 415.27 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: nvidia tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.3.2 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k4.20.7-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168 
           v: 8.045.08-NAPI port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 31.51 GiB (3.4%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3T0 scheme: GPT 
Partition: ID-1: / size: 68.40 GiB used: 15.54 GiB (22.7%) fs: ext4 dev: /dev/sda9 
           ID-2: /home size: 432.75 GiB used: 15.92 GiB (3.7%) fs: ext4 dev: /dev/sda10 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 53.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 215 Uptime: 31m Memory: 7.68 GiB used: 1.23 GiB (16.0%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: zsh v: 5.6.2 running in: urxvtd inxi: 3.0.30 

im trying to get bumblebee working.

heres my /etc/default/grub

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi=“Windows 2009” acpi_backlight=vendor resume=UUID=6b4e4449-c0a6-44d0-8188-f5df22ea6c83"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

i had him go through and remove any existing optimus-manager leftovers, including any/all gpu related configs/blacklists and do a clean install of bumblebee, he can get to a graphical desktop, the problem lies with the errors being thrown by any optirun/primusrun commands so no gpu switching.

@ivedantlodha you are currently able to boot into a graphical environment right? i assumed you could because you were able to previously.

Yes I'm able to boot into my graphical environment.

check if your account is member of bumblebee

groups

If not, add your user to bumblebee.

Else, try when booting, on grub menu option, edit to remove one or more parameters (this is just guessing, if no other option).

1 Like

Found something that looked interesting. It has the GTX1060 not as the op GTX1050, but ...


as described, the only boot parameter used was acpi_osi=
Also i'm not sure if the boot parameter acpi_backlight=vendor is ok ...
Looking trough this

but i would not use it ... as @AgentS also mentioned.

2 Likes

One more (guessing) check for kernel params is

cat /etc/sysctl.d/*.conf | grep -v ^#
1 Like

the backlight parameter could probably go but the acpi_osi ones were the only way of getting his laptop to boot without ending at a black screen or not get hung up. i guess OP could try removing them and possibly booting to a TTY using 3 as a parameter. and then login and manually startx or sddm ?

1 Like

Tried removing acpi_osi. Still no good.
Also I've been facing an issue where my screen randomly turns of while my machine is still running. Then I have to restart the laptop using power button. This issue has started after I reinstalled the graphic drivers as @dglt had asked

can you temporarily disable tlp, reboot and see if the monitor issue continues happening, also test optirun/primus after
sudo systemctl disable tlp
reboot

Both the problems persist.

possibly add a screen/monitor section to one of the .conf files ? i dont know how bumblebee works and where the configurations go but you could compare yours to others that have been posted previously ?

im not sure if iasked this already, but did you check to make sure the correct bbswitch for your kernel is installed? IIRC, this is how the nvidia gpu is switched on/off when using optirun/primusrun so please check output of:
pacman -Qs bbswitch
and if the correct bbswitch is not installed, install it. also maybe try a different kernel and see if it changes anything?

if you've given up on bumblebee, i have an alternative to using bumblebee/optimus-manager i would be happy to walk you through.
setup is simple and basically how it works is:

sudo set-nvidia.sh
(this sets up/sets nvidia prime to be used by default)
sudo set-intel.sh
(this sets intel only mode as default and safely disables/powers down the nvidia gpu at boot)

let me know your interested, i wrote this up yesterday and its working perfectly for me so i would like others to try it out. right now its designed to work with LightDM so your the perfect test case ATM. heres the github page i made yesterday, detailed installation instructions are also on the git page

Sure, Thanks a lot for all the help. Ill try a bit and if not successful, ill give your method a try

Thank you

Is this ideal for laptops, with power consumption in consideration? I rarely use GPU and battery life is a priority for me

yes, when in intel only mode (set-intel.sh) your system will then boot into a purely intel only setup and the nvidia is powered down and no longer even visible, drawing zero power. this setup remains the default setup unless you run set-nvidia.sh which would then make the default an nvidia prime setup using both intel/nvidia (what i use mostly).

when each is run, the configuration for intel only is removed and replaced with nvidia prime configuration. same goes for when you switch to intel. so this actually works very well for someone like you who would rather use intel only 90% of the time and occasionally use nvidia/intel prime every once in a while.

if you post me the following info, i will make the scripts/configs custom for your system and all you would need to do is remove bumblebee, install video-nvidia, git clone , copy files to right directories and run the script and you'll be good to go.

please do this:
sudo pacman -S xf86-video-intel acpi_call-dkms git
sudo modprobe acpi_call

post output of:
lspci | grep -E "VGA|3D"
sudo /usr/share/acpi_call/examples/turn_off_gpu.sh
cat /etc/lightdm/lightdm.conf | grep display-setup

it will only take me a minute or two after you post that info to make changes and post changes to git repo. then you can git clone it.

Forum kindly sponsored by