System fonts on Snap applications

Hi there, I'm sure this question has come up before but I've been searching and cannot find the solution.

I have a few Snap packages installed but I have issues when I try to use open or upload something and the system dialog is opened. It seems that the Snaps cannot find fonts. I'm using Gnome and Xorg (I switched from Wayland because of I need to share my desktop a lot).

Here's a screenshot:
Screenshot from 2020-04-07 22-03-13

Here is the list of Snaps I have installed:

snap list 
Name               Version                     Rev   Tracking       Publisher   Notes
bitwarden          1.17.2                      24    latest/stable  bitwarden✓  -
core               16-2.44.1                   8935  latest/stable  canonical✓  core
core18             20200311                    1705  latest/stable  canonical✓  base
gnome-3-28-1804    3.28.0-16-g27c9498.27c9498  116   latest/stable  canonical✓  -
gtk-common-themes  0.1-29-g45e78c5             1474  latest/stable  canonical✓  -
slack              4.4.0                       22    latest/stable  slack✓      classic
spotify            1.1.26.501.gbe11e53b-15     41    latest/stable  spotify✓    -
teams-for-linux    1.0.0                       79    latest/stable  alarconj    -

Here's the details of my installation:


 ██████████████████  ████████     mick@laptop
 ██████████████████  ████████     OS: Manjaro 19.0.2 Kyria
 ██████████████████  ████████     Kernel: x86_64 Linux 5.4.28-1-MANJARO
 ██████████████████  ████████     Uptime: 2d 3h 23m
 ████████            ████████     Packages: 1317
 ████████  ████████  ████████     Shell: bash 5.0.16
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: GNOME 3.36.1
 ████████  ████████  ████████     WM: Mutter
 ████████  ████████  ████████     WM Theme: Matcha-dark-azul
 ████████  ████████  ████████     GTK Theme: Matcha-dark-azul [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Papirus-Dark
 ████████  ████████  ████████     Font: Noto Sans 11
 ████████  ████████  ████████     Disk: 67G / 234G (30%)
                                  CPU: Intel Core i5-7200U @ 4x 3.1GHz [52.0°C]
                                  GPU: Intel Corporation HD Graphics 620 (rev 02)
                                  RAM: 3550MiB / 7873MiB

Here are my system details, in case they are needed:

System:    Host: laptop Kernel: 5.4.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Gnome 3.36.0 
           wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Timi product: TM1604 v: XMAKB3M0P0304 serial: <filter> 
           Mobo: Timi model: TM1604 v: XMAKB3M0P0304 serial: <filter> UEFI: Insyde v: XMAKB3M0P0304 
           date: 06/29/2017 
Battery:   ID-1: BAT0 charge: 28.3 Wh condition: 28.3/39.0 Wh (72%) volts: 8.6/7.6 model: LGC R13B02W type: Li-poly 
           serial: <filter> status: Not charging 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber Lake rev: 9 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607 
           Speed: 1403 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1601 4: 1600 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Xiaomi driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d12 
           Display: x11 server: X.Org 1.20.8 driver: intel compositor: gnome-shell resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.6 Mesa 19.3.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Xiaomi driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-3.2:13 
           chip ID: 046d:0825 serial: <filter> 
           Sound Server: ALSA v: k5.4.28-1-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 4040 bus ID: 02:00.0 
           chip ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 471.36 GiB used: 65.00 GiB (13.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-00000 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: CXB7401Q scheme: GPT 
           ID-2: /dev/sda vendor: Crucial model: CT250MX500SSD4 size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 023 scheme: GPT 
Partition: ID-1: / size: 227.94 GiB used: 65.00 GiB (28.5%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: 35.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 231 Uptime: 2d 3h 19m Memory: 7.69 GiB used: 2.73 GiB (35.5%) Init: systemd v: 244 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.16 running in: gnome-terminal inxi: 3.0.37 

Any help or pointers greatly appreciated!

Edit: It might be related to the fact that these are mostly Electron apps...but I cannot confirm.

I've to double check again, as this issue is known and therefore we use older fonts. I hope not that someone removed that overlay based on this fact.

This is common .. you must either use

fc-cache -r

or manually delete fontconfig cache

sudo rm -f /var/cache/fontconfig/*

And possibly home cache too

rm ~/.cache/fontconfig/*

Normally fontconfig 2:2.13.1+12+g5f5ec56-1 should be installed and all is fine ...

Let me double-check that. Maybe Canonical changed something ...

It was certainly that way for me on unstable when testing for someone else yesterday.

ya, something changed. have to see why. removing the cache worked, however it is not great. have to see if a fresh installation has the same issue.

Thanks guys for the input.

I tried deleting the fontconfig cache but it didn't seem to help. I just restarted the SNAP. Do I need to log out and log back in again or anything?

In my end I had to do this:

sudo rm -f /var/cache/fontconfig/*

Thanks gentlemen,

I can confirm that this solved my issue.
Screenshot from 2020-04-09 08-08-43

I've tried all of this, but none of them works.
Can you help me solve this problem?

With the release of snapd 2.45.1 you might only need to delete ~/.cache/fontconfig/* to get the fonts back ...

Unfortunately for me none of these work. I'm running snapd 2.45.1. Any ideas how to solve?

@linux4me I assume you updated fontconfig packages. Try this:

sudo rm -f /var/cache/fontconfig/*
rm -f ~/.cache/fontconfig/*

@philm I'm using the fontconfig from the official repository. I reinstalled again and then removed the files you indicated. Unfortunately still got the issue.

I only tested with snap-store snap so far. On my end it works. You can always post about it in the upstream forum:

Also remember that the fix of snapd 2.45.1-1 is currently only in our unstable branch.

@philm It was carnet that I was trying to install. The AUR package wouldn't build because of an AppImage error so I thought I'd try the snap version but that had issues so now I've just downloaded the AppImage from their github and that's running fine. I'll try the snap again when the latest snapd hits stable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by