System froze, now it won't boot

As the title says, I was just using my system as I normaly would (surfing the web and stuff), and then it suddenly compeltely froze. Not sure if it was the right thing to do, but after waiting a while I turned the system off by holding down the power-button. Now when I try to boot, I get this:

[FAILED] Failed to start Load Kernel Modules.
See "systemctl status systemd-modules-load.service" for details

I'm not sure where to locate this file, and I'm pretty certain I won't know what to do with the information contained within it. Also, I'd love some advice for what to do in future situations where my PC just completely freezes. I really like Linux so far, and I'd love to stick around :grinning:

EDIT: Ok, so it seems that after restarting my computer after the freeze, it tried to boot into the 5.0 kernel for some reason. I do not have that installed, nor have I installed any other kernel at any point. So that was weird, but I fixed it by just booting through the 4.19 kernel.

Worth reading:

2 Likes

This might be the solution to my issue. But I can't log in to my user, because for some reason my keyboard is not set to nordic and my passord contains nordic characters... Any way to get nordic keyboard?

Edit: I tried following using the alt+numpad ASCII key combos found here, but looks like the console only registers stuff up to about character 80, because anything above only becomes a square like this: ■

When your computer freezes not much you can do but reboot. You might want to feel around see if it's hot, but most often software caused the problem.

Yeah I think it must be software related. But I just find it weird, because I wasn't doing anything else than browsing. But computers are quite complex, there was probably something going on under the hood that crashed somehow.

I would try three things.

  1. Boot into a manjaro liveusb, and run FSCK on all your drives. Filesystem damage can corrupt files, and filesystem damage should be repaired ASAP

  2. Try booting with another kernel if you have installed more than one

  3. Try chrooting into your installation, then running an update, and/or reinstalling your kernel. Tutorial: How to magically fix most computers that will not boot after a manjaro update!.

Reinstall kernel:
sudo mhwd-kernel -r linux419
sudo mhwd-kernel -i linux419

1 Like

Hey man, you helped me out! I noticed that for some reason it was now trying to auto-boot with the 5.0 kernel, which I do not have installed. I used the GUI during boot to force it to boot into 4.19 kernel, and my system instantly booted.

A question though: Should I still boot into a liveusb and run FSCK just in case? I've never run that command before.

2 Likes

No. It is not necessary, because it runs on your boot drive automatically before your system starts up. FSCK is a utility that checks a filesystem for issues, then attempts to fix them. Make sure to update grub now that your system does boot, and make sure “5.0” does not show up.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by