System running slow

could you made an another htop screen without any apps ?
and with F6 sort by cpu for the screenshot

there is something very strange
your load average is between 3 to 4 ,
mine with more cpu is between 0,3 to 0,4 for 10 - 15%

did you try another kernel ( like 4.8 ? )

no, i have never tried to install a different kernel.
shall i?

you can try ,

sudo mhwd-kernel -i linux48

you will have 2 kernels for boot , by default higher always selected,
you can change on star with grub

check if it better ( see also the rest sudo journalctl -b 0 )

as you recomended to try some another kernel,i tried the fallback kernel instead.
Till now running it i didn't face any noticable problem.
running the command: journalctl -b 0 , i saw there were no red logs.
but trying: systemd-analyze critical-chain there were some red lines.

di you have tlp installed ?
if not plz install

sudo pacman -S tlp

wiki : https://wiki.archlinux.org/index.php/TLP

if you keep have trouble , we may have to trace with tlp-stat
see : http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html#commands

i have tlp installed

i have seen one report with your cpu & KDE
did you need a light distribution ?
you should in this case try with Xfce

some specialists in @KDE should have a look with all process launched
on the last screenshot you have a average of 3 threads running

will my problem be solved if i install another kernel??
will you please tell me how to install a new kernel and replace it with the present kernel?

Menu -> Settings -> Manjaro Settings Manager

Inside you will see: Kernel, click on it and you will see kernels available and next to it button for Install. See screen shot bellow.

How to select it? At boot menu after computer restart, I can't recall, 'advanced options' or 'more options' move cursor to it with arrows keys and press enter and you will see all available kernels listed.

I don't know, it may. It is always a good idea to have installed at least one more kernel as a backup. If after upgrade/drivers change.... somethings breaks, sometimes just switching kernels solves the problem.

Create live USB or DVD with Manjaro Xfce and see if it behaves better. Maybe just using Xfce may solve your problem. Maybe not but it is worth checking out, unless you don't want to switch from KDE

1 Like

I tried to install manjaro deepin,
It installed well but at the boot time I'm getting this error:
[FAILED] Failed to start Create Volatile Files and directories
There is no cursor on the screen to type anything😰
How to fix this now?

To get cursor usually helps Ctrl+Alt+F2 which is tty console. Here I will copy-paste from another post :wink:

.get to tty by simultaneously pressing Ctrl+Alt+F2 you will find yourself in front of blank, black screen, where you enter your user name and password. To return back you press Ctrl+Alt+F7. You may sometimes need to do this, if your graphic card driver doesn't loads startx correctly. 'startx' is this graphic environment where you see icones, mouse pointer, desktop...

One more thing, you really should try Xfce. KDE and Xfce are official versions. Since you have problems with KDE, the most normal step would be to move down to simpler but still official version which is Xfce.

P.s.
this is right now unrelated but anyway...

I don't remember if you were already doing chroot but just in case you didn't, check this post where I put together few links and few general tips, they may become handy down the road:

Alt+ctrl+F2 or F3 or any of them are not working

In this case, your computer stops before most gets initialized, loaded....
Ctrl+Alt+F2 is useful if something goes wrong with graphic card/driver since it apears like that system is locked up, but with switching to tty you gain full control over system without GUI.

Well, in your example error is somewhere before and system is not properly loaded up yet. Proper set of actions at this point would be to chroot into your system by using live USB/DVD and examine the logs. I'm beginner and I could only do the chroot part. I'm not good enough yet at logs and troubleshooting problems. Logs like:

sudo journalctl -b 0

And the other logs mentioned by @stephane. Why you need to chroot first? Because if you just load system up with live USB/DVD then you are not accessing system/log files on your system, by chrooting you actually gain access to your system from the outside.

Unfortunately, I don't have enough knowledge to help you. I can tell you what I would do if I would be in your shoes:

1 - I would start with Xfce, since it is official version and since you experienced slowness problems with KDE. Not any other version.

2 - if I would still experience any problems with Xfce, I would post new msg in: Technical Issues and Assistance forum:

https://archived.forum.manjaro.org/c/technical-issues-and-assistance

Where I would post description of the problem and I would post output from inxi -Fxzc0 so members would know what system you have. If Xfce will not boot all the way (it should, KDE did) you will probably need to do chroot, link to tutorial is in my previous post.

Make sure, before you boot from Xcfe USB/DVD to install it, make sure you check and verify with checksum that file was properly downloaded.

I'm sorry you are having a problems for so long now. You would probably get more help if you would post in Technical Issues and Assistance forum. And I'm sorry I can't be of any more help.

But let me post about your problem in that forum and invite some here to see if someone can help you from here on.

1 Like

@SAMXAVERIAN

Can you check if fan on your CPU is running? If it is not, your CPU would be slowing down to prevent overheating. Can you please head over to:

2 Likes

hello , there is an option in Calamarès
install on ONE partition ( without format ) , if /home is on another partition ,
samxaverian can re-install / ( only / ) , /home will not be changed

but , he had to check before ( with Gparted before install ) if the point for /home is ok.
after re install , all environment are reset.

report if necessary before

sudo fdisk -l
1 Like

@AlManja, @stephane, sorry guys for being late to inform but I changed to deepin. And so far it seems to be good. Thanks a lot guys for helping me out and really I learnt a lot from you two.

1 Like

necro-bumping

Forum kindly sponsored by