System startup shows loading text

Manjaro never used to do this before I updated my sytem.
Now on startup it shows the black screen with the text showing everything that is being loaded.
I didn't get any errors.
How can I stop Manjaro from showing what it's loading on startup?

And also is there anyway to make Manjaro start up faster?
Like the Windows 10 "fast startup" feature.

Editing your file /etc/default/grub and rebuild grub configuration

No - the system takes the time needed.

What you are referring to is hybrid sleep where the systems is partly in a swap file.

It is possible but as you are posting in the #newbies - you should be very cautious if modifying your system.

There are many of us who like that verbose start.... :wink:

Spelling Junkie corrected topic header. :smiley:

:sweat_smile: makeing spelling mistakes for the whole world to see

1 Like

BlockquoteEditing your file /etc/default/grub and rebuild grub configuration

How exactly should I do that?

Edit your default file

sudo nano /etc/default/grub

Locate the line starting with GRUB_CMDLINE_LINUX_DEFAULT and modify the line to read

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"

Then save the file F2YEnter and rebuild your grub config

sudo update-grub

I already have this in that line. How do I add your line to that?

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor"```

Uhh - type it - I guess - adding what is not already there - and don't remove anything :slight_smile:

Should it be separated by a comma?

Never mind.
Just look at a previous timeshift backup's grub file

Timeshift backups my data each day to a separate drive

:woman_facepalming: Is there any commas anywhere?

No there's no commas

Maybe you should omit them?

GRUB_DEFAULT="0"
GRUB_TIMEOUT="-1"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT="false"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK="y"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT="console"

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE="auto"

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX="keep"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

It still shows the text at boot.

I did do sudo update-grub
And also restarted

Although you already had quiet set, is there any change after modifying GRUB_CMDLINE_LINUX_DEFAULT?
As @manyroads said, I also like to have a verbose start. @linux-aarhus: are there other kernel parameters beside initcall_debug that increase the boot verbosity? Is the list of boot messages saved so one can inspect it after the system booted?

I used Kompare and compared the two /etc/default/grub files to each other. Used one from a backup that I knew didn't show any boot messages and my current grub file.

The only difference between the two was the GRUB_CMDLINE_LINUX_DEFAULT line.
I saved my current grub file before editing it and I used the saved version to compare that to a previous backup.

No there was no difference after editing GRUB_CMDLINE_LINUX_DEFAULT

Got it working with guide from arch linux.

https://wiki.archlinux.org/index.php/Silent_boot```
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by