System update notifier icon is black and broken

Same here, but now I don't see it anymore in the system tray.

The system update notifier icon is black and broken.
Any way how to fix this ?

I managed to make it white again by copying the Breeze-Dark tray icons to the default ones and replacing them, but the update icon still looks "broken" blurry, no idea how to make the old icon show up like the previous version in this version is like a shield.

Edit: I have installed Octopi for the time being also you can go first to your icon theme folder edit index.theme and set: FollowsColorScheme=true to FollowsColorScheme=false

Works most of the time.

Copy them where?
Mind you, but due to the way Plasma handles tray icons, all should be taken from /usr/share/plasma/desktoptheme/breath2/icons/
Are special icons, but now pamac is using the icons from /usr/share/icons/hicolor/scalable/status
and sometimes, due cache is mixing them up.

I forgot to mention /usr/share/plasma/desktoptheme/breath2/icons/.

But regarding icons in the tray being grey/black this does the trick :point_up:

That's a hacky way to do it, but whatever.
All the icons in /usr/share/plasma/desktoptheme/breath2/icons/ follow the new KDE Plasma standard and follow the color-scheme, have css styles applied, with the correct sizes.
I'll ask @guinux if there is something else to consider with the new pamac-tray-appindicator

For clarity (pun intended) blurred icons:

1pamac_tray

2pamac_tray

multiple pamac desktop files

pamac-desktop-files

On latte-dock sometimes looks like this:

software-manager-pamac-latte

Edited for little more clarification:
Looking at


i see no inconsistency with the icons for Breath2

image

image

image

I'm no programmer, so i don't know how the tray written in vala behaves in KDE Plasma. The icons follow the standard by KDE Plasma, and follow whatever color-scheme is used, but apparently are not used.

1 Like

My find about this is that if i Quit it from the tray icon, and start manually the pamac-tray-appindicator regardless that i do it trough terminal, or use the desktop file from /etc/xdg/autostart/pamac-tray-appindicator.desktop then the icon in tray will respect the KDE Plasma icon theme, behave as it used to behave.

image

image

3 Likes

I have a little different issue. My icon does not even show.

I'm using Plasma 5.19.3, Breath Dark theme on Wayland.

Running pamac-tray-appindicator from the terminal does nothing and shows no output, other than the regular "process is started" line.

pamac-tray-appindicator from the folder works for me. 'Til next system boot, of course.

It works! thanx :+1:

Okay, I spoke too soon ...

Kill it first from System Monitor. It depends also on the settings in Pamac

image

The thing is once rebooted the system, all is the same, blurred or not showing, is not a fix.

I removed the /etc/xdg/autostart/pamac-tray-appindicator.desktop and now i'm trying to see if a delayed start will help.

Nope, is not helping if is delayed. I'll try something else.

Seems this isn't limited to just Pamac tray icon. My GreenWithEnvy tray icon seems to be suffering from similar issues:
Screenshot_20200719_223759

Thanks. Killing it first and then starting it worked. I wonder how it is when I reboot. :stuck_out_tongue:

hahaha :stuck_out_tongue:

It's the same after reboot.

Damn. Thanks for confirming it though.

Thanks for your trouble.

So, i created a simple script

#!/bin/sh
sleep 2m && /usr/bin/pamac-tray-appindicator 

Yeah, i know is exaggerated 2 minutes, but it works. Placed it in
~/.config/autostart-scripts/pamactray.sh
made it executable and rebooted. The icon now looks fine.
But remember, i removed the /etc/xdg/autostart/pamac-tray-appindicator.desktop

2 Likes

Couldn't you just add the sleep 2m && to the Exec= line in that file instead?

1 Like

I was tired to keep give my password ... so i removed it and made tests with the script keep increasing the time. :sweat_smile:

Forum kindly sponsored by